summaryrefslogtreecommitdiff
path: root/app-misc/razertool
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/razertool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/razertool')
-rw-r--r--app-misc/razertool/Manifest1
-rw-r--r--app-misc/razertool/metadata.xml12
-rw-r--r--app-misc/razertool/razertool-0.0.7-r3.ebuild62
3 files changed, 75 insertions, 0 deletions
diff --git a/app-misc/razertool/Manifest b/app-misc/razertool/Manifest
new file mode 100644
index 00000000000..568021f938a
--- /dev/null
+++ b/app-misc/razertool/Manifest
@@ -0,0 +1 @@
+DIST razertool_0.0.7.orig.tar.gz 192274 SHA256 fd7026f6082b90306de3536f9395ae9407c282f2d60a32fd5406e358f48b977d SHA512 0221ec90b55f4459f5a772eb651e9807423d9e3c82ebd680ee835167bcebf2552e1d7767d294c5392b1fbc58558084e7022cb67f529c033eaff33b4fb3eb1017 WHIRLPOOL 19ce64cdc9d473066bfdc6a2ffe5f3a8096f8d1247ab447f50d41a505410765d4c9b56e5c14873af3735cf8fe9cfdd9a4cea8175f5b806ccc5c4739a6ebe3e69
diff --git a/app-misc/razertool/metadata.xml b/app-misc/razertool/metadata.xml
new file mode 100644
index 00000000000..42280e49bd3
--- /dev/null
+++ b/app-misc/razertool/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <longdescription>RazerTool is an unofficial tool for controlling Razer Copperhead(TM) mice in *nix. It has both command-line and gtk+-2.x versions. Allows to switch and alter profiles, upgrade firmware, ...</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">razertool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/razertool/razertool-0.0.7-r3.ebuild b/app-misc/razertool/razertool-0.0.7-r3.ebuild
new file mode 100644
index 00000000000..aac0ec26c5a
--- /dev/null
+++ b/app-misc/razertool/razertool-0.0.7-r3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Unofficial tool for controlling the Razer Copperhead mouse"
+HOMEPAGE="http://razertool.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+RDEPEND="virtual/libusb:0
+ gtk? (
+ >=gnome-base/librsvg-2.0
+ >=x11-libs/cairo-1.0.0
+ >=x11-libs/gtk+-2.8.0:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i razertool.rules.example \
+ -e 's:ACTION=="add", ::;s:BUS=:SUBSYSTEMS=:;s:SYSFS{:ATTRS{:g' \
+ || die "sed razertool.rules.example action failed"
+
+ # plugdev group may not exist (created by hal), default to usb
+ sed -i razertool.rules.example \
+ -e 's:plugdev:usb:' \
+ || die "sed razertool.rules.example plugdev failed"
+}
+
+src_configure() {
+ econf $(use_enable gtk)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ insinto /lib/udev/rules.d
+ newins razertool.rules.example 90-razertool.rules || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # Icon and desktop entry
+ dosym /usr/share/${PN}/pixmaps/${PN}-icon.png /usr/share/pixmaps/${PN}-icon.png
+ make_desktop_entry "razertool-gtk" "RazerTool" ${PN}-icon "GTK;Settings;HardwareSettings"
+}
+
+pkg_postinst() {
+ elog "Razer Copperhead mice need firmware version 6.20 or higher"
+ elog "to work properly. Running ${PN} on mice with older firmwares"
+ elog "might lead to random USB-disconnects."
+ elog "To run as non-root, add yourself to the usb group:"
+ elog " gpasswd -a <user> usb"
+ elog "or adapt permissions/owner/group in:"
+ elog " /etc/udev/rules.d/90-razertool.rules"
+ elog "Then unplug and plug in the mouse."
+}