summaryrefslogtreecommitdiff
path: root/app-misc/strigi
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/strigi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/strigi')
-rw-r--r--app-misc/strigi/Manifest1
-rw-r--r--app-misc/strigi/files/strigi-0.7.8-gcc-4.8.patch11
-rw-r--r--app-misc/strigi/files/strigi-0.7.8-libav10.patch16
-rw-r--r--app-misc/strigi/metadata.xml10
-rw-r--r--app-misc/strigi/strigi-0.7.8-r1.ebuild99
5 files changed, 137 insertions, 0 deletions
diff --git a/app-misc/strigi/Manifest b/app-misc/strigi/Manifest
new file mode 100644
index 00000000000..5aaea43c118
--- /dev/null
+++ b/app-misc/strigi/Manifest
@@ -0,0 +1 @@
+DIST strigi-0.7.8.tar.bz2 810574 SHA256 43e461a625acdefa59bf58cc9d10aebda9eba920dfbe800fc77e6dcbf1eff989 SHA512 536f5bd5ed13d87d30c2fa31b6dcb2a883df173e5d60deefe0fdeb843f40f29f7edd0041029dc013bb31a205572087ed95ca661bcdf6d989d9806931716b1043 WHIRLPOOL 6853025cee89811dadb6e7f6309a6a8dfec1863cb75ab8af04a9a21b228b74723de06c4f787342ce7a0d6087303ecc0c4f599c2a3978838675678343d0b84ae4
diff --git a/app-misc/strigi/files/strigi-0.7.8-gcc-4.8.patch b/app-misc/strigi/files/strigi-0.7.8-gcc-4.8.patch
new file mode 100644
index 00000000000..f525a71627a
--- /dev/null
+++ b/app-misc/strigi/files/strigi-0.7.8-gcc-4.8.patch
@@ -0,0 +1,11 @@
+--- libstreams/include/strigi/bufferedstream.h
++++ libstreams/include/strigi/bufferedstream.h
+@@ -34,7 +34,7 @@
+ * BufferedStream will do the rest.
+ */
+ template <class T>
+-class BufferedStream : public StreamBase<T> {
++class STREAMS_EXPORT BufferedStream : public StreamBase<T> {
+ private:
+ StreamBuffer<T> buffer;
+ bool finishedWritingToBuffer;
diff --git a/app-misc/strigi/files/strigi-0.7.8-libav10.patch b/app-misc/strigi/files/strigi-0.7.8-libav10.patch
new file mode 100644
index 00000000000..b38763ff29c
--- /dev/null
+++ b/app-misc/strigi/files/strigi-0.7.8-libav10.patch
@@ -0,0 +1,16 @@
+Index: strigi-0.7.8/libstreamanalyzer/plugins/endplugins/ffmpegendanalyzer.cpp
+===================================================================
+--- strigi-0.7.8.orig/libstreamanalyzer/plugins/endplugins/ffmpegendanalyzer.cpp 2013-02-05 21:34:52.000000000 +0000
++++ strigi-0.7.8/libstreamanalyzer/plugins/endplugins/ffmpegendanalyzer.cpp 2014-02-28 21:45:10.570587443 +0000
+@@ -481,9 +481,9 @@
+ outs << codec.height;
+ ar.addTriplet(streamuri, heightPropertyName, outs.str());
+ }
+- if (stream.r_frame_rate.num && stream.r_frame_rate.den) {
++ if (stream.avg_frame_rate.num && stream.avg_frame_rate.den) {
+ ostringstream outs;
+- outs << stream.r_frame_rate.num / stream.r_frame_rate.den;
++ outs << stream.avg_frame_rate.num / stream.avg_frame_rate.den;
+ ar.addTriplet(streamuri, frameRatePropertyName, outs.str());
+ }
+ if (codec.pix_fmt != PIX_FMT_NONE) {}//FIXME pixel format
diff --git a/app-misc/strigi/metadata.xml b/app-misc/strigi/metadata.xml
new file mode 100644
index 00000000000..ceb0f7756c4
--- /dev/null
+++ b/app-misc/strigi/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="clucene">Enable <pkg>dev-cpp/clucene</pkg> backend support.</flag>
+ <flag name="inotify">Enable support for inotify.</flag>
+ <flag name="log">Enables advanced logging through <pkg>dev-libs/log4cxx</pkg>.</flag>
+ </use>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/app-misc/strigi/strigi-0.7.8-r1.ebuild b/app-misc/strigi/strigi-0.7.8-r1.ebuild
new file mode 100644
index 00000000000..eb9271eaaa7
--- /dev/null
+++ b/app-misc/strigi/strigi-0.7.8-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ "${PV}" != "9999" ]]; then
+ SRC_URI="http://www.vandenoever.info/software/strigi/${P}.tar.bz2"
+ KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+else
+ EGIT_REPO_URI=( "git://anongit.kde.org/strigi" )
+ GIT_ECLASS="git-r3"
+ KEYWORDS=""
+fi
+
+inherit cmake-utils ${GIT_ECLASS}
+
+DESCRIPTION="Fast crawling desktop search engine with Qt4 GUI"
+HOMEPAGE="https://projects.kde.org/projects/kdesupport/strigi/strigi"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="clucene +dbus debug exif fam ffmpeg inotify libav log +qt4 test"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-libs/libxml2:2
+ sys-libs/zlib
+ virtual/libiconv
+ clucene? ( >=dev-cpp/clucene-0.9.21[-debug] )
+ dbus? (
+ sys-apps/dbus
+ qt4? ( dev-qt/qtdbus:4 )
+ )
+ exif? ( media-gfx/exiv2:= )
+ fam? ( virtual/fam )
+ ffmpeg? (
+ libav? ( media-video/libav:0= )
+ !libav? ( media-video/ffmpeg:0= )
+ )
+ log? ( >=dev-libs/log4cxx-0.10.0 )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc-4.8.patch"
+ "${FILESDIR}/${P}-libav10.patch"
+)
+
+if [[ ${PV} == 9999 ]] ; then
+ src_unpack() {
+ git config --global url."git://anongit.kde.org/".insteadOf "kde:" || die
+ git-r3_src_unpack
+ pushd "${S}" > /dev/null || die
+ git submodule foreach git checkout master || die
+ popd > /dev/null || die
+ }
+fi
+
+src_configure() {
+ # Enabled: POLLING (only reliable way to check for files changed.)
+ # Disabled: xine - recommended upstream to keep it this way
+ local mycmakeargs=(
+ -DENABLE_POLLING=ON
+ -DFORCE_DEPS=ON
+ -DENABLE_REGENERATEXSD=OFF
+ -DENABLE_XINE=OFF
+ $(cmake-utils_use_enable clucene CLUCENE)
+ $(cmake-utils_use_enable clucene CLUCENE_NG)
+ $(cmake-utils_use_enable dbus)
+ $(cmake-utils_use_enable exif EXIV2)
+ $(cmake-utils_use_enable fam)
+ $(cmake-utils_use_enable ffmpeg)
+ $(cmake-utils_use_enable inotify)
+ $(cmake-utils_use_enable log LOG4CXX)
+ $(cmake-utils_use_enable qt4)
+ $(cmake-utils_use_find_package test CPPUNIT)
+ )
+
+ if use qt4; then
+ mycmakeargs+=( -DENABLE_DBUS=ON )
+ fi
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if ! use clucene ; then
+ elog "Because you didn't enable the clucene backend, strigi may not be functional."
+ elog "If you intend to use standalone strigi indexer (not needed for KDE),"
+ elog "be sure to reinstall app-misc/strigi with the clucene USE flag enabled."
+ fi
+}