summaryrefslogtreecommitdiff
path: root/app-misc/uptimed
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/uptimed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/uptimed')
-rw-r--r--app-misc/uptimed/Manifest2
-rw-r--r--app-misc/uptimed/files/uptimed.init14
-rw-r--r--app-misc/uptimed/files/uptimed.service10
-rw-r--r--app-misc/uptimed/metadata.xml11
-rw-r--r--app-misc/uptimed/uptimed-0.3.18.ebuild53
-rw-r--r--app-misc/uptimed/uptimed-0.4.0.ebuild53
6 files changed, 143 insertions, 0 deletions
diff --git a/app-misc/uptimed/Manifest b/app-misc/uptimed/Manifest
new file mode 100644
index 00000000000..c97ec148503
--- /dev/null
+++ b/app-misc/uptimed/Manifest
@@ -0,0 +1,2 @@
+DIST uptimed-0.3.18.tar.gz 397295 SHA256 fe9c0c78c8fca1ef9b61474f2039dc3634f2caf1c547b7ddc7a4eaa31238b2c9 SHA512 6ccc9eebec2ed1b4dd0cc11590ba277c7ed453c244207772c26d147682627e47e7265e1b599ed505fb8aae8b013c61e77889e9d5ed638f994b579142b85fed1f WHIRLPOOL 848ff159267bb71fa5b8a63f55a954d21c125306d1defb60c807921130c820c8576a050326ba0fe718805f34b17c4092a01b534ffdc852599da47ced0a754b19
+DIST uptimed-0.4.0.tar.gz 55026 SHA256 26891965bb499065e34072cecd3eb8087102b1c05f530c8fe8504a07c722f9bf SHA512 918cd9e065d5005daf5062f14dffb725cb6d6764aa571fd45d63de3f7349b910cbae0dedc832f9bfb52a42caea90e8aec8390685baaf0718fec827240e517900 WHIRLPOOL 7611a0fda9c1f9f4bee30cb6f38c65dd93dfeb185335d34173f6abf4eb6e12747f27b0adb649a33807cda264671d98be0b3135b36abde111b7d30e06b885923f
diff --git a/app-misc/uptimed/files/uptimed.init b/app-misc/uptimed/files/uptimed.init
new file mode 100644
index 00000000000..45f8d39b734
--- /dev/null
+++ b/app-misc/uptimed/files/uptimed.init
@@ -0,0 +1,14 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+description="uptimed - a daemon to record uptime records"
+pidfile="/var/run/uptimed/uptimed.pid"
+command="/usr/sbin/uptimed"
+command_args="-p ${pidfile}"
+start_stop_daemon_args="-u uptimed"
+
+start_pre() {
+ checkpath -q -d -o uptimed ${pidfile%/*}
+}
diff --git a/app-misc/uptimed/files/uptimed.service b/app-misc/uptimed/files/uptimed.service
new file mode 100644
index 00000000000..531c4157021
--- /dev/null
+++ b/app-misc/uptimed/files/uptimed.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Uptime record tracking daemon
+Documentation=man:uptimed(8) man:uprecords(1)
+
+[Service]
+ExecStartPre=/usr/sbin/uptimed -b
+ExecStart=/usr/sbin/uptimed -f
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-misc/uptimed/metadata.xml b/app-misc/uptimed/metadata.xml
new file mode 100644
index 00000000000..982f54ca71c
--- /dev/null
+++ b/app-misc/uptimed/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rpodgorny/uptimed</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/uptimed/uptimed-0.3.18.ebuild b/app-misc/uptimed/uptimed-0.3.18.ebuild
new file mode 100644
index 00000000000..4d744d8eefe
--- /dev/null
+++ b/app-misc/uptimed/uptimed-0.3.18.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils user systemd
+
+DESCRIPTION="System uptime record daemon that keeps track of your highest uptimes"
+HOMEPAGE="https://github.com/rpodgorny/uptimed/"
+SRC_URI="https://github.com/rpodgorny/uptimed/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="static-libs"
+
+pkg_setup() {
+ enewgroup uptimed
+ enewuser uptimed -1 -1 -1 uptimed
+}
+
+src_prepare() {
+ # respect DESTDIR
+ sed -i -e 's|-d \(/var/spool.*\)$|-d $(DESTDIR)\1|' Makefile.am || die
+ # fix configure.ac for >=automake-1.13 (bug #467582)
+ sed 's@AM_CONFIG_HEADER@AC_CONFIG_HEADERS@' -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+ keepdir /var/spool/uptimed
+ fowners uptimed:uptimed /var/spool/uptimed
+ dodoc ChangeLog README TODO AUTHORS CREDITS INSTALL.cgi sample-cgi/*
+ newinitd "${FILESDIR}"/uptimed.init uptimed
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}
+
+pkg_postinst() {
+ einfo "Fixing permissions in /var/spool/${PN}"
+ chown -R uptimed:uptimed /var/spool/${PN}
+ echo
+ elog "Start uptimed with '/etc/init.d/uptimed start' (for openRC)"
+ elog "or systemctl start uptimed (for systemd)"
+ elog "To view your uptime records, use the command 'uprecords'."
+ echo
+}
diff --git a/app-misc/uptimed/uptimed-0.4.0.ebuild b/app-misc/uptimed/uptimed-0.4.0.ebuild
new file mode 100644
index 00000000000..50530a0cea3
--- /dev/null
+++ b/app-misc/uptimed/uptimed-0.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils user systemd
+
+DESCRIPTION="System uptime record daemon that keeps track of your highest uptimes"
+HOMEPAGE="https://github.com/rpodgorny/uptimed/"
+SRC_URI="https://github.com/rpodgorny/uptimed/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="static-libs"
+
+pkg_setup() {
+ enewgroup uptimed
+ enewuser uptimed -1 -1 -1 uptimed
+}
+
+src_prepare() {
+ # respect DESTDIR
+ sed -i -e 's|-d \(/var/spool.*\)$|-d $(DESTDIR)\1|' Makefile.am || die
+ # fix configure.ac for >=automake-1.13 (bug #467582)
+ sed 's@AM_CONFIG_HEADER@AC_CONFIG_HEADERS@' -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+ keepdir /var/spool/uptimed
+ fowners uptimed:uptimed /var/spool/uptimed
+ dodoc ChangeLog README.md TODO AUTHORS CREDITS INSTALL.cgi sample-cgi/*
+ newinitd "${FILESDIR}"/${PN}.init uptimed
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}
+
+pkg_postinst() {
+ einfo "Fixing permissions in /var/spool/${PN}"
+ chown -R uptimed:uptimed /var/spool/${PN}
+ echo
+ elog "Start uptimed with '/etc/init.d/uptimed start' (for openRC)"
+ elog "or systemctl start uptimed (for systemd)"
+ elog "To view your uptime records, use the command 'uprecords'."
+ echo
+}