summaryrefslogtreecommitdiff
path: root/app-misc/yagtd
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/yagtd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/yagtd')
-rw-r--r--app-misc/yagtd/Manifest1
-rw-r--r--app-misc/yagtd/metadata.xml16
-rw-r--r--app-misc/yagtd/yagtd-0.3.4-r1.ebuild35
-rw-r--r--app-misc/yagtd/yagtd-0.3.4.ebuild31
4 files changed, 83 insertions, 0 deletions
diff --git a/app-misc/yagtd/Manifest b/app-misc/yagtd/Manifest
new file mode 100644
index 00000000000..2faf3dffe5b
--- /dev/null
+++ b/app-misc/yagtd/Manifest
@@ -0,0 +1 @@
+DIST yagtd-0.3.4.tar.gz 1402287 SHA256 777b3e56b5a6449383c5a86f8dfc41664eeda046c75fefa2b49b8d87028db7fa SHA512 99f8dd5344615285a09e039f9c829fdcb09305baa1beaef03710fb5661ba5dde53491264142e9ed2c207e89e06855cbd64621e447468aa033e9f972b896385a8 WHIRLPOOL 209554eaa13538bce5b4112267ece4e1250efaaff56697f324b97382386884a7c3143da798b3c003766e4b66aa8a9a0ab5d804f5f4212018c2f31602b3ba4472
diff --git a/app-misc/yagtd/metadata.xml b/app-misc/yagtd/metadata.xml
new file mode 100644
index 00000000000..81adea60373
--- /dev/null
+++ b/app-misc/yagtd/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+yaGTD incorporates major features from Allen's 'Getting Things Done' philosophy and
+notion of urgency and importance preached by Stephen Covey
+(cf Seven Habits of Highly Effective People book).
+To resume, if you are comfortable at the command line a simple plain text is an
+age-old but perfect method for tracking your stuff, and yaGTD can help you to
+manage efficiently this file.
+</longdescription>
+</pkgmetadata>
+
diff --git a/app-misc/yagtd/yagtd-0.3.4-r1.ebuild b/app-misc/yagtd/yagtd-0.3.4-r1.ebuild
new file mode 100644
index 00000000000..dab244bd605
--- /dev/null
+++ b/app-misc/yagtd/yagtd-0.3.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="CLI todo list manager based on the 'Getting Things Done' philosophy"
+HOMEPAGE="https://gna.org/projects/yagtd/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ #fix doc install location
+ sed -i -e "s:\/doc\/yagtd:\/doc\/${P}:g" setup.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_install() {
+ distutils-r1_python_install
+ ln -s yagtd.py "${D}$(python_get_scriptdir)"/yagtd || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ dosym yagtd.py /usr/bin/yagtd
+}
diff --git a/app-misc/yagtd/yagtd-0.3.4.ebuild b/app-misc/yagtd/yagtd-0.3.4.ebuild
new file mode 100644
index 00000000000..d31f2f750c1
--- /dev/null
+++ b/app-misc/yagtd/yagtd-0.3.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="CLI todo list manager based on the 'Getting Things Done' philosophy"
+HOMEPAGE="https://gna.org/projects/yagtd/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+PYTHON_MODNAME="gtd.py yagtd.py"
+
+src_prepare() {
+ #fix doc install location
+ sed -i -e "s:\/doc\/yagtd:\/doc\/${P}:g" setup.py || die
+}
+
+src_install() {
+ distutils_src_install
+ dosym /usr/bin/yagtd.py /usr/bin/yagtd
+}