summaryrefslogtreecommitdiff
path: root/app-misc
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-14 17:56:22 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-14 19:37:42 +0100
commitaa89b97f4188d12c712d5cfc4e4df0e6a3bd3e2f (patch)
treeaae347592d658ac62d3837883e04001d6b2cb789 /app-misc
parentf58f85efe42cca5bceeac13515a845e00e7c7a56 (diff)
downloadgentoo-aa89b97f4188d12c712d5cfc4e4df0e6a3bd3e2f.tar.gz
gentoo-aa89b97f4188d12c712d5cfc4e4df0e6a3bd3e2f.tar.xz
app-misc/gnote: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gnote/Manifest1
-rw-r--r--app-misc/gnote/gnote-3.18.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index 191627daaa0..3604007de7c 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -2,3 +2,4 @@ DIST boost.m4-32553aaf4d5090da19aa0ec33b936982c685009f.zip 48610 SHA256 c7125b53
DIST gnote-3.14.2.tar.xz 3146108 SHA256 4d01745cab0a01c6b4a921c376c11f1dcb40bf3e635fb88739afb05994a89c22 SHA512 100c86330876507e784300407c9b66de0ee709c0a0368a51c6823e37bc97d8891b52630c1e33fcb09c6d3f7dedbfa5c323cb8326476b0cef2bdfc6dfc88ba2a0 WHIRLPOOL 5b965f8c45814504e8b679f6f4eabfc1907af2cc30c5c45b36efa9fa19bbd57e65739b356f2ea934d6a5c260b0ee301007ed11edc31a73d5921aeb93d1717ca9
DIST gnote-3.16.1.tar.xz 3059032 SHA256 8360a8ddfbc1cddd8970a29c66965f2de4d1330145f7cc7d47831205e2b10087 SHA512 33a5485343e08ab9adbd36aacc63f779991759d753e7c3132b14465b128596b77a2ba6517eaec188dd042b89c38100bf83ddd772f0cf0bf338f9ec41139e68be WHIRLPOOL 60dd34fed6a611c4484d39eab945e8806421f6df7f269dca928f4a84a7442d249faa2677877067cb657d79b37b267dd0ca42d7a25d3d2b54f24fa9f87d56423d
DIST gnote-3.16.2.tar.xz 3068136 SHA256 5c5b55b5c548d15e344d59fdd2a0260b1acbd13a9fa4cf9bfc1fe6e68a041e07 SHA512 b9d405ad8392d526fcb4098952c6531ba99b1a9b74a1bb857886b3017b676938e001ea7332bd189d5bdbbf554b40bcff57c995d6391135d4176ba00529d4b130 WHIRLPOOL c6d94674093eb1883b87c5da9d302c99f73fd32e51d728b406d2f8f8a40cc8eac85e6be39f5d0ad38d5f492699c1d97a7e642dc31df791cde16b09957d98f418
+DIST gnote-3.18.0.tar.xz 3300404 SHA256 4828363ae3ddac57d37a0a2b17882be8fe67afcecf97ae992cd744b95da1c348 SHA512 76802759353a11278e4f47a14dc62d3d3bcec61a0a05619cc151bde1969a4675aba26f04b77406dd5f9074b292ec9b8c1288e4e00cb1577141d7bd605416acc0 WHIRLPOOL d2a55d3de08f460edaf8f8c8446766fccbe0c6aff43e82532b00b8e0af8932cdbfda573392e28cc9d9ee47ac8959cc8b23f98a2b3273761ec431dfdd9017f0f0
diff --git a/app-misc/gnote/gnote-3.18.0.ebuild b/app-misc/gnote/gnote-3.18.0.ebuild
new file mode 100644
index 00000000000..a040b8f2bf3
--- /dev/null
+++ b/app-misc/gnote/gnote-3.18.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 readme.gentoo
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug X"
+
+# Automagic glib-2.32 dep
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gtkspell-3.0:3
+ >=dev-cpp/glibmm-2.32:2
+ >=dev-cpp/gtkmm-3.10:3.0
+ >=dev-libs/boost-1.34
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.10:3
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.35.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+ gnome2_src_prepare
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_with X x11-support)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}