summaryrefslogtreecommitdiff
path: root/app-mobilephone/ringtonetools
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/ringtonetools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/ringtonetools')
-rw-r--r--app-mobilephone/ringtonetools/Manifest1
-rw-r--r--app-mobilephone/ringtonetools/files/ringtonetools-2.26-no-strip.patch11
-rw-r--r--app-mobilephone/ringtonetools/metadata.xml6
-rw-r--r--app-mobilephone/ringtonetools/ringtonetools-2.26.ebuild31
4 files changed, 49 insertions, 0 deletions
diff --git a/app-mobilephone/ringtonetools/Manifest b/app-mobilephone/ringtonetools/Manifest
new file mode 100644
index 00000000000..23b8d4e5184
--- /dev/null
+++ b/app-mobilephone/ringtonetools/Manifest
@@ -0,0 +1 @@
+DIST ringtonetools-2.26.tar.gz 40172 SHA256 609081b7ef41addd0250af38ef0391ec0b696e8a1821a3817113acd80b6b88a1 SHA512 aa352a8a9e6d84bb649d559e1026239fb7129636bfe6369d90b1e47ceedc530703144a549e0ec0aed1c89d39727c6d604aca31c2255bf3a5c0fb88502f8b31a4 WHIRLPOOL e773c454438267af4bf671d96b574c9e62ea7de83804fe3fc7987f9fed4ced7993a8c7edd4bd1026345c367152b2bd33dbcac8eb59bce843a73030a92a035f6f
diff --git a/app-mobilephone/ringtonetools/files/ringtonetools-2.26-no-strip.patch b/app-mobilephone/ringtonetools/files/ringtonetools-2.26-no-strip.patch
new file mode 100644
index 00000000000..5438f444248
--- /dev/null
+++ b/app-mobilephone/ringtonetools/files/ringtonetools-2.26-no-strip.patch
@@ -0,0 +1,11 @@
+diff -Nru ringtonetools-2.26.orig/Makefile ringtonetools-2.26/Makefile
+--- ringtonetools-2.26.orig/Makefile 2005-08-01 20:42:00.000000000 +0300
++++ ringtonetools-2.26/Makefile 2006-09-24 13:01:32.252022000 +0300
+@@ -3,7 +3,6 @@
+ @cd src && make
+ @if [ -e src/ringtonetools.exe ]; then mv src/ringtonetools.exe ringtonetools.exe; fi
+ @if [ -e src/ringtonetools ]; then mv src/ringtonetools .; fi
+- @strip ringtonetools*
+
+
+ clean:
diff --git a/app-mobilephone/ringtonetools/metadata.xml b/app-mobilephone/ringtonetools/metadata.xml
new file mode 100644
index 00000000000..5656ad343ee
--- /dev/null
+++ b/app-mobilephone/ringtonetools/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <longdescription>Ringtone Tools is a program for creating custom ringtones and graphical logos for mobile phones.</longdescription>
+</pkgmetadata>
diff --git a/app-mobilephone/ringtonetools/ringtonetools-2.26.ebuild b/app-mobilephone/ringtonetools/ringtonetools-2.26.ebuild
new file mode 100644
index 00000000000..4de86e9a3bb
--- /dev/null
+++ b/app-mobilephone/ringtonetools/ringtonetools-2.26.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="program for creating ringtones and logos for mobile phones"
+HOMEPAGE="http://ringtonetools.mikekohn.net/"
+SRC_URI="http://downloads.mikekohn.net/ringtonetools/${P}.tar.gz"
+
+LICENSE="ringtonetools"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-no-strip.patch"
+}
+
+src_compile() {
+ emake -j1 FLAGS="${CFLAGS}" LIBS="${LDFLAGS}" CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ dobin ringtonetools || die "program not found"
+ dodoc docs/*
+ docinto samples
+ dodoc samples/*
+}