summaryrefslogtreecommitdiff
path: root/app-office/gtimelog
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/gtimelog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/gtimelog')
-rw-r--r--app-office/gtimelog/Manifest2
-rw-r--r--app-office/gtimelog/gtimelog-0.8.0.ebuild67
-rw-r--r--app-office/gtimelog/gtimelog-0.8.1.ebuild69
-rw-r--r--app-office/gtimelog/metadata.xml8
4 files changed, 146 insertions, 0 deletions
diff --git a/app-office/gtimelog/Manifest b/app-office/gtimelog/Manifest
new file mode 100644
index 00000000000..151913e6f3f
--- /dev/null
+++ b/app-office/gtimelog/Manifest
@@ -0,0 +1,2 @@
+DIST gtimelog-0.8.0.tar.gz 187323 SHA256 2b061348ecb77fd974692251f7fe8e946a66955a37ce932de305adbdb8ce794d SHA512 079ee86dbd19c661c6b70dd3cb434cf79d4eb9127cbe325273284e773aeb5eb77441a85a926fd5f39018438c1f24d44acd0933b473f9af5b2d01f8771e68495a WHIRLPOOL e19f33d7e87ae8c9791370d9b5aee0fc1124a82515df01606ef197b1da287cc872ff5324f7598d1c7b9623df8c308158aff398436ba2979a3920fbc5ff761620
+DIST gtimelog-0.8.1.tar.gz 188353 SHA256 c61fb5aff929362b41ec2808b4cdf1fa55e38065f1adf45c2c8eea9a095f1a04 SHA512 bec4e3182d08be1a75da79f30b58b76e77e1b678477b33edeba529fdf15d8f61d9913c0f43d7ed46cf39b571ab481a8620c5f20b60fb251e16f530aa6465ce98 WHIRLPOOL 74b70aec9872db92480147f6a31e6b618332eb1a56f028088990d23325df406f41dd609f235e44e338b2b9f6040fea146109cfd468eeeddd75835d3b34d89931
diff --git a/app-office/gtimelog/gtimelog-0.8.0.ebuild b/app-office/gtimelog/gtimelog-0.8.0.ebuild
new file mode 100644
index 00000000000..db32c90863a
--- /dev/null
+++ b/app-office/gtimelog/gtimelog-0.8.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit eutils distutils virtualx
+
+DESCRIPTION="A small Gtk+ application for keeping track of your time"
+HOMEPAGE="http://mg.pov.lt/gtimelog/"
+LICENSE="GPL-2"
+SLOT="0"
+
+SRC_URI="https://launchpad.net/gtimelog/devel/${PV}/+download/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+
+IUSE="ayatana test"
+
+# gnome-base/gnome-desktop provides gnome-week.png
+RDEPEND="dev-libs/gobject-introspection
+ dev-python/dbus-python
+ dev-python/pygobject:3
+ gnome-base/gnome-desktop:2
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+
+ ayatana? ( dev-libs/libappindicator:3[introspection] )"
+DEPEND="test? (
+ ${RDEPEND}
+ ayatana? ( dev-libs/libappindicator:3[introspection] ) )"
+
+DISTUTILS_SRC_TEST="setup.py"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+
+ DOCS="HACKING.txt NEWS.txt NOTES.txt README.txt"
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+ # Support prefixed installation
+ sed -e "s:\"/usr:\"${EPREFIX}/usr:g" \
+ -i src/gtimelog/main.py || die "sed failed"
+ distutils_src_prepare
+}
+
+src_test() {
+ VIRTUALX_COMMAND=distutils_src_test virtualmake
+}
+
+src_install() {
+ domenu gtimelog.desktop
+ doicon src/gtimelog/gtimelog-*.png
+ insinto /usr/share/gtimelog
+ doins src/gtimelog/*.ui src/gtimelog/gtimelog.png
+ exeinto /usr/share/gtimelog/scripts
+ doexe scripts/*.py
+
+ distutils_src_install
+
+ # Don't install icons in /usr/lib/python*
+ find "${ED}/$(python_get_sitedir)" -regex '.*\(png\|ui\)$' -exec rm -f {} + || die
+}
diff --git a/app-office/gtimelog/gtimelog-0.8.1.ebuild b/app-office/gtimelog/gtimelog-0.8.1.ebuild
new file mode 100644
index 00000000000..be47f0e08e9
--- /dev/null
+++ b/app-office/gtimelog/gtimelog-0.8.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_IN_SOURCE_BUILD=true
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A small Gtk+ application for keeping track of your time"
+HOMEPAGE="http://mg.pov.lt/gtimelog/"
+LICENSE="GPL-2"
+SLOT="0"
+
+SRC_URI="https://launchpad.net/gtimelog/devel/${PV}/+download/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+
+IUSE="ayatana test"
+
+# gnome-base/gnome-desktop provides gnome-week.png
+RDEPEND="
+ dev-libs/gobject-introspection
+ dev-python/dbus-python
+ dev-python/pygobject:3
+ gnome-base/gnome-desktop:2
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ ayatana? ( dev-libs/libappindicator:3[introspection] )
+"
+DEPEND="test? (
+ ${RDEPEND}
+ ayatana? ( dev-libs/libappindicator:3[introspection] ) )
+"
+
+DOCS="HACKING.txt NEWS.txt NOTES.txt README.txt"
+
+src_prepare() {
+ # Support prefixed installation
+ sed -e "s:\"/usr:\"${EPREFIX}/usr:g" \
+ -i src/gtimelog/main.py || die "sed failed"
+
+ sed -i -e 's/python2.3/python/' scripts/export-my-calendar.py || die
+
+ sed -i -e 's/Application;//' gtimelog.desktop || die #462958
+
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ VIRTUALX_COMMAND=distutils-r1_src_test virtualmake
+}
+
+src_install() {
+ domenu gtimelog.desktop
+ doicon src/gtimelog/gtimelog-*.png
+ insinto /usr/share/gtimelog
+ doins src/gtimelog/*.ui src/gtimelog/gtimelog.png
+ exeinto /usr/share/gtimelog/scripts
+ doexe scripts/*.py
+
+ distutils-r1_src_install
+ python_fix_shebang "${ED}"
+
+ # Don't install icons in /usr/lib/python*
+ find "${ED}/$(python_get_sitedir)" -regex '.*\(png\|ui\)$' -exec rm -f {} + || die
+}
diff --git a/app-office/gtimelog/metadata.xml b/app-office/gtimelog/metadata.xml
new file mode 100644
index 00000000000..9ffd1e3ec8f
--- /dev/null
+++ b/app-office/gtimelog/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <upstream>
+ <remote-id type="launchpad">gtimelog</remote-id>
+ </upstream>
+</pkgmetadata>