summaryrefslogtreecommitdiff
path: root/app-office/pinpoint
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/pinpoint
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/pinpoint')
-rw-r--r--app-office/pinpoint/Manifest1
-rw-r--r--app-office/pinpoint/metadata.xml11
-rw-r--r--app-office/pinpoint/pinpoint-0.1.5_pre20141026.ebuild57
3 files changed, 69 insertions, 0 deletions
diff --git a/app-office/pinpoint/Manifest b/app-office/pinpoint/Manifest
new file mode 100644
index 00000000000..8a8d57ada89
--- /dev/null
+++ b/app-office/pinpoint/Manifest
@@ -0,0 +1 @@
+DIST pinpoint-215ccad331a39c6e95d173938fcfffe6eb4d75d6.tar.xz 708020 SHA256 1303581f09ff6414269fe0642f7ce51094ebc5cee5101ef5b3113054da0bc8e9 SHA512 efbc711e034a968b104cca669fedaae8c1f088f598996843a65849f632ebdbff3df8d36225852b24327c26e2b972b1c5097775531b23ebc3eedf62415346f27e WHIRLPOOL 1c80ee81257c42b10ab860eabd4a95c61a9980b80cfb901ce167e70cf0046586b74e3670bffdb4342adfd378fb02c97ecfb1f4ae59d3e0ce09b205f9ef1e7ebd
diff --git a/app-office/pinpoint/metadata.xml b/app-office/pinpoint/metadata.xml
new file mode 100644
index 00000000000..ee0a2f23ae6
--- /dev/null
+++ b/app-office/pinpoint/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+ <longdescription lang="en">
+ Pinpoint is a simple presentation tool that hopes to avoid audience
+ death by bullet point and instead encourage presentations containing
+ beautiful images and small amounts of concise text in slides.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/app-office/pinpoint/pinpoint-0.1.5_pre20141026.ebuild b/app-office/pinpoint/pinpoint-0.1.5_pre20141026.ebuild
new file mode 100644
index 00000000000..8ef69a3bd28
--- /dev/null
+++ b/app-office/pinpoint/pinpoint-0.1.5_pre20141026.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit autotools gnome2
+
+DESCRIPTION="A tool for making hackers do excellent presentations"
+HOMEPAGE="https://wiki.gnome.org/Apps/Pinpoint"
+
+MY_PV="215ccad331a39c6e95d173938fcfffe6eb4d75d6" #snapshot
+SRC_URI="https://git.gnome.org/browse/${PN}/snapshot/${PN}-${MY_PV}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+gstreamer +pdf"
+
+# rsvg is used for svg-in-pdf -- clubbing it under pdf for now
+RDEPEND="
+ >=media-libs/clutter-1.12:1.0
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/cairo-1.9.4
+ x11-libs/pango
+ x11-libs/gdk-pixbuf:2
+ gstreamer? ( media-libs/clutter-gst:2.0 )
+ pdf? ( gnome-base/librsvg:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # dax support is disabled because we don't have it in tree yet and it's
+ # experimental
+ gnome2_src_configure \
+ --disable-dax \
+ $(use_enable gstreamer cluttergst) \
+ $(use_enable pdf rsvg)
+}
+
+src_install() {
+ gnome2_src_install
+
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto "/usr/share/doc/${PF}/examples"
+ doins introduction.pin bg.jpg bowls.jpg linus.jpg
+}