summaryrefslogtreecommitdiff
path: root/app-office
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-29 16:58:24 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-29 16:58:24 +0200
commitb20d064bc910e4365155da6a4b925902906dba38 (patch)
treefc605aefb0f93095704adcdbee21b32c8748bed0 /app-office
parentedeac4ba55d457447e69212fd005d1275f222a03 (diff)
downloadgentoo-b20d064bc910e4365155da6a4b925902906dba38.tar.gz
gentoo-b20d064bc910e4365155da6a4b925902906dba38.tar.xz
app-office/libreoffice: Re-shuffle disable-flaky-tests
Closes: https://bugs.gentoo.org/656846 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-1.patch (renamed from app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests.patch)37
-rw-r--r--app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-2.patch37
-rw-r--r--app-office/libreoffice/libreoffice-6.0.3.2.ebuild2
-rw-r--r--app-office/libreoffice/libreoffice-6.0.4.2.ebuild2
-rw-r--r--app-office/libreoffice/libreoffice-6.0.9999.ebuild2
5 files changed, 40 insertions, 40 deletions
diff --git a/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests.patch b/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-1.patch
index b25e4fc3ae5..03421c5e12b 100644
--- a/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests.patch
+++ b/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-1.patch
@@ -214,40 +214,3 @@ index 4d65beeb90c4..f3d71501c41a 100644
DECLARE_OOXMLIMPORT_TEST(testTdf113946, "tdf113946.docx")
{
---- a/xmlsecurity/qa/unit/signing/signing.cxx 2018-01-27 18:21:08.228434985 +0100
-+++ b/xmlsecurity/qa/unit/signing/signing.cxx 2018-01-27 18:21:37.428824309 +0100
-@@ -114,7 +114,7 @@
- /// Test a typical broken ODF signature where the XML dsig hash is corrupted.
- void testODFBrokenDsigGPG();
- /// Test loading an encrypted ODF document
-- void testODFEncryptedGPG();
-+// void testODFEncryptedGPG();
- #endif
- CPPUNIT_TEST_SUITE(SigningTest);
- CPPUNIT_TEST(testDescription);
-@@ -143,7 +143,7 @@
- CPPUNIT_TEST(testODFUntrustedGoodGPG);
- CPPUNIT_TEST(testODFBrokenStreamGPG);
- CPPUNIT_TEST(testODFBrokenDsigGPG);
-- CPPUNIT_TEST(testODFEncryptedGPG);
-+// CPPUNIT_TEST(testODFEncryptedGPG);
- #endif
- CPPUNIT_TEST_SUITE_END();
-
-@@ -743,14 +743,14 @@
- CPPUNIT_ASSERT_EQUAL(static_cast<int>(SignatureState::BROKEN), static_cast<int>(pObjectShell->GetDocumentSignatureState()));
- }
-
--void SigningTest::testODFEncryptedGPG()
-+/*void SigningTest::testODFEncryptedGPG()
- {
- createDoc(m_directories.getURLFromSrc(DATA_DIRECTORY) + "encryptedGPG.odt");
- SfxBaseModel* pBaseModel = dynamic_cast<SfxBaseModel*>(mxComponent.get());
- CPPUNIT_ASSERT(pBaseModel);
- SfxObjectShell* pObjectShell = pBaseModel->GetObjectShell();
- CPPUNIT_ASSERT(pObjectShell);
--}
-+}*/
-
- #endif
-
diff --git a/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-2.patch b/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-2.patch
new file mode 100644
index 00000000000..55f2d8a55fc
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-2.patch
@@ -0,0 +1,37 @@
+--- a/xmlsecurity/qa/unit/signing/signing.cxx 2018-01-27 18:21:08.228434985 +0100
++++ b/xmlsecurity/qa/unit/signing/signing.cxx 2018-01-27 18:21:37.428824309 +0100
+@@ -114,7 +114,7 @@
+ /// Test a typical broken ODF signature where the XML dsig hash is corrupted.
+ void testODFBrokenDsigGPG();
+ /// Test loading an encrypted ODF document
+- void testODFEncryptedGPG();
++// void testODFEncryptedGPG();
+ #endif
+ CPPUNIT_TEST_SUITE(SigningTest);
+ CPPUNIT_TEST(testDescription);
+@@ -143,7 +143,7 @@
+ CPPUNIT_TEST(testODFUntrustedGoodGPG);
+ CPPUNIT_TEST(testODFBrokenStreamGPG);
+ CPPUNIT_TEST(testODFBrokenDsigGPG);
+- CPPUNIT_TEST(testODFEncryptedGPG);
++// CPPUNIT_TEST(testODFEncryptedGPG);
+ #endif
+ CPPUNIT_TEST_SUITE_END();
+
+@@ -743,14 +743,14 @@
+ CPPUNIT_ASSERT_EQUAL(static_cast<int>(SignatureState::BROKEN), static_cast<int>(pObjectShell->GetDocumentSignatureState()));
+ }
+
+-void SigningTest::testODFEncryptedGPG()
++/*void SigningTest::testODFEncryptedGPG()
+ {
+ createDoc(m_directories.getURLFromSrc(DATA_DIRECTORY) + "encryptedGPG.odt");
+ SfxBaseModel* pBaseModel = dynamic_cast<SfxBaseModel*>(mxComponent.get());
+ CPPUNIT_ASSERT(pBaseModel);
+ SfxObjectShell* pObjectShell = pBaseModel->GetObjectShell();
+ CPPUNIT_ASSERT(pObjectShell);
+-}
++}*/
+
+ #endif
+
diff --git a/app-office/libreoffice/libreoffice-6.0.3.2.ebuild b/app-office/libreoffice/libreoffice-6.0.3.2.ebuild
index a7d6373ce84..837b49a029d 100644
--- a/app-office/libreoffice/libreoffice-6.0.3.2.ebuild
+++ b/app-office/libreoffice/libreoffice-6.0.3.2.ebuild
@@ -245,7 +245,7 @@ PATCHES=(
# not upstreamable stuff
"${FILESDIR}/${PN}-5.4-system-pyuno.patch"
"${FILESDIR}/${PN}-5.3.4.2-kioclient5.patch"
- "${FILESDIR}/${PN}-6.0.3.2-disable-flaky-tests.patch" #bug 656676
+ "${FILESDIR}"/${PN}-6.0.3.2-disable-flaky-tests-{1,2}.patch #bug 656676
# 6.0 branch
"${FILESDIR}/${P}-poppler-0.64.patch"
diff --git a/app-office/libreoffice/libreoffice-6.0.4.2.ebuild b/app-office/libreoffice/libreoffice-6.0.4.2.ebuild
index 433d077bc2c..a7f087f49e2 100644
--- a/app-office/libreoffice/libreoffice-6.0.4.2.ebuild
+++ b/app-office/libreoffice/libreoffice-6.0.4.2.ebuild
@@ -246,7 +246,7 @@ PATCHES=(
# not upstreamable stuff
"${FILESDIR}/${PN}-5.4-system-pyuno.patch"
"${FILESDIR}/${PN}-5.3.4.2-kioclient5.patch"
- "${FILESDIR}/${PN}-6.0.3.2-disable-flaky-tests.patch" #bug 656676
+ "${FILESDIR}/${PN}-6.0.3.2-disable-flaky-tests-1.patch" #bug 656676
# TODO: upstream
"${FILESDIR}/${PN}-5.2.5.1-glibc-2.24.patch"
diff --git a/app-office/libreoffice/libreoffice-6.0.9999.ebuild b/app-office/libreoffice/libreoffice-6.0.9999.ebuild
index 433d077bc2c..a7f087f49e2 100644
--- a/app-office/libreoffice/libreoffice-6.0.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.0.9999.ebuild
@@ -246,7 +246,7 @@ PATCHES=(
# not upstreamable stuff
"${FILESDIR}/${PN}-5.4-system-pyuno.patch"
"${FILESDIR}/${PN}-5.3.4.2-kioclient5.patch"
- "${FILESDIR}/${PN}-6.0.3.2-disable-flaky-tests.patch" #bug 656676
+ "${FILESDIR}/${PN}-6.0.3.2-disable-flaky-tests-1.patch" #bug 656676
# TODO: upstream
"${FILESDIR}/${PN}-5.2.5.1-glibc-2.24.patch"