summaryrefslogtreecommitdiff
path: root/app-office
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-10 10:30:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-10 10:58:36 +0200
commitc3bba70d6c0670228fd4da49e64fbbd17aa1a0aa (patch)
tree117f8dc34f94e991af22f0d5298d700b1a539d52 /app-office
parentc4231e07617594a86eeaa250956e5e1a763e02a7 (diff)
downloadgentoo-c3bba70d6c0670228fd4da49e64fbbd17aa1a0aa.tar.gz
gentoo-c3bba70d6c0670228fd4da49e64fbbd17aa1a0aa.tar.xz
app-office/libreoffice: Fix configure with >=media-libs/glm-0.9.9
Bug: https://bugs.gentoo.org/657178 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/files/libreoffice-5.4.7.2-glm-0.9.9.patch82
-rw-r--r--app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch19
-rw-r--r--app-office/libreoffice/libreoffice-5.4.7.2.ebuild2
-rw-r--r--app-office/libreoffice/libreoffice-6.0.4.2.ebuild1
4 files changed, 104 insertions, 0 deletions
diff --git a/app-office/libreoffice/files/libreoffice-5.4.7.2-glm-0.9.9.patch b/app-office/libreoffice/files/libreoffice-5.4.7.2-glm-0.9.9.patch
new file mode 100644
index 00000000000..28982d90c36
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-5.4.7.2-glm-0.9.9.patch
@@ -0,0 +1,82 @@
+From 7984347b9a2fce74cdce0c1c5b27f6e2b55a2f49 Mon Sep 17 00:00:00 2001
+From: Rene Engelhard <rene@debian.org>
+Date: Sun, 28 Jan 2018 19:48:25 +0100
+Subject: fix build with glm 0.9.9
+
+In file included from /usr/include/glm/gtx/norm.hpp:18:0,
+ from /data/rene/git/LibreOffice/master/vcl/inc/opengl/VertexUti
+ls.hxx:16,
+ from /data/rene/git/LibreOffice/master/vcl/inc/opengl/LineRende
+rUtils.hxx:14,
+ from /data/rene/git/LibreOffice/master/vcl/opengl/LineRenderUti
+ls.cxx:11:
+/usr/include/glm/gtx/quaternion.hpp:23:3: error: #error "GLM: GLM_GTX_quaternion
+ is an experimental extension and may change in the future. Use #define GLM_ENABLE_EXPERIMENTAL before including it, if you really want to use it."
+ # error "GLM: GLM_GTX_quaternion is an experimental extension and may change in the future. Use #define GLM_ENABLE_EXPERIMENTAL before including it, if you really want to use it."
+ ^~~~~
+
+so just define it.
+
+Change-Id: I981bfb5fd944f32a3774b3f9b183989773bf235f
+Reviewed-on: https://gerrit.libreoffice.org/48799
+Tested-by: Jenkins <ci@libreoffice.org>
+Tested-by: Rene Engelhard <rene@debian.org>
+Reviewed-by: Rene Engelhard <rene@debian.org>
+---
+ chart2/Library_chartcore.mk | 6 ++++++
+ chart2/Library_chartopengl.mk | 6 ++++++
+ vcl/Library_vcl.mk | 6 ++++++
+ 3 files changed, 18 insertions(+)
+
+diff --git a/chart2/Library_chartcore.mk b/chart2/Library_chartcore.mk
+index f785d09..08455f9 100644
+--- a/chart2/Library_chartcore.mk
++++ b/chart2/Library_chartcore.mk
+@@ -23,6 +23,12 @@ $(eval $(call gb_Library_add_defs,chartcore,\
+ -DOOO_DLLIMPLEMENTATION_CHARTVIEW \
+ ))
+
++ifeq ($(SYSTEM_GLM),TRUE)
++$(eval $(call gb_Library_add_defs,chartcore,\
++ -DGLM_ENABLE_EXPERIMENTAL \
++))
++endif
++
+ $(eval $(call gb_Library_set_precompiled_header,chartcore,$(SRCDIR)/chart2/inc/pch/precompiled_chartcore))
+
+ $(eval $(call gb_Library_use_externals,chartcore,\
+diff --git a/chart2/Library_chartopengl.mk b/chart2/Library_chartopengl.mk
+index f999f94..8b5a22c 100644
+--- a/chart2/Library_chartopengl.mk
++++ b/chart2/Library_chartopengl.mk
+@@ -54,5 +54,11 @@ $(eval $(call gb_Library_add_exception_objects,chartopengl,\
+ chart2/source/view/main/DummyXShape \
+ chart2/source/view/main/OpenGLRender \
+ ))
++
++ifeq ($(SYSTEM_GLM),TRUE)
++$(eval $(call gb_Library_add_defs,chartopengl,\
++ -DGLM_ENABLE_EXPERIMENTAL \
++))
++endif
+
+ # vim: set noet sw=4 ts=4:
+diff --git a/vcl/Library_vcl.mk b/vcl/Library_vcl.mk
+index 699d6ab..a2caa8e 100644
+--- a/vcl/Library_vcl.mk
++++ b/vcl/Library_vcl.mk
+@@ -49,6 +49,12 @@ $(eval $(call gb_Library_add_defs,vcl,\
+ -DENABLE_MERGELIBS=$(if $(MERGELIBS),1,0) \
+ ))
+
++ifeq ($(SYSTEM_GLM),TRUE)
++$(eval $(call gb_Library_add_defs,vcl,\
++ -DGLM_ENABLE_EXPERIMENTAL \
++))
++endif
++
+ $(eval $(call gb_Library_use_sdk_api,vcl))
+
+ $(eval $(call gb_Library_use_custom_headers,vcl,\
+--
+cgit v1.1
diff --git a/app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch b/app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch
new file mode 100644
index 00000000000..ea667d03ceb
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch
@@ -0,0 +1,19 @@
+Fix build with >=media-libs/glm-0.9.9
+https://bugs.gentoo.org/657178
+https://bugs.documentfoundation.org/show_bug.cgi?id=118070
+
+--- a/vcl/Executable_icontest.mk
++++ a/vcl/Executable_icontest.mk
+@@ -19,6 +19,12 @@ $(eval $(call gb_Executable_use_externals,icontest,\
+ ))
+ endif
+
++ifeq ($(SYSTEM_GLM),TRUE)
++$(eval $(call gb_Executable_add_defs,icontest,\
++ -DGLM_ENABLE_EXPERIMENTAL \
++))
++endif
++
+ $(eval $(call gb_Executable_use_api,icontest,\
+ offapi \
+ udkapi \
diff --git a/app-office/libreoffice/libreoffice-5.4.7.2.ebuild b/app-office/libreoffice/libreoffice-5.4.7.2.ebuild
index 8b6c7e2e1ca..7f73e8fc0a4 100644
--- a/app-office/libreoffice/libreoffice-5.4.7.2.ebuild
+++ b/app-office/libreoffice/libreoffice-5.4.7.2.ebuild
@@ -232,10 +232,12 @@ PATCHES=(
# 6.0 branch
"${FILESDIR}/${PN}-5.4.4.2-poppler-0.62.patch" # bug 642602
"${FILESDIR}/${PN}-6.0.3.2-poppler-0.64.patch" # bug 653478
+ "${FILESDIR}/${P}-glm-0.9.9.patch" # bug 657178
# TODO: upstream
"${FILESDIR}/${PN}-5.2.5.1-glibc-2.24.patch"
"${FILESDIR}/${PN}-5.4.4.2-gtk3-no-gtk-build.patch" # bug 641812
+ "${FILESDIR}/${PN}-6.0.4.2-glm-0.9.9.patch" # bug 657178
)
pkg_pretend() {
diff --git a/app-office/libreoffice/libreoffice-6.0.4.2.ebuild b/app-office/libreoffice/libreoffice-6.0.4.2.ebuild
index b1c28905c33..304982e8d2d 100644
--- a/app-office/libreoffice/libreoffice-6.0.4.2.ebuild
+++ b/app-office/libreoffice/libreoffice-6.0.4.2.ebuild
@@ -251,6 +251,7 @@ PATCHES=(
# TODO: upstream
"${FILESDIR}/${PN}-5.2.5.1-glibc-2.24.patch"
"${FILESDIR}/${PN}-6.0.3.2-testTdf108947.patch" #bug 656600
+ "${FILESDIR}/${P}-glm-0.9.9.patch" # bug 657178
# gtk3-kde5 vcl plugin backported from master
"${WORKDIR}"/${PATCHSET/.tar.xz/}