summaryrefslogtreecommitdiff
path: root/app-pda/libopensync-plugin-gnokii
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/libopensync-plugin-gnokii
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/libopensync-plugin-gnokii')
-rw-r--r--app-pda/libopensync-plugin-gnokii/Manifest2
-rw-r--r--app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.22.ebuild29
-rw-r--r--app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.36.ebuild20
-rw-r--r--app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-9999.ebuild22
-rw-r--r--app-pda/libopensync-plugin-gnokii/metadata.xml5
5 files changed, 78 insertions, 0 deletions
diff --git a/app-pda/libopensync-plugin-gnokii/Manifest b/app-pda/libopensync-plugin-gnokii/Manifest
new file mode 100644
index 00000000000..f9edabcb0f8
--- /dev/null
+++ b/app-pda/libopensync-plugin-gnokii/Manifest
@@ -0,0 +1,2 @@
+DIST libopensync-plugin-gnokii-0.22.tar.bz2 226990 SHA256 eb4902b4b7f9923f7644d350dd6cd84b562ebde8ca201e6284a29cff90c838a1 SHA512 a6ef418087d3803ebd4a6e68c8d2b6840667985d9cf8d8020efb98f675a519c3e1923329843de4d6fa72c7b35e23e7fef496e9067f941e24f12c30cd8d022059 WHIRLPOOL f26b8991b23d058f8e8589a93e111fdd81514fd755a0d43ff8c3201616c3f0d86b246a2f1bcc150fccbd5f1bcc2e925390b2ecdbe188b26293e89f8703f62b2a
+DIST libopensync-plugin-gnokii-0.36.tar.bz2 43782 SHA256 8674cc4a5df4a57d5d66756afc8492ac13ff335108ac225ee8164215a6feeb0b SHA512 527c5743cca879d3a9a34bfa16e10bf0d05e45dc0cc53b19a5e343ccf5f1985c38ee88f126da5c864dfc4f1c3ccee1d36c0d5d135907add7ad3d493373f28547 WHIRLPOOL a88e72fb7724af11f2bd32e57905da9438e0825d1f1c281667a012320f01919f6a5d9396fd188fa6db08e8963c3da69799f0b1b38a0b47ae88cdebfca1dfb566
diff --git a/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.22.ebuild b/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.22.ebuild
new file mode 100644
index 00000000000..dac0db2bad4
--- /dev/null
+++ b/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.22.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic
+
+DESCRIPTION="OpenSync Gnokii Plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://dev.gentooexperimental.org/~peper/distfiles/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="=app-pda/libopensync-${PV}*
+ >=app-mobilephone/gnokii-0.6.14"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ append-flags -Wno-error
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+}
diff --git a/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.36.ebuild b/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.36.ebuild
new file mode 100644
index 00000000000..7b4421097eb
--- /dev/null
+++ b/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.36.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="OpenSync Gnokii Plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="=app-pda/libopensync-${PV}*
+ >=app-mobilephone/gnokii-0.6.14"
+RDEPEND="${DEPEND}"
diff --git a/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-9999.ebuild b/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-9999.ebuild
new file mode 100644
index 00000000000..271f281d0e9
--- /dev/null
+++ b/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit cmake-utils subversion
+
+DESCRIPTION="OpenSync Gnokii Plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI=""
+
+ESVN_REPO_URI="http://svn.opensync.org/plugins/gnokii-sync"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="=app-pda/libopensync-${PV}*
+ >=app-mobilephone/gnokii-0.6.14"
+RDEPEND="${DEPEND}"
diff --git a/app-pda/libopensync-plugin-gnokii/metadata.xml b/app-pda/libopensync-plugin-gnokii/metadata.xml
new file mode 100644
index 00000000000..228404d3a4b
--- /dev/null
+++ b/app-pda/libopensync-plugin-gnokii/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pda</herd>
+</pkgmetadata>