summaryrefslogtreecommitdiff
path: root/app-pda/libopensync-plugin-gpe
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/libopensync-plugin-gpe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/libopensync-plugin-gpe')
-rw-r--r--app-pda/libopensync-plugin-gpe/Manifest2
-rw-r--r--app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.22.ebuild20
-rw-r--r--app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.36.ebuild19
-rw-r--r--app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-9999.ebuild21
-rw-r--r--app-pda/libopensync-plugin-gpe/metadata.xml5
5 files changed, 67 insertions, 0 deletions
diff --git a/app-pda/libopensync-plugin-gpe/Manifest b/app-pda/libopensync-plugin-gpe/Manifest
new file mode 100644
index 00000000000..2331400d311
--- /dev/null
+++ b/app-pda/libopensync-plugin-gpe/Manifest
@@ -0,0 +1,2 @@
+DIST libopensync-plugin-gpe-0.22.tar.bz2 221836 SHA256 2f291a694bee5a502845b1b5ab465acdd524f4c288fcb4b4851982532a4ff56b SHA512 c1f8c94314898014fac174a11b965e9118ee86e2b168463ec52f10b39c4fa8baee365827505d7bd9d843c3049b34e41319329ab1d90ea7180ef5e75ebf312687 WHIRLPOOL 5ca25b1b3fe6882ef47cdfeed1dd7686f397814445f07eaac864cbd77982b278927d0f2d77f15ac5f5c13da0a0a3c6292e352f9b5b54eca8a28a47efa9bbc6b8
+DIST libopensync-plugin-gpe-0.36.tar.bz2 40935 SHA256 b919b1536ca0229881122ac63d98d02a8c8f038f8dbcad4fe173c466cca2cb05 SHA512 65bad63f66a35f8b9005e593ada82f82f59ed6d835e8eed9d249e812ad70efaac78f3c0f897293395f0612e82c54870d8df42cd8f0e267c860d063a3b1e0179b WHIRLPOOL 57a59bc3d94b123b3f4645de1c282f8b8b8771dc06bc6397e079c9209dd59cac0a2639accbfeee5a15d2e80fde676e7976f23457f8b4def330dc12e4a5df3e30
diff --git a/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.22.ebuild b/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.22.ebuild
new file mode 100644
index 00000000000..7696e7edd1c
--- /dev/null
+++ b/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.22.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="OpenSync Gpe Plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://dev.gentooexperimental.org/~peper/distfiles/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="=app-pda/libopensync-${PV}*"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+}
diff --git a/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.36.ebuild b/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.36.ebuild
new file mode 100644
index 00000000000..9d6812c61e3
--- /dev/null
+++ b/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.36.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="OpenSync Gpe Plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="=app-pda/libopensync-${PV}*"
+RDEPEND="${DEPEND}"
diff --git a/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-9999.ebuild b/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-9999.ebuild
new file mode 100644
index 00000000000..ab00aeec2c6
--- /dev/null
+++ b/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit cmake-utils subversion
+
+DESCRIPTION="OpenSync Gpe Plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI=""
+
+ESVN_REPO_URI="http://svn.opensync.org/plugins/gpe"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="=app-pda/libopensync-${PV}*"
+RDEPEND="${DEPEND}"
diff --git a/app-pda/libopensync-plugin-gpe/metadata.xml b/app-pda/libopensync-plugin-gpe/metadata.xml
new file mode 100644
index 00000000000..228404d3a4b
--- /dev/null
+++ b/app-pda/libopensync-plugin-gpe/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pda</herd>
+</pkgmetadata>