summaryrefslogtreecommitdiff
path: root/app-pda/libopensync-plugin-palm
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/libopensync-plugin-palm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/libopensync-plugin-palm')
-rw-r--r--app-pda/libopensync-plugin-palm/Manifest1
-rw-r--r--app-pda/libopensync-plugin-palm/files/libopensync-plugin-palm-include_pisock.patch11
-rw-r--r--app-pda/libopensync-plugin-palm/libopensync-plugin-palm-0.22.ebuild36
-rw-r--r--app-pda/libopensync-plugin-palm/libopensync-plugin-palm-9999.ebuild27
-rw-r--r--app-pda/libopensync-plugin-palm/metadata.xml10
5 files changed, 85 insertions, 0 deletions
diff --git a/app-pda/libopensync-plugin-palm/Manifest b/app-pda/libopensync-plugin-palm/Manifest
new file mode 100644
index 00000000000..0384fcb238f
--- /dev/null
+++ b/app-pda/libopensync-plugin-palm/Manifest
@@ -0,0 +1 @@
+DIST libopensync-plugin-palm-0.22.tar.bz2 232123 SHA256 a96c25ce7a68a1e6455a6f05fec20e8db77dab319de7e330145b3cfef8e0ce0d SHA512 fbcfc7fbc68bb1798dd02e38f4d1abe3d2c0f6d2b3a141d83d829454d43c45cdaf4d400b1226d7a8ed39d1304c68332eb9d0c77be635974c3d7f11207b952dd0 WHIRLPOOL 1850e4724a2b95916dc3afa983b865dc01d6a90b5a21e14772ead9f8bc22ae95bc5ca53f4eb83a1737b10b23f3fa7076c2b4737f709ecb435110f6c026d51342
diff --git a/app-pda/libopensync-plugin-palm/files/libopensync-plugin-palm-include_pisock.patch b/app-pda/libopensync-plugin-palm/files/libopensync-plugin-palm-include_pisock.patch
new file mode 100644
index 00000000000..8182e6735be
--- /dev/null
+++ b/app-pda/libopensync-plugin-palm/files/libopensync-plugin-palm-include_pisock.patch
@@ -0,0 +1,11 @@
+--- acinclude.m4.org 2006-10-25 17:52:48.000000000 +0200
++++ acinclude.m4 2006-10-25 17:53:15.000000000 +0200
+@@ -16,7 +16,7 @@
+ PILOT_CFLAGS="-I$with_pilot_link/include"
+ PILOT_LIBS="-L$with_pilot_link/lib -Wl,-R$with_pilot_link/lib -lpisock"
+ else
+- PILOT_CFLAGS=""
++ PILOT_CFLAGS="-I/usr/include/libpisock"
+ PILOT_LIBS="-lpisock"
+ fi
+
diff --git a/app-pda/libopensync-plugin-palm/libopensync-plugin-palm-0.22.ebuild b/app-pda/libopensync-plugin-palm/libopensync-plugin-palm-0.22.ebuild
new file mode 100644
index 00000000000..8d06aa84807
--- /dev/null
+++ b/app-pda/libopensync-plugin-palm/libopensync-plugin-palm-0.22.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="OpenSync Palm Plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+RDEPEND="~app-pda/libopensync-${PV}
+ >=app-pda/pilot-link-0.11.8
+ dev-libs/glib:2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Patch fixing includedir for pisock
+ epatch "${FILESDIR}/${PN}-include_pisock.patch"
+ sed -i -e 's: -Werror::g' src/Makefile.am
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+ dodoc AUTHORS README
+}
diff --git a/app-pda/libopensync-plugin-palm/libopensync-plugin-palm-9999.ebuild b/app-pda/libopensync-plugin-palm/libopensync-plugin-palm-9999.ebuild
new file mode 100644
index 00000000000..4beb4ee98d5
--- /dev/null
+++ b/app-pda/libopensync-plugin-palm/libopensync-plugin-palm-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit cmake-utils subversion
+
+DESCRIPTION="OpenSync Palm Plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI=""
+
+ESVN_REPO_URI="http://svn.opensync.org/plugins/palm"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+RDEPEND="~app-pda/libopensync-${PV}
+ >=app-pda/pilot-link-0.11.8
+ dev-libs/glib:2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README"
diff --git a/app-pda/libopensync-plugin-palm/metadata.xml b/app-pda/libopensync-plugin-palm/metadata.xml
new file mode 100644
index 00000000000..0c317e5ffa3
--- /dev/null
+++ b/app-pda/libopensync-plugin-palm/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>pda</herd>
+ <maintainer>
+ <email>rhill@gentoo.org</email>
+ <name>Ryan Hill</name>
+ </maintainer>
+</pkgmetadata>
+