summaryrefslogtreecommitdiff
path: root/app-pda/msynctool
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/msynctool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/msynctool')
-rw-r--r--app-pda/msynctool/Manifest1
-rw-r--r--app-pda/msynctool/metadata.xml12
-rw-r--r--app-pda/msynctool/msynctool-0.22.ebuild32
3 files changed, 45 insertions, 0 deletions
diff --git a/app-pda/msynctool/Manifest b/app-pda/msynctool/Manifest
new file mode 100644
index 00000000000..f507c2909cc
--- /dev/null
+++ b/app-pda/msynctool/Manifest
@@ -0,0 +1 @@
+DIST msynctool-0.22.tar.bz2 219787 SHA256 5a3008eaaf61dc9f7cc0cd0c762d700dfa8cc1aa65c07ec5bf12abe252f2d280 SHA512 69bc7e38f8d35e3eaebfb307832eab5e6a47a14197433482c8e1c9ccf6fc05070b0931e4063ad0511909b8a310237fc4bdf838acbd93877c55579499f754027f WHIRLPOOL 9e3b39514815e969b2e909f5f1f31e183ba8c49356f83c454566512487e1cd5db04c868c378f1e5aa2e3e559f7e51c637b92e0fd6adc2658f440c6f3cc91b843
diff --git a/app-pda/msynctool/metadata.xml b/app-pda/msynctool/metadata.xml
new file mode 100644
index 00000000000..a514ffc3d37
--- /dev/null
+++ b/app-pda/msynctool/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>pda</herd>
+ <maintainer>
+ <email>rhill@gentoo.org</email>
+ <name>Ryan Hill</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
+
diff --git a/app-pda/msynctool/msynctool-0.22.ebuild b/app-pda/msynctool/msynctool-0.22.ebuild
new file mode 100644
index 00000000000..4866994832f
--- /dev/null
+++ b/app-pda/msynctool/msynctool-0.22.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+DESCRIPTION="OpenSync msync tool"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/downloads/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="~app-pda/libopensync-${PV}
+ dev-libs/glib:2
+ dev-libs/libxml2
+ !app-pda/osynctool"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e 's: -Werror::g' \
+ -e 's: -R $(libdir)::g' \
+ tools/Makefile.in
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README
+}