summaryrefslogtreecommitdiff
path: root/app-pda/osynctool
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/osynctool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/osynctool')
-rw-r--r--app-pda/osynctool/Manifest1
-rw-r--r--app-pda/osynctool/metadata.xml10
-rw-r--r--app-pda/osynctool/osynctool-0.39.ebuild28
-rw-r--r--app-pda/osynctool/osynctool-9999.ebuild30
4 files changed, 69 insertions, 0 deletions
diff --git a/app-pda/osynctool/Manifest b/app-pda/osynctool/Manifest
new file mode 100644
index 00000000000..d87cd8227ca
--- /dev/null
+++ b/app-pda/osynctool/Manifest
@@ -0,0 +1 @@
+DIST osynctool-0.39.tar.bz2 55850 SHA256 9690bc7720fadd1517c56f04b480d99c87304a43dc6e04b89bf1f59bb7e6764d SHA512 3e814b5b0261c8c69da451d1ce8d8380ebb1058f134a6d47e9e863036d3321866f4a8c1f71d23b9552d0abe7317bc9df3afcc64e97b35f7091d28b3ba8c2f4b6 WHIRLPOOL 168524b6469020d73b7a14ed40c987854c8b849f1e7eb26e10910dfa5a37b7d80424ebe460c1bfc9aaa0703cc8672d9b2d873702b7b759e246b1496b67531426
diff --git a/app-pda/osynctool/metadata.xml b/app-pda/osynctool/metadata.xml
new file mode 100644
index 00000000000..65fffc6ff83
--- /dev/null
+++ b/app-pda/osynctool/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pda</herd>
+<longdescription lang="en">
+Command line interface for OpenSync.
+You can use this tool to synchronize your devices and applications using the OpenSync framework from the command line.
+</longdescription>
+</pkgmetadata>
+
diff --git a/app-pda/osynctool/osynctool-0.39.ebuild b/app-pda/osynctool/osynctool-0.39.ebuild
new file mode 100644
index 00000000000..1e9e0e50cf7
--- /dev/null
+++ b/app-pda/osynctool/osynctool-0.39.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit cmake-utils
+
+DESCRIPTION="Command line interface for OpenSync"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="~app-pda/libopensync-${PV}
+ dev-libs/glib:2
+ !app-pda/msynctool"
+DEPEND="${DEPEND}"
+
+DOCS="AUTHORS CODING"
+
+src_prepare() {
+ sed -i -e 's:/etc/bash_completion.d:/share/bash-completion:g' \
+ tools/CMakeLists.txt
+}
diff --git a/app-pda/osynctool/osynctool-9999.ebuild b/app-pda/osynctool/osynctool-9999.ebuild
new file mode 100644
index 00000000000..b4957991f6f
--- /dev/null
+++ b/app-pda/osynctool/osynctool-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit cmake-utils subversion
+
+DESCRIPTION="Command line interface for OpenSync"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI=""
+
+ESVN_REPO_URI="http://svn.opensync.org/osynctool/trunk"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="~app-pda/libopensync-${PV}
+ dev-libs/glib:2
+ !app-pda/msynctool"
+DEPEND="${DEPEND}"
+
+DOCS="AUTHORS CODING"
+
+src_prepare() {
+ sed -i -e 's:/etc/bash_completion.d:/share/bash-completion:g' \
+ tools/CMakeLists.txt
+}