summaryrefslogtreecommitdiff
path: root/app-portage/distpatch/distpatch-0.1.2.ebuild
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2016-11-06 23:13:50 +0100
committerRafael Martins <rafaelmartins@gentoo.org>2016-11-06 23:14:08 +0100
commitad3e4995c84af6432be00414f90e0653a70d8b9c (patch)
tree5a3e12a536633ea82e13b4dc0b567482aa70bb49 /app-portage/distpatch/distpatch-0.1.2.ebuild
parentf7b99ca8a5a42905fa1a475cb55c4a18fee93cb5 (diff)
downloadgentoo-ad3e4995c84af6432be00414f90e0653a70d8b9c.tar.gz
gentoo-ad3e4995c84af6432be00414f90e0653a70d8b9c.tar.xz
app-portage/distpatch: version bump. ported to distutils-r1
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-portage/distpatch/distpatch-0.1.2.ebuild')
-rw-r--r--app-portage/distpatch/distpatch-0.1.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-portage/distpatch/distpatch-0.1.2.ebuild b/app-portage/distpatch/distpatch-0.1.2.ebuild
new file mode 100644
index 00000000000..bb3bc3323f5
--- /dev/null
+++ b/app-portage/distpatch/distpatch-0.1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distfile Patching Support for Gentoo Linux (tools)"
+HOMEPAGE="https://www.gentoo.org/proj/en/infrastructure/distpatch/"
+SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND=">=sys-apps/portage-2.1.8.3
+ dev-python/snakeoil"
+DEPEND="${CDEPEND}
+ dev-python/setuptools"
+RDEPEND="${CDEPEND}
+ >=dev-util/diffball-1.0.1"