summaryrefslogtreecommitdiff
path: root/app-portage/eix
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-11-01 19:44:27 +0100
committerMichał Górny <mgorny@gentoo.org>2016-11-06 16:34:35 +0100
commit0674aa64df1d65d427d653e3ed8b37b211b4d848 (patch)
tree2b6255f478c06b11a0f2e06567db68b9897098c9 /app-portage/eix
parent39f0ae3fe1259d17abc10cc0b21e2c9820089292 (diff)
downloadgentoo-0674aa64df1d65d427d653e3ed8b37b211b4d848.tar.gz
gentoo-0674aa64df1d65d427d653e3ed8b37b211b4d848.tar.xz
app-portage/eix: Own the cache directory
Diffstat (limited to 'app-portage/eix')
-rw-r--r--app-portage/eix/eix-0.32.1-r1.ebuild (renamed from app-portage/eix/eix-0.32.1.ebuild)12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-portage/eix/eix-0.32.1.ebuild b/app-portage/eix/eix-0.32.1-r1.ebuild
index 57695a9fba1..4665d7be271 100644
--- a/app-portage/eix/eix-0.32.1.ebuild
+++ b/app-portage/eix/eix-0.32.1-r1.ebuild
@@ -75,15 +75,15 @@ src_install() {
default
dobashcomp bash/eix
systemd_dotmpfilesd tmpfiles.d/eix.conf
+
+ keepdir /var/cache/eix
}
pkg_postinst() {
- local cache=${EROOT%/}/var/cache/${PN}
- if [[ ! -d ${cache} ]]; then
- mkdir "${cache}" || die
- if ! use prefix; then
- chown portage:portage "${cache}" || die
- fi
+ if ! use prefix; then
+ # note: if this is done in src_install(), portage:portage
+ # ownership may be reset to root
+ fowners portage:portage "${EROOT%/}"/var/cache/eix
fi
local obs=${EROOT%/}/var/cache/eix.previous