summaryrefslogtreecommitdiff
path: root/app-portage/grs/grs-9999.ebuild
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-01-14 04:49:33 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-01-14 04:49:33 -0500
commitc795a2f9b15c90bf85bbd359137b394ab60e6565 (patch)
treed384e74cc04f198d02266a86c22e0684e8af1640 /app-portage/grs/grs-9999.ebuild
parent7bb94047731ead935688c2b85c11f77bb0b1511b (diff)
downloadgentoo-c795a2f9b15c90bf85bbd359137b394ab60e6565.tar.gz
gentoo-c795a2f9b15c90bf85bbd359137b394ab60e6565.tar.xz
app-portage/grs: update -9999 for new installation requirements
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-portage/grs/grs-9999.ebuild')
-rw-r--r--app-portage/grs/grs-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-portage/grs/grs-9999.ebuild b/app-portage/grs/grs-9999.ebuild
index 5e16f8b436e..a4a9b8ed236 100644
--- a/app-portage/grs/grs-9999.ebuild
+++ b/app-portage/grs/grs-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -6,11 +6,15 @@ PYTHON_COMPAT=( python3_{4,5,6} )
inherit distutils-r1 linux-info
+ISO="ISO-1.tar.gz"
+
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/grss.git"
+ SRC_URI="https://dev.gentoo.org/~blueness/${PN}/${ISO}"
inherit git-r3
else
- SRC_URI="https://dev.gentoo.org/~blueness/${PN}/${P}.tar.gz"
+ SRC_URI="https://dev.gentoo.org/~blueness/${PN}/${P}.tar.gz
+ https://dev.gentoo.org/~blueness/${PN}/${ISO}"
KEYWORDS="~amd64"
fi
@@ -50,4 +54,6 @@ src_install() {
distutils-r1_src_install
echo "CONFIG_PROTECT=\"/etc/grs/systems.conf\"" > "${T}"/20grs
doenvd "${T}"/20grs
+ mkdir ${D}/usr/share/${P}
+ cp "${DISTDIR}"/${ISO} ${D}/usr/share/${P}
}