summaryrefslogtreecommitdiff
path: root/app-portage/layman-dbtools
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-portage/layman-dbtools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-portage/layman-dbtools')
-rw-r--r--app-portage/layman-dbtools/layman-dbtools-0_p20100322.ebuild57
-rw-r--r--app-portage/layman-dbtools/metadata.xml8
2 files changed, 65 insertions, 0 deletions
diff --git a/app-portage/layman-dbtools/layman-dbtools-0_p20100322.ebuild b/app-portage/layman-dbtools/layman-dbtools-0_p20100322.ebuild
new file mode 100644
index 00000000000..186af044cf4
--- /dev/null
+++ b/app-portage/layman-dbtools/layman-dbtools-0_p20100322.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="xml"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit git-2 python
+
+DESCRIPTION="Tools to work with layman-global.txt/repositories.xml like files"
+HOMEPAGE="http://cgit.gentoo.org/proj/repositories-xml-format.git"
+SRC_URI=""
+EGIT_REPO_URI="git://anongit.gentoo.org/proj/repositories-xml-format.git
+ http://anongit.gentoo.org/git/proj/repositories-xml-format.git"
+EGIT_COMMIT="8c4d7440c6d47f7ed690edafb7c0af53742f3297"
+
+if [[ ${PV} != 0_p20100322 ]]; then
+ die 'Broken bump detected: same \${EGIT_COMMIT} again'
+fi
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-portage/layman"
+
+src_install() {
+ abi_specific_install() {
+ local code_dir="$(python_get_sitedir)"/layman/dbtools
+
+ exeinto "${code_dir}"
+ doexe write-repositories-xml.py || die "doexe failed"
+
+ insinto "${code_dir}"
+ doins layman/dbtools/*.py || die "doins failed"
+
+ dodir /usr/bin
+ dosym "${code_dir}"/write-repositories-xml.py /usr/bin/write-repositories-xml-${PYTHON_ABI} \
+ || die "dosym failed"
+ }
+ python_execute_function abi_specific_install
+
+ python_generate_wrapper_scripts "${ED}usr/bin/write-repositories-xml"
+}
+
+pkg_postinst() {
+ python_mod_optimize layman/dbtools
+}
+
+pkg_postrm() {
+ python_mod_cleanup layman/dbtools
+}
diff --git a/app-portage/layman-dbtools/metadata.xml b/app-portage/layman-dbtools/metadata.xml
new file mode 100644
index 00000000000..16bcc9f800a
--- /dev/null
+++ b/app-portage/layman-dbtools/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+</pkgmetadata>