summaryrefslogtreecommitdiff
path: root/app-portage/pms-test-suite
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-portage/pms-test-suite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-portage/pms-test-suite')
-rw-r--r--app-portage/pms-test-suite/Manifest1
-rw-r--r--app-portage/pms-test-suite/metadata.xml15
-rw-r--r--app-portage/pms-test-suite/pms-test-suite-0.2.ebuild62
-rw-r--r--app-portage/pms-test-suite/pms-test-suite-9999.ebuild71
4 files changed, 149 insertions, 0 deletions
diff --git a/app-portage/pms-test-suite/Manifest b/app-portage/pms-test-suite/Manifest
new file mode 100644
index 00000000000..cba23b3f974
--- /dev/null
+++ b/app-portage/pms-test-suite/Manifest
@@ -0,0 +1 @@
+DIST pms-test-suite-0.2.tar.bz2 21962 SHA256 104a757edf5b223ff38885691b332420da82a0c62b80469787883579385aafea SHA512 66e5d166458f6a1082c8c53cb52a679d25d26187369c25f2df16519d0b44ad447d12c726abaca45187965bb4263bc063ef969b391ae0912c449907f0b8e79b68 WHIRLPOOL dd92de5d204501c79538f5d007e919ecbd6c78daff0377115df3d022e7b46233d1b2b97278081996471044f5b42f5350fd6f8eeef90a85097ea578e949f628de
diff --git a/app-portage/pms-test-suite/metadata.xml b/app-portage/pms-test-suite/metadata.xml
new file mode 100644
index 00000000000..38dc3aae0e7
--- /dev/null
+++ b/app-portage/pms-test-suite/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/pms-test-suite/issues/</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-portage/pms-test-suite/pms-test-suite-0.2.ebuild b/app-portage/pms-test-suite/pms-test-suite-0.2.ebuild
new file mode 100644
index 00000000000..3b6d1087dc4
--- /dev/null
+++ b/app-portage/pms-test-suite/pms-test-suite-0.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND='2:2.6'
+# Python ABIs are not supported by pkgcore
+#SUPPORT_PYTHON_ABIS=1
+# Python3 is not supported by dbus & gobject
+RESTRICT_PYTHON_ABIS='2.4 2.5 3.*'
+DISTUTILS_SRC_TEST=setup.py
+
+inherit base distutils
+
+DESCRIPTION="A test suite for Package Manager PMS compliance"
+HOMEPAGE="http://www.gentoo.org/proj/en/qa/pms/pms-test-suite.xml"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=app-portage/gentoopm-0.1.5
+ dev-python/dbus-python
+ dev-python/pygobject:2"
+DEPEND="doc? ( dev-python/epydoc )
+ test? ( >=sys-apps/portage-2.1.10.3
+ sys-apps/pkgcore
+ >=sys-apps/paludis-0.64.2[python] )"
+
+# broken atm
+RESTRICT=test
+
+PYTHON_MODNAME=pmstestsuite
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ base_src_prepare
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ "$(PYTHON)" setup.py "${_DISTUTILS_GLOBAL_OPTIONS[@]}" doc || die
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r doc/*
+ fi
+}
diff --git a/app-portage/pms-test-suite/pms-test-suite-9999.ebuild b/app-portage/pms-test-suite/pms-test-suite-9999.ebuild
new file mode 100644
index 00000000000..f0709db0956
--- /dev/null
+++ b/app-portage/pms-test-suite/pms-test-suite-9999.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND='2:2.6'
+# Python ABIs are not supported by pkgcore
+#SUPPORT_PYTHON_ABIS=1
+# Python3 is not supported by dbus & gobject
+RESTRICT_PYTHON_ABIS='2.4 2.5 3.*'
+DISTUTILS_SRC_TEST=setup.py
+
+inherit base distutils
+
+#if LIVE
+EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git
+ http://anongit.gentoo.org/git/proj/${PN}.git
+ http://bitbucket.org/mgorny/${PN}.git"
+inherit git-2
+#endif
+
+DESCRIPTION="A test suite for Package Manager PMS compliance"
+HOMEPAGE="http://www.gentoo.org/proj/en/qa/pms/pms-test-suite.xml"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=app-portage/gentoopm-0.1.5
+ dev-python/dbus-python
+ dev-python/pygobject:2"
+DEPEND="doc? ( dev-python/epydoc )
+ test? ( >=sys-apps/portage-2.1.10.3
+ sys-apps/pkgcore
+ >=sys-apps/paludis-0.64.2[python] )"
+
+PYTHON_MODNAME=pmstestsuite
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ base_src_prepare
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ "$(PYTHON)" setup.py "${_DISTUTILS_GLOBAL_OPTIONS[@]}" doc || die
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r doc/*
+ fi
+}