summaryrefslogtreecommitdiff
path: root/app-portage/porthole
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-portage/porthole
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-portage/porthole')
-rw-r--r--app-portage/porthole/Manifest1
-rw-r--r--app-portage/porthole/files/porthole-0.6.1-masking_status.patch17
-rw-r--r--app-portage/porthole/files/porthole-0.6.1-missing-attribute.patch14
-rw-r--r--app-portage/porthole/files/porthole-0.6.1-missing_import.patch19
-rw-r--r--app-portage/porthole/metadata.xml13
-rw-r--r--app-portage/porthole/porthole-0.6.1-r1.ebuild76
-rw-r--r--app-portage/porthole/porthole-0.6.1-r2.ebuild76
-rw-r--r--app-portage/porthole/porthole-0.6.1-r3.ebuild77
8 files changed, 293 insertions, 0 deletions
diff --git a/app-portage/porthole/Manifest b/app-portage/porthole/Manifest
new file mode 100644
index 00000000000..8804ab28048
--- /dev/null
+++ b/app-portage/porthole/Manifest
@@ -0,0 +1 @@
+DIST porthole-0.6.1.tar.bz2 958696 SHA256 eb9991cb078f51f5b4c9900995ffc3f7f5e3891e62b10cd1c5384efece010d62 SHA512 9bc1d79c587ad8228b9bb4eee6cb32559a5d7b6a9f4f6ece752fce9030f71fdbfd6158d7a2a055641b63df1f0a1c31995747e15b618de79cd8a7a56e4d8f634c WHIRLPOOL 8f9cf3b2d7b4ec44b0425115b19c9c00b4fe816d035d512b305a5e3d02f7e92f2b0d12057b141f123ff2d8c747e23e8075bb1afefe5bb02d9a02884f08eb1ba7
diff --git a/app-portage/porthole/files/porthole-0.6.1-masking_status.patch b/app-portage/porthole/files/porthole-0.6.1-masking_status.patch
new file mode 100644
index 00000000000..e626fbb3c58
--- /dev/null
+++ b/app-portage/porthole/files/porthole-0.6.1-masking_status.patch
@@ -0,0 +1,17 @@
+Index: porthole/backends/portagelib.py
+===================================================================
+--- porthole/backends/portagelib.py (revision 1209)
++++ porthole/backends/portagelib.py (working copy)
+@@ -452,7 +452,11 @@
+
+
+ def get_masking_status(ebuild):
+- return portage.getmaskingstatus(ebuild)
++ try:
++ status = portage.getmaskingstatus(ebuild)
++ except KeyError:
++ status = ['deprecated']
++ return status
+
+
+ def get_masking_reason(ebuild):
diff --git a/app-portage/porthole/files/porthole-0.6.1-missing-attribute.patch b/app-portage/porthole/files/porthole-0.6.1-missing-attribute.patch
new file mode 100644
index 00000000000..aa011a174b1
--- /dev/null
+++ b/app-portage/porthole/files/porthole-0.6.1-missing-attribute.patch
@@ -0,0 +1,14 @@
+diff -uNr porthole/db/user_configs.py.old porthole/db/user_configs.py
+
+--- porthole/db/user_configs.py.old 2010-11-27 13:34:35.000000000 +0600
++++ porthole/db/user_configs.py 2010-11-27 13:31:24.000000000 +0600
+@@ -364,7 +364,7 @@
+ debug.dprint("USER_CONFIGS: set_user_config(): add: " +
+ "%s,\n remove: %s " %(str(add),str(remove)))
+ set_config.set_user_config(filename=file, name=name, ebuild=ebuild,
+- comment=comment, username=privileges.USER,
++ comment=comment, username=privileges.user,
+ add=add, remove=remove)
+ self.set_config_callback()
+ else:
+ \ No newline at end of file
diff --git a/app-portage/porthole/files/porthole-0.6.1-missing_import.patch b/app-portage/porthole/files/porthole-0.6.1-missing_import.patch
new file mode 100644
index 00000000000..33c9e4ee335
--- /dev/null
+++ b/app-portage/porthole/files/porthole-0.6.1-missing_import.patch
@@ -0,0 +1,19 @@
+--- porthole/db/user_configs.py 2010/03/20 12:32:29 1217
++++ porthole/db/user_configs.py 2010/03/20 14:10:46 1218
+@@ -36,6 +36,7 @@
+ from porthole import backends
+ portage_lib = backends.portage_lib
+ from porthole.utils import debug
++from porthole.privilege import controller as privileges
+
+ ## set up this module to act as a user configs data server,
+ ## watch the user configs for changes and auto update
+@@ -363,7 +364,7 @@
+ debug.dprint("USER_CONFIGS: set_user_config(): add: " +
+ "%s,\n remove: %s " %(str(add),str(remove)))
+ set_config.set_user_config(filename=file, name=name, ebuild=ebuild,
+- comment=comment, username=priviliges.USER,
++ comment=comment, username=privileges.USER,
+ add=add, remove=remove)
+ self.set_config_callback()
+ else:
diff --git a/app-portage/porthole/metadata.xml b/app-portage/porthole/metadata.xml
new file mode 100644
index 00000000000..7b77e0fe700
--- /dev/null
+++ b/app-portage/porthole/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tools-portage</herd>
+ <maintainer>
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ <description>Upstream Maintainer (please CC on bugs)</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">porthole</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-portage/porthole/porthole-0.6.1-r1.ebuild b/app-portage/porthole/porthole-0.6.1-r1.ebuild
new file mode 100644
index 00000000000..606f49f3ffd
--- /dev/null
+++ b/app-portage/porthole/porthole-0.6.1-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_USE_WITH="xml threads"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="A GTK+-based frontend to Portage"
+HOMEPAGE="http://porthole.sourceforge.net"
+SRC_URI="mirror://sourceforge/porthole/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ~sparc x86 ~x86-fbsd"
+IUSE="nls"
+LANGS="de pl ru vi it fr tr"
+for X in $LANGS; do IUSE="${IUSE} linguas_${X}"; done
+
+RDEPEND=">=sys-apps/portage-2.1
+ dev-python/pygtk:2
+ gnome-base/libglade:2.0
+ dev-python/pygtksourceview:2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.14 )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-masking_status.patch" # bug 307037
+}
+
+src_compile(){
+ # Compile localizations if necessary
+ if use nls ; then
+ cd scripts
+ ./pocompile.sh -emerge ${LINGUAS} || die "pocompile failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc TODO README NEWS AUTHORS
+
+ keepdir /var/log/porthole
+ fperms g+w /var/log/porthole
+ keepdir /var/db/porthole
+ fperms g+w /var/db/porthole
+
+ # nls
+ if use nls; then
+ # mo directory doesn't exists with nls enabled and unsupported LINGUAS
+ [[ -d porthole/i18n/mo ]] && domo porthole/i18n/mo/*
+ fi
+}
+
+pkg_preinst() {
+ chgrp portage "${D}"/var/log/porthole
+ chgrp portage "${D}"/var/db/porthole
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Porthole has updated the way that the upgrades are sent to emerge."
+ einfo "In this new way the user needs to set any 'Settings' menu emerge options"
+ einfo "Porthole automatically adds '--oneshot' for all upgrades selections"
+ einfo "Other options recommended are '--noreplace' along with '--update'"
+ einfo "They allow for portage to skip any packages that might have already"
+ einfo "been upgraded as a dependency of another previously upgraded package"
+ einfo
+}
diff --git a/app-portage/porthole/porthole-0.6.1-r2.ebuild b/app-portage/porthole/porthole-0.6.1-r2.ebuild
new file mode 100644
index 00000000000..8e7db7f2a39
--- /dev/null
+++ b/app-portage/porthole/porthole-0.6.1-r2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_USE_WITH="xml threads"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+inherit distutils eutils
+
+DESCRIPTION="A GTK+-based frontend to Portage"
+HOMEPAGE="http://porthole.sourceforge.net"
+SRC_URI="mirror://sourceforge/porthole/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+LANGS="de pl ru vi it fr tr"
+for X in $LANGS; do IUSE="${IUSE} linguas_${X}"; done
+
+RDEPEND=">=sys-apps/portage-2.1
+ dev-python/pygtk:2
+ gnome-base/libglade:2.0
+ dev-python/pygtksourceview:2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.14 )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-masking_status.patch" # bug 307037
+ epatch "${FILESDIR}/${P}-missing_import.patch" # bug 323179
+}
+
+src_compile(){
+ # Compile localizations if necessary
+ if use nls ; then
+ cd scripts
+ ./pocompile.sh -emerge ${LINGUAS} || die "pocompile failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc TODO README NEWS AUTHORS
+
+ keepdir /var/log/porthole
+ fperms g+w /var/log/porthole
+ keepdir /var/db/porthole
+ fperms g+w /var/db/porthole
+
+ # nls
+ if use nls; then
+ # mo directory doesn't exists with nls enabled and unsupported LINGUAS
+ [[ -d porthole/i18n/mo ]] && domo porthole/i18n/mo/*
+ fi
+}
+
+pkg_preinst() {
+ chgrp portage "${D}"/var/log/porthole
+ chgrp portage "${D}"/var/db/porthole
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Porthole has updated the way that the upgrades are sent to emerge."
+ einfo "In this new way the user needs to set any 'Settings' menu emerge options"
+ einfo "Porthole automatically adds '--oneshot' for all upgrades selections"
+ einfo "Other options recommended are '--noreplace' along with '--update'"
+ einfo "They allow for portage to skip any packages that might have already"
+ einfo "been upgraded as a dependency of another previously upgraded package"
+ einfo
+}
diff --git a/app-portage/porthole/porthole-0.6.1-r3.ebuild b/app-portage/porthole/porthole-0.6.1-r3.ebuild
new file mode 100644
index 00000000000..7a2fca24728
--- /dev/null
+++ b/app-portage/porthole/porthole-0.6.1-r3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_USE_WITH="xml threads"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+inherit distutils eutils
+
+DESCRIPTION="A GTK+-based frontend to Portage"
+HOMEPAGE="http://porthole.sourceforge.net"
+SRC_URI="mirror://sourceforge/porthole/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+LANGS="de pl ru vi it fr tr"
+for X in $LANGS; do IUSE="${IUSE} linguas_${X}"; done
+
+RDEPEND=">=sys-apps/portage-2.1
+ dev-python/pygtk:2
+ gnome-base/libglade:2.0
+ dev-python/pygtksourceview:2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.14 )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-masking_status.patch" # bug 307037
+ epatch "${FILESDIR}/${P}-missing_import.patch" # bug 323179
+ epatch "${FILESDIR}/${P}-missing-attribute.patch" #bug 323179
+}
+
+src_compile(){
+ # Compile localizations if necessary
+ if use nls ; then
+ cd scripts
+ ./pocompile.sh -emerge ${LINGUAS} || die "pocompile failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc TODO README NEWS AUTHORS
+
+ keepdir /var/log/porthole
+ fperms g+w /var/log/porthole
+ keepdir /var/db/porthole
+ fperms g+w /var/db/porthole
+
+ # nls
+ if use nls; then
+ # mo directory doesn't exists with nls enabled and unsupported LINGUAS
+ [[ -d porthole/i18n/mo ]] && domo porthole/i18n/mo/*
+ fi
+}
+
+pkg_preinst() {
+ chgrp portage "${D}"/var/log/porthole
+ chgrp portage "${D}"/var/db/porthole
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Porthole has updated the way that the upgrades are sent to emerge."
+ einfo "In this new way the user needs to set any 'Settings' menu emerge options"
+ einfo "Porthole automatically adds '--oneshot' for all upgrades selections"
+ einfo "Other options recommended are '--noreplace' along with '--update'"
+ einfo "They allow for portage to skip any packages that might have already"
+ einfo "been upgraded as a dependency of another previously upgraded package"
+ einfo
+}