summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2017-12-12 15:13:33 -0600
committerPaul Varner <fuzzyray@gentoo.org>2017-12-12 15:15:01 -0600
commit9a1fdfb375f497c50c48ccf7267140088cca6c29 (patch)
treea8de0245224c5da00775cfe9d99e3fa505164cb7 /app-portage
parentf3472dd789f9403fe71a1bb8dbea1aa8f5ff3ea5 (diff)
downloadgentoo-9a1fdfb375f497c50c48ccf7267140088cca6c29.tar.gz
gentoo-9a1fdfb375f497c50c48ccf7267140088cca6c29.tar.xz
app-portage/gentoolkit: Version bump.
Contains fixes for Python3.6 and unicode Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoolkit/Manifest1
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.4.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-portage/gentoolkit/Manifest b/app-portage/gentoolkit/Manifest
index dd6834288d6..ea3f55b2d55 100644
--- a/app-portage/gentoolkit/Manifest
+++ b/app-portage/gentoolkit/Manifest
@@ -1,2 +1,3 @@
DIST gentoolkit-0.3.3.tar.gz 3197037 BLAKE2B c2a45971f1f25e3008422b63b59042ca0f2b170b98e10fc4e449ee6be76c0422469cd8bce1b744830404d5a26ba87ded47aab679069965eea266719249475923 SHA512 ad142c2c66e7f7a2e4184c8f95e394ee783cd57808e6254e9f5df0f3f60ad842042f773716ca0fd6d7545bb8a2d11c1c167a4ec471eb3238c8ee3a519f70a691
DIST gentoolkit-0.4.0.tar.gz 3215377 BLAKE2B 404f81e2f5bce5da4df122156bc76d225497456ad8ec78a50c41e1183390f8e452a6ce8a3473b5371a6712ce1599be33034c5eed64a1852d116c745bc5a775f4 SHA512 6cf693c588d4a2f5bd06fff4e78ef98007e613348048ec993c5430e168baef6c1da01e1843903f3e87ca8e47dd1ffb207acccbc5c0e881fa3093a7880fec9a56
+DIST gentoolkit-0.4.1.tar.gz 3214527 BLAKE2B 1c6be826a099ba4d18ac8fa0bb38808cbf30ee1d93d26c26965d7fa332e6a87f8eee475126f56d68e2a1c0ff04f258f79f5684551b2fe5947d8ac6f6ff3e7079 SHA512 52b665e19dd8b871f4238d05d40a071d69ef114f36b589c29f46686b1439997e72f58896bb4f330ab256af6000a9559426c78cae08640e54b74db343b3b22945
diff --git a/app-portage/gentoolkit/gentoolkit-0.4.1.ebuild b/app-portage/gentoolkit/gentoolkit-0.4.1.ebuild
new file mode 100644
index 00000000000..ed5581daa99
--- /dev/null
+++ b/app-portage/gentoolkit/gentoolkit-0.4.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6} pypy)
+PYTHON_REQ_USE="xml(+),threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage-Tools"
+SRC_URI="https://dev.gentoo.org/~fuzzyray/releases/gentoolkit/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="sys-apps/portage[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ !app-portage/gentoolkit-dev
+ sys-apps/gawk
+ sys-apps/gentoo-functions"
+
+python_prepare_all() {
+ python_setup
+ echo VERSION="${PVR}" "${PYTHON}" setup.py set_version
+ VERSION="${PVR}" "${PYTHON}" setup.py set_version
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ # Create cache directory for revdep-rebuild
+ mkdir -p -m 0755 "${EROOT%/}"/var/cache
+ mkdir -p -m 0700 "${EROOT%/}"/var/cache/revdep-rebuild
+
+ einfo "Starting with version 0.4.0, ebump, ekeyword and imlate are now"
+ einfo "part of the gentoolkit package."
+ einfo "The gentoolkit-dev package is now deprecated in favor of a single"
+ einfo "gentoolkit package. The remaining tools from gentoolkit-dev"
+ einfo "are now obsolete/unused with the git based tree."
+
+ # Only show the elog information on a new install
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "For further information on gentoolkit, please read the gentoolkit"
+ elog "guide: https://wiki.gentoo.org/wiki/Gentoolkit"
+ elog
+ elog "Another alternative to equery is app-portage/portage-utils"
+ elog
+ elog "Additional tools that may be of interest:"
+ elog
+ elog " app-admin/eclean-kernel"
+ elog " app-portage/diffmask"
+ elog " app-portage/flaggie"
+ elog " app-portage/install-mask"
+ elog " app-portage/portpeek"
+ elog " app-portage/smart-live-rebuild"
+ fi
+}