summaryrefslogtreecommitdiff
path: root/app-shells/dash
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-14 10:02:55 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-14 10:02:55 +0200
commitfd5b82cc1650651864fb8714c59796fef6defc89 (patch)
tree1edf1b7b43e0adeb235a9db15e228038c82792ba /app-shells/dash
parentaca4d0d8ea28b3d26391d4660d46be3d8e0bad02 (diff)
downloadgentoo-fd5b82cc1650651864fb8714c59796fef6defc89.tar.gz
gentoo-fd5b82cc1650651864fb8714c59796fef6defc89.tar.xz
app-shells/dash: Revbump to fix typo in dumb-echo patch.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'app-shells/dash')
-rw-r--r--app-shells/dash/dash-0.5.10.1-r1.ebuild (renamed from app-shells/dash/dash-0.5.10.1.ebuild)0
-rw-r--r--app-shells/dash/files/dash-0.5.10-dumb-echo.patch2
2 files changed, 1 insertions, 1 deletions
diff --git a/app-shells/dash/dash-0.5.10.1.ebuild b/app-shells/dash/dash-0.5.10.1-r1.ebuild
index d51383e2eb1..d51383e2eb1 100644
--- a/app-shells/dash/dash-0.5.10.1.ebuild
+++ b/app-shells/dash/dash-0.5.10.1-r1.ebuild
diff --git a/app-shells/dash/files/dash-0.5.10-dumb-echo.patch b/app-shells/dash/files/dash-0.5.10-dumb-echo.patch
index 6b19b5b59f7..35d32460930 100644
--- a/app-shells/dash/files/dash-0.5.10-dumb-echo.patch
+++ b/app-shells/dash/files/dash-0.5.10-dumb-echo.patch
@@ -24,7 +24,7 @@ sequence. it also makes dash smaller & faster to disable this logic entirely.
- lastfmt = "%s";
+ for (i = 1; i < argc; ++i) {
+ outstr(argv[i], out1);
-+ if (1 < argc - 1)
++ if (i < argc - 1)
+ outc(' ', out1);
}
-