summaryrefslogtreecommitdiff
path: root/app-shells/scsh
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-12-08 23:43:55 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-08 23:47:47 +0100
commit97bcea63fe55df0e0b60994cbb513f2483c6cb12 (patch)
tree47c20967c047a97599330080ae282de2f3fd5446 /app-shells/scsh
parent085dff3048d6adc50da5af99e114fa9e33e0cd62 (diff)
downloadgentoo-97bcea63fe55df0e0b60994cbb513f2483c6cb12.tar.gz
gentoo-97bcea63fe55df0e0b60994cbb513f2483c6cb12.tar.xz
app-shells/scsh: EAPI 6 bump and clean up.
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-shells/scsh')
-rw-r--r--app-shells/scsh/files/0.6.7-Makefile.in-LDFLAGS.patch4
-rw-r--r--app-shells/scsh/files/0.6.7-Makefile.in-doc-dir-gentoo.patch4
-rw-r--r--app-shells/scsh/scsh-0.6.7-r2.ebuild49
3 files changed, 53 insertions, 4 deletions
diff --git a/app-shells/scsh/files/0.6.7-Makefile.in-LDFLAGS.patch b/app-shells/scsh/files/0.6.7-Makefile.in-LDFLAGS.patch
index b1c6480885d..34d54a53c3a 100644
--- a/app-shells/scsh/files/0.6.7-Makefile.in-LDFLAGS.patch
+++ b/app-shells/scsh/files/0.6.7-Makefile.in-LDFLAGS.patch
@@ -1,5 +1,5 @@
---- Makefile.in.orig 2010-08-11 16:55:09.246939884 +0200
-+++ Makefile.in 2010-08-11 16:55:31.309819842 +0200
+--- a/Makefile.in.orig 2010-08-11 16:55:09.246939884 +0200
++++ b/Makefile.in 2010-08-11 16:55:31.309819842 +0200
@@ -853,7 +853,7 @@
cig/libcig.c: cig/libcig.scm
diff --git a/app-shells/scsh/files/0.6.7-Makefile.in-doc-dir-gentoo.patch b/app-shells/scsh/files/0.6.7-Makefile.in-doc-dir-gentoo.patch
index 6ec949bb115..d32e24b4e4b 100644
--- a/app-shells/scsh/files/0.6.7-Makefile.in-doc-dir-gentoo.patch
+++ b/app-shells/scsh/files/0.6.7-Makefile.in-doc-dir-gentoo.patch
@@ -1,5 +1,5 @@
---- Makefile.in.orig 2004-09-24 01:43:55.743685848 +0200
-+++ Makefile.in 2004-09-24 01:43:55.745685544 +0200
+--- a/Makefile.in.orig 2004-09-24 01:43:55.743685848 +0200
++++ b/Makefile.in 2004-09-24 01:43:55.745685544 +0200
@@ -33,7 +33,7 @@
host = @host@
### End of `configure' section###
diff --git a/app-shells/scsh/scsh-0.6.7-r2.ebuild b/app-shells/scsh/scsh-0.6.7-r2.ebuild
new file mode 100644
index 00000000000..a90d9360a7f
--- /dev/null
+++ b/app-shells/scsh/scsh-0.6.7-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit multilib
+
+MY_PV="${PV%*.*}"
+
+DESCRIPTION="Unix shell embedded in Scheme"
+HOMEPAGE="http://www.scsh.net/"
+SRC_URI="ftp://ftp.scsh.net/pub/scsh/${MY_PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="!dev-scheme/scheme48"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-Makefile.in-doc-dir-gentoo.patch"
+ "${FILESDIR}/${PV}-Makefile.in-LDFLAGS.patch"
+ "${FILESDIR}/${PV}-Missing-includes.patch"
+)
+
+RESTRICT="test" # some tests don't pass.
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ use amd64 && multilib_toolchain_setup x86
+ SCSH_LIB_DIRS="/usr/$(get_libdir)/${PN}"
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --includedir=/usr/include \
+ --with-lib-dirs-list=${SCSH_LIB_DIRS}
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ local ENVD="${T}/50scsh"
+ echo "SCSH_LIB_DIRS=\"${SCSH_LIB_DIRS}\"" > "${ENVD}" || die
+ doenvd "${ENVD}"
+}