summaryrefslogtreecommitdiff
path: root/app-shells/thefuck/thefuck-3.14.ebuild
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-01-11 17:56:08 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-01-11 17:57:30 +0100
commit56cfc287d26b0ebf0d55c33c0062df39a353caad (patch)
treee0b3e8efad1c4f08f54b9d5bf7c2a79a0c9fd435 /app-shells/thefuck/thefuck-3.14.ebuild
parentfda584284ad5b2cbaa5199d507c9ec409a2bb98d (diff)
downloadgentoo-56cfc287d26b0ebf0d55c33c0062df39a353caad.tar.gz
gentoo-56cfc287d26b0ebf0d55c33c0062df39a353caad.tar.xz
app-shells/thefuck: Version bump to 3.14
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-shells/thefuck/thefuck-3.14.ebuild')
-rw-r--r--app-shells/thefuck/thefuck-3.14.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-shells/thefuck/thefuck-3.14.ebuild b/app-shells/thefuck/thefuck-3.14.ebuild
new file mode 100644
index 00000000000..cbacf20c859
--- /dev/null
+++ b/app-shells/thefuck/thefuck-3.14.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7)"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ py.test || die
+}