summaryrefslogtreecommitdiff
path: root/app-shells
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2017-11-25 14:16:24 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-25 14:38:12 +0100
commit1e436f321483e3b85b3c289d9bf638dbf2a4d75f (patch)
tree151c94c459cf3e8b4caf172156d6b5f157153aa8 /app-shells
parentb6022616f6caeb4d701bc0e2162e91e0127f1e84 (diff)
downloadgentoo-1e436f321483e3b85b3c289d9bf638dbf2a4d75f.tar.gz
gentoo-1e436f321483e3b85b3c289d9bf638dbf2a4d75f.tar.xz
app-shells/thefuck: Version bump to 3.25 and add proxied maintainer
Closes: https://github.com/gentoo/gentoo/pull/6294 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/thefuck/Manifest1
-rw-r--r--app-shells/thefuck/metadata.xml9
-rw-r--r--app-shells/thefuck/thefuck-3.25.ebuild41
3 files changed, 50 insertions, 1 deletions
diff --git a/app-shells/thefuck/Manifest b/app-shells/thefuck/Manifest
index ca20cd21ebf..a642f807299 100644
--- a/app-shells/thefuck/Manifest
+++ b/app-shells/thefuck/Manifest
@@ -1 +1,2 @@
DIST thefuck-3.24.tar.gz 1360450 SHA256 686867f264ee34d9287814dde0e9ca5debb322deeaf0ac6773ec06f823d7c0b4 SHA512 d4949ea723cf3b080f2fbe269d0cafe3d0266089fa8cc515b3b9376b2004c045be82716cd219741a60a0e99c20575adb92339a879467f709f7ca03dcc71a5c2d WHIRLPOOL 395eb03bf8ec1504909631a7e88e2761d7778742fb52d6fd567ee4c3c1ec9186726550dde23b2234a93064d6317065852236fb83fd4bfcdb733a4d2aa7cee2e8
+DIST thefuck-3.25.tar.gz 1362279 BLAKE2B 52b3f1c8756b6981c0528fd77c18256957dd5d628ea37801b9c9abf6114e1cef8af53d9d1dd50fc7c88fad7bd628dc8373aa70dbc6933c07c63b7da31eb5d95a SHA512 c7b215358c09e1fa5e6aae519e7d6c3fd50027b4c72bb1c128786cd2cff707196f2b9b2a23dfed34d841874caab9463791e82c9083f6aac9c90f26d12a4d4598
diff --git a/app-shells/thefuck/metadata.xml b/app-shells/thefuck/metadata.xml
index 8010e62df65..e02f8f7384b 100644
--- a/app-shells/thefuck/metadata.xml
+++ b/app-shells/thefuck/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>holgersson@posteo.de</email>
+ <name>Nils Freydank</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">nvbn/thefuck</remote-id>
</upstream>
diff --git a/app-shells/thefuck/thefuck-3.25.ebuild b/app-shells/thefuck/thefuck-3.25.ebuild
new file mode 100644
index 00000000000..7c1efbcfc50
--- /dev/null
+++ b/app-shells/thefuck/thefuck-3.25.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test || die
+}