summaryrefslogtreecommitdiff
path: root/app-shells
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-02-17 10:33:25 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-02-17 10:35:47 +0000
commit3a77f9163093e6db58f4beffd654300a9e87eeff (patch)
tree269fa6beca044aa9ebf3c500cfacafcb79178024 /app-shells
parentc9c68d5695775a3967d1ef0a3586b2eeb7076afc (diff)
downloadgentoo-3a77f9163093e6db58f4beffd654300a9e87eeff.tar.gz
gentoo-3a77f9163093e6db58f4beffd654300a9e87eeff.tar.xz
app-shells/autojump: Clean up.
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/autojump/autojump-22.2.4-r3.ebuild56
-rw-r--r--app-shells/autojump/files/autojump-21.3.0-supported-shells.patch34
2 files changed, 0 insertions, 90 deletions
diff --git a/app-shells/autojump/autojump-22.2.4-r3.ebuild b/app-shells/autojump/autojump-22.2.4-r3.ebuild
deleted file mode 100644
index 4b774f94985..00000000000
--- a/app-shells/autojump/autojump-22.2.4-r3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit bash-completion-r1 python-r1 vcs-snapshot
-
-DESCRIPTION="change directory command that learns"
-HOMEPAGE="https://github.com/joelthelion/autojump"
-SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~ppc ~ppc64"
-IUSE="python test"
-
-# Not all tests pass. Need investigation.
-RESTRICT="test"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="test? ( dev-python/flake8 dev-python/tox )"
-
-src_prepare() {
- sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
- -e "s:/usr/local/share:/usr/share:" \
- -i bin/autojump.sh || die
-}
-
-src_compile() {
- :
-}
-
-src_install() {
- dobin bin/autojump
-
- insinto /etc/profile.d
- doins bin/"${PN}".sh
-
- insinto /usr/share/"${PN}"/
- doins bin/"${PN}.bash"
- doins bin/"${PN}.zsh"
- insinto /usr/share/zsh/site-functions
- doins bin/_j
-
- python_foreach_impl python_domodule bin/autojump_argparse.py bin/autojump_data.py bin/autojump_utils.py
- if use python; then
- python_foreach_impl python_domodule tools/autojump_ipython.py
- einfo 'This tool provides "j" for ipython, please add'
- einfo '"import autojump_ipython" to your ipy_user_conf.py.'
- fi
-
- doman docs/"${PN}.1"
- dodoc README.md
-}
diff --git a/app-shells/autojump/files/autojump-21.3.0-supported-shells.patch b/app-shells/autojump/files/autojump-21.3.0-supported-shells.patch
deleted file mode 100644
index a16fc2d4dcf..00000000000
--- a/app-shells/autojump/files/autojump-21.3.0-supported-shells.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- autojump-21.3.0/bin/autojump.sh
-+++ autojump-21.3.0/bin/autojump.sh
-@@ -1,17 +1,17 @@
- # source autojump on BASH or ZSH depending on the shell
-
- shell=`echo ${SHELL} | awk -F/ '{ print $NF }'`
--
--# check local install
--if [ -s ~/.autojump/etc/profile.d/autojump.${shell} ]; then
-- source ~/.autojump/etc/profile.d/autojump.${shell}
--
--# check global install
--elif [ -s /etc/profile.d/autojump.${shell} ]; then
-- source /etc/profile.d/autojump.${shell}
--
--# check custom install locations (modified by Homebrew or using --destdir option)
--elif [ -s custom_install/autojump.${shell} ]; then
-- source custom_install/autojump.${shell}
--
--fi
-+case ${shell} in
-+ bash|zsh)
-+ # check local install
-+ if [ -s ~/.autojump/etc/profile.d/autojump.${shell} ]; then
-+ source ~/.autojump/etc/profile.d/autojump.${shell}
-+ # check global install
-+ elif [ -s "${EPREFIX}"/etc/profile.d/autojump.${shell} ]; then
-+ source "${EPREFIX}"/etc/profile.d/autojump.${shell}
-+ fi
-+ ;;
-+ *)
-+ echo "Your shell ${shell} (from SHELL=${SHELL}) is unkown."
-+ ;;
-+esac