summaryrefslogtreecommitdiff
path: root/app-shells
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-06-17 16:24:29 +0200
committerFabian Groffen <grobian@gentoo.org>2018-06-17 16:24:39 +0200
commite9b10da8ccfcff1583c63c83b3762d4fe51a2812 (patch)
tree1901b573599fa0f17c2799bb06f1122c5dc580dd /app-shells
parenta85630e5f5b70fe06956f00e6b5b28d4554f47d6 (diff)
downloadgentoo-e9b10da8ccfcff1583c63c83b3762d4fe51a2812.tar.gz
gentoo-e9b10da8ccfcff1583c63c83b3762d4fe51a2812.tar.xz
app-shells/dash: fix compilation on Solaris <=10, bug #657990
Closes: https://bugs.gentoo.org/657990 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/dash/dash-0.5.10.2.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/app-shells/dash/dash-0.5.10.2.ebuild b/app-shells/dash/dash-0.5.10.2.ebuild
index d51383e2eb1..4935f47043a 100644
--- a/app-shells/dash/dash-0.5.10.2.ebuild
+++ b/app-shells/dash/dash-0.5.10.2.ebuild
@@ -55,6 +55,9 @@ src_configure() {
# don't redefine stat on Solaris
if [[ ${CHOST} == *-solaris* ]] ; then
export ac_cv_func_stat64=yes
+
+ # if your headers strictly adhere to POSIX, you'll need this too
+ [[ ${CHOST##*solaris2.} -le 10 ]] && append-cppflags -DNAME_MAX=255
fi
append-cppflags -DJOBS=$(usex libedit 1 0)
use static && append-ldflags -static