summaryrefslogtreecommitdiff
path: root/app-text/bogosort
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/bogosort
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/bogosort')
-rw-r--r--app-text/bogosort/Manifest1
-rw-r--r--app-text/bogosort/bogosort-0.4.2-r1.ebuild35
-rw-r--r--app-text/bogosort/files/bogosort-0.4.2-glibc-2.10.patch41
-rw-r--r--app-text/bogosort/files/xmalloc.patch15
-rw-r--r--app-text/bogosort/metadata.xml10
5 files changed, 102 insertions, 0 deletions
diff --git a/app-text/bogosort/Manifest b/app-text/bogosort/Manifest
new file mode 100644
index 00000000000..532e7b2b371
--- /dev/null
+++ b/app-text/bogosort/Manifest
@@ -0,0 +1 @@
+DIST bogosort-0.4.2.tar.gz 161628 SHA256 bfd66ce866bb8935088873c52323a06997f627a209da1017491425d93e5510ef SHA512 2d2f7be36ec08aa78323cbdc5f1030297706c364d6fc82554065cf737295d11c90dd6061323f2732b63c70401d710b2018075bff6d1e6ab0078069b405ea62e9 WHIRLPOOL 35402daa7555d86327d4bc9534b8d92bd0f34413241b8a24914a7bbf32a2f4c7708ea3e8fcc0420c0ba2b73a6708581df8dbfdaead3da05b77a0a9a72c6bb241
diff --git a/app-text/bogosort/bogosort-0.4.2-r1.ebuild b/app-text/bogosort/bogosort-0.4.2-r1.ebuild
new file mode 100644
index 00000000000..6796e5d0d20
--- /dev/null
+++ b/app-text/bogosort/bogosort-0.4.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A file sorting program which uses the bogosort algorithm"
+HOMEPAGE="http://www.lysator.liu.se/~qha/bogosort/"
+SRC_URI="ftp://ulrik.haugen.se/pub/unix/bogosort/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ~mips ppc sparc x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/xmalloc.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch
+}
+
+src_configure() {
+ tc-export CC
+ econf || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README NEWS ChangeLog AUTHORS || die
+}
diff --git a/app-text/bogosort/files/bogosort-0.4.2-glibc-2.10.patch b/app-text/bogosort/files/bogosort-0.4.2-glibc-2.10.patch
new file mode 100644
index 00000000000..ac54c8b61b0
--- /dev/null
+++ b/app-text/bogosort/files/bogosort-0.4.2-glibc-2.10.patch
@@ -0,0 +1,41 @@
+diff -ur bogosort-0.4.2.orig/getlines.c bogosort-0.4.2/getlines.c
+--- bogosort-0.4.2.orig/getlines.c 2002-05-04 23:22:22.000000000 +0300
++++ bogosort-0.4.2/getlines.c 2009-08-06 14:32:22.000000000 +0300
+@@ -49,7 +49,7 @@
+ char **ss = NULL;
+
+ /* read all lines available */
+- while ((s = getline(stream)) != NULL) {
++ while ((s = get_line(stream)) != NULL) {
+ if (numlines == allocated) /* make more room if needed */
+ ss = (char **)xrealloc(ss,
+ (allocated += LINESTEP) * sizeof (char *));
+@@ -81,7 +81,7 @@
+ allocated = numlines + 1; /* this is a lie, but it's close enough */
+
+ /* read all lines available */
+- while ((s = getline(stream)) != NULL) {
++ while ((s = get_line(stream)) != NULL) {
+ if (numlines == allocated) /* make more room if needed */
+ ss = (char **)xrealloc(ss,
+ (allocated += LINESTEP) * sizeof (char *));
+@@ -100,7 +100,7 @@
+ * line in stream, return NULL on EOF
+ */
+ char *
+-getline(FILE *stream)
++get_line(FILE *stream)
+ {
+ int c, numchars = 0, allocated = 0;
+ char *s = NULL;
+diff -ur bogosort-0.4.2.orig/getlines.h bogosort-0.4.2/getlines.h
+--- bogosort-0.4.2.orig/getlines.h 2002-03-16 00:04:38.000000000 +0200
++++ bogosort-0.4.2/getlines.h 2009-08-06 14:32:48.000000000 +0300
+@@ -39,6 +39,6 @@
+ * getline: return a pointer to a newly allocated string containing the next
+ * line in stream
+ */
+-char *getline(FILE *stream);
++char *get_line(FILE *stream);
+
+ #endif /* GETLINES_H */
diff --git a/app-text/bogosort/files/xmalloc.patch b/app-text/bogosort/files/xmalloc.patch
new file mode 100644
index 00000000000..41545ca34ba
--- /dev/null
+++ b/app-text/bogosort/files/xmalloc.patch
@@ -0,0 +1,15 @@
+--- xmalloc.c.orig 2004-12-15 23:44:16.880786468 +0100
++++ xmalloc.c 2004-12-15 23:44:21.846546805 +0100
+@@ -68,12 +68,6 @@
+ The caller may set it to some other value. */
+ int xmalloc_exit_failure = EXIT_FAILURE;
+
+-#if __STDC__ && (HAVE_VPRINTF || HAVE_DOPRNT)
+-void error (int, int, const char *, ...);
+-#else
+-void error ();
+-#endif
+-
+ static VOID *
+ fixup_null_alloc (n)
+ size_t n;
diff --git a/app-text/bogosort/metadata.xml b/app-text/bogosort/metadata.xml
new file mode 100644
index 00000000000..190b1c47c93
--- /dev/null
+++ b/app-text/bogosort/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <longdescription lang="en">
+ The bogosort will sort a file in a similar way to sort(1), but using
+ the bogosort algorithm rather than the conventional qsort. The tool
+ can also randomise the lines in its input.
+ </longdescription>
+</pkgmetadata>