summaryrefslogtreecommitdiff
path: root/app-text/convmv
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/convmv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/convmv')
-rw-r--r--app-text/convmv/Manifest2
-rw-r--r--app-text/convmv/convmv-1.15-r1.ebuild35
-rw-r--r--app-text/convmv/convmv-1.15.ebuild36
-rw-r--r--app-text/convmv/convmv-2.0.ebuild35
-rw-r--r--app-text/convmv/metadata.xml8
5 files changed, 116 insertions, 0 deletions
diff --git a/app-text/convmv/Manifest b/app-text/convmv/Manifest
new file mode 100644
index 00000000000..825f41d8d8c
--- /dev/null
+++ b/app-text/convmv/Manifest
@@ -0,0 +1,2 @@
+DIST convmv-1.15.tar.gz 27180 SHA256 c315aec78490b588000467d1c51081b36e629de0537c5a17fd48b1acaf8a5135 SHA512 b809f103da48d43f9c7fb6cb3e08a88e1c9b2a2ad691f9fcc4422b4e597c247b86fd0446c777e4c9911b4fad551cdc9fc88eff3a1d8cb4b001e164cc8387b900 WHIRLPOOL d7c3e3fbe918472d96f1cbc40b70f280a179a3c99cef07953c0723dfcba0e81ff383d918382b196d0525724dde650c4a480e5cc91c07f9452308a3eebd1567cc
+DIST convmv-2.0.tar.gz 29534 SHA256 170cf675be1fca77868ff472e9340ca828b1463865a63d4f4b7b3bf4053db93f SHA512 9f452551ab4ea7a45ec4e5d4e4d3c4fdb60cae49f048953d16df9ecd9ee3271c2d6748704f010af6ef312d7ce2079ae9c502e04d936419e29257f68596fc4f58 WHIRLPOOL c907bf99805e2afa7590043a291c7eaa19b681fecf9eb38314d41952edcea381f7e8bf1442226bd9c72122c3b0840e4c376f3947c4b2f65495287155a1353026
diff --git a/app-text/convmv/convmv-1.15-r1.ebuild b/app-text/convmv/convmv-1.15-r1.ebuild
new file mode 100644
index 00000000000..7125bc0f237
--- /dev/null
+++ b/app-text/convmv/convmv-1.15-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="convert filenames to utf8 or any other charset"
+HOMEPAGE="http://j3e.de/linux/convmv"
+SRC_URI="http://j3e.de/linux/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "1s|#!/usr|#!${EPREFIX}/usr|" convmv || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc CREDITS Changes TODO VERSION
+}
+
+src_test() {
+ unpack ./testsuite.tar
+
+ cd "${S}"/suite
+ ./dotests.sh || die "Tests failed"
+}
diff --git a/app-text/convmv/convmv-1.15.ebuild b/app-text/convmv/convmv-1.15.ebuild
new file mode 100644
index 00000000000..bd80ade124c
--- /dev/null
+++ b/app-text/convmv/convmv-1.15.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="convert filenames to utf8 or any other charset"
+HOMEPAGE="http://j3e.de/linux/convmv"
+SRC_URI="http://j3e.de/linux/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "1s|#!/usr|#!${EPREFIX}/usr|" convmv || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install \
+ || die "einstall failed"
+ dodoc CREDITS Changes TODO VERSION
+}
+
+src_test() {
+ unpack ./testsuite.tar
+
+ cd "${S}"/suite
+ ./dotests.sh || die "Tests failed"
+}
diff --git a/app-text/convmv/convmv-2.0.ebuild b/app-text/convmv/convmv-2.0.ebuild
new file mode 100644
index 00000000000..9db5cf978c6
--- /dev/null
+++ b/app-text/convmv/convmv-2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="convert filenames to utf8 or any other charset"
+HOMEPAGE="http://j3e.de/linux/convmv"
+SRC_URI="http://j3e.de/linux/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "1s|#!/usr|#!${EPREFIX}/usr|" convmv || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc CREDITS Changes TODO VERSION
+}
+
+src_test() {
+ unpack ./testsuite.tar
+
+ cd "${S}"/suite
+ ./dotests.sh || die "Tests failed"
+}
diff --git a/app-text/convmv/metadata.xml b/app-text/convmv/metadata.xml
new file mode 100644
index 00000000000..91c8a805afc
--- /dev/null
+++ b/app-text/convmv/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+</pkgmetadata>