summaryrefslogtreecommitdiff
path: root/app-text/dvibook
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/dvibook
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/dvibook')
-rw-r--r--app-text/dvibook/Manifest1
-rw-r--r--app-text/dvibook/dvibook-20001129.ebuild38
-rw-r--r--app-text/dvibook/files/dvibook-20001129.patch253
-rw-r--r--app-text/dvibook/metadata.xml5
4 files changed, 297 insertions, 0 deletions
diff --git a/app-text/dvibook/Manifest b/app-text/dvibook/Manifest
new file mode 100644
index 00000000000..30962f16cb6
--- /dev/null
+++ b/app-text/dvibook/Manifest
@@ -0,0 +1 @@
+DIST dvibook-20001129.tar.gz 141312 SHA256 d0217d94ecc8c15f4d5aafe94d63e26de5957882a14ea4bdd95f518bd31f125d SHA512 7d9991d8d870951f3e68a5b931ea05466b85dd5b23c5f62ebe3e4c2ddc0650677a0e65f506b7b66938f297a95200879cdbe3370e3e3a92b68bab1b671923d590 WHIRLPOOL fb5251b7f072d26201099674fb5509288bbec6629646810551ea1b1a56665a530ba1779edd56e16e19021d1843664c4e16be27a7bb79189f7d906f27e84b1439
diff --git a/app-text/dvibook/dvibook-20001129.ebuild b/app-text/dvibook/dvibook-20001129.ebuild
new file mode 100644
index 00000000000..7bd5977e70a
--- /dev/null
+++ b/app-text/dvibook/dvibook-20001129.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="DVI file utilities: dvibook, dviconcat, dvitodvi, and dviselect"
+HOMEPAGE="http://www.ctan.org/tex-archive/dviware/dvibook/"
+# Taken from: ftp://tug.ctan.org/tex-archive/dviware/${PN}.tar.gz
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="dvibook"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+
+IUSE=""
+DEPEND="x11-misc/imake
+ x11-misc/gccmakedep
+ app-text/rman"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}.patch
+}
+
+src_compile() {
+ xmkmf -a || die "xmkmf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install install.man || die
+
+ dodoc README
+}
diff --git a/app-text/dvibook/files/dvibook-20001129.patch b/app-text/dvibook/files/dvibook-20001129.patch
new file mode 100644
index 00000000000..595ac98ecac
--- /dev/null
+++ b/app-text/dvibook/files/dvibook-20001129.patch
@@ -0,0 +1,253 @@
+diff -Nur dvibook-orig/Dvibook/Imakefile dvibook/Dvibook/Imakefile
+--- dvibook-orig/Dvibook/Imakefile 1994-03-19 01:00:00.000000000 +0100
++++ dvibook/Dvibook/Imakefile 2004-07-08 09:24:05.038918792 +0200
+@@ -1,24 +1,15 @@
+-OBJS =dvibook.o
+-SRCS =dvibook.c
++#include "../Imake.Config"
+
+- LIBTEXROOT= ../
+- LIBTEXSRC = ../libtex
+- LIBTEX = $(LIBTEXSRC)/libtex.a
+- DEPLIBTEX = $(LIBTEX)
+- DEPLIBS = $(DEPLIBTEX) XawClientDepLibs
+-LOCAL_LIBRARIES = $(LIBTEX)
+-
+- DEFINES = -I$(LIBTEXROOT)
++ BINDIR = $(TEX_BINDIR)
++ MANDIR = $(TEX_MANDIR)
+
+-FILES =Imakefile dvibook.man Makefile.raw $(SRCS)
++ FILES = Imakefile dvibook.man $(SRCS)
+
+-all: dvibook
++ INCLUDES = -I$(LIBTEXROOT)
++LOCAL_LIBRARIES = $(LIBTEX)
++ DEPLIBS = $(DEPLIBTEX)
+
+-NormalProgramTarget(dvibook,$(OBJS),$(DEPLIBS),$(LOCAL_LIBRARIES),$(SYSLIBS))
+-InstallProgram(dvibook, $(BINDIR))
+-InstallManPage(dvibook,$(MANDIR))
+-DependTarget()
+-TagsTarget()
++SimpleProgramTarget(dvibook)
+
+ tar:
+ cd ../..;\
+diff -Nur dvibook-orig/Dvitodvi/Imakefile dvibook/Dvitodvi/Imakefile
+--- dvibook-orig/Dvitodvi/Imakefile 1994-03-19 01:00:00.000000000 +0100
++++ dvibook/Dvitodvi/Imakefile 2004-07-08 09:24:05.039918647 +0200
+@@ -1,24 +1,15 @@
+-OBJS =dvitodvi.o
+-SRCS =dvitodvi.c
++#include "../Imake.Config"
+
+- LIBTEXROOT= ../
+- LIBTEXSRC = ../libtex
+- LIBTEX = $(LIBTEXSRC)/libtex.a
+- DEPLIBTEX = $(LIBTEX)
+- DEPLIBS = $(DEPLIBTEX) XawClientDepLibs
+-LOCAL_LIBRARIES = $(LIBTEX)
+-
+- DEFINES = -I$(LIBTEXROOT)
++ BINDIR = $(TEX_BINDIR)
++ MANDIR = $(TEX_MANDIR)
+
+-FILES =Imakefile dvitodvi.man Makefile.raw $(SRCS)
++ FILES = Imakefile dvitodvi.man $(SRCS)
+
+-all: dvitodvi
++ INCLUDES = -I$(LIBTEXROOT)
++LOCAL_LIBRARIES = $(LIBTEX)
++ DEPLIBS = $(DEPLIBTEX)
+
+-NormalProgramTarget(dvitodvi,$(OBJS),$(DEPLIBS),$(LOCAL_LIBRARIES),$(SYSLIBS))
+-InstallProgram(dvitodvi, $(BINDIR))
+-InstallManPage(dvitodvi,$(MANDIR))
+-DependTarget()
+-TagsTarget()
++SimpleProgramTarget(dvitodvi)
+
+ tar:
+ cd ../..;\
+diff -Nur dvibook-orig/Imake.Config dvibook/Imake.Config
+--- dvibook-orig/Imake.Config 1994-03-19 01:00:00.000000000 +0100
++++ dvibook/Imake.Config 2004-07-08 09:24:05.039918647 +0200
+@@ -1,8 +1,8 @@
+ /* * Install directories for programs not related to X */
+
+-TEX_BINDIR = /srl/TeX/bin
+-TEX_MANDIR = /srl/TeX/man/man1
+-TEX_INPUTS = /srl/TeX/lib/tex/inputs
++TEX_BINDIR = /usr/bin
++TEX_MANDIR = /usr/share/man/man1
++MANSUFFIX = 1
+
+ /*
+ * Set `FONTDESC' to the location of your fontdesc file, unquoted.
+@@ -189,7 +189,7 @@
+ /*
+ * Undefine GETOP if your loader complains about multiple ref's.
+ */
+-#if 1
++#if 0
+ GETOPT=getopt.o
+ #else
+ GETOPT=
+diff -Nur dvibook-orig/libtex/error.c dvibook/libtex/error.c
+--- dvibook-orig/libtex/error.c 1994-03-19 01:00:00.000000000 +0100
++++ dvibook/libtex/error.c 2004-07-08 09:24:05.054916460 +0200
+@@ -21,7 +21,7 @@
+ #include "types.h" /* for HAVE_VPRINTF */
+ #include "error.h"
+ #include <stdio.h>
+-#include <varargs.h>
++#include <stdarg.h>
+
+ #if defined(lint) && !defined(LINT_ANYWAY)
+
+@@ -34,12 +34,9 @@
+ /* VARARGS1 ARGSUSED */
+ void panic(fmt) char *fmt; { exit(1); /* NOTREACHED */ }
+
+-#else lint
++#else /* lint */
+
+ extern char *ProgName; /* program name from argv[0] */
+-extern int errno; /* Unix system-call error */
+-extern char *sys_errlist[]; /* table of error number => string */
+-extern int sys_nerr; /* size of table */
+
+ static FILE *trap_file; /* error diversion file, if any */
+ static void (*trap_fn)(); /* trap function */
+@@ -143,10 +140,7 @@
+ (void) _doprnt(fmt, l, fp);
+ #endif
+ if (e) {
+- if (e < sys_nerr)
+- (void) fprintf(fp, ": %s", sys_errlist[e]);
+- else
+- (void) fprintf(fp, ": Unknown error code %d", e);
++ (void) fprintf(fp, ": %s", strerror(e));
+ }
+ (void) putc('\n', fp);
+ (void) fflush(fp);
+@@ -160,18 +154,11 @@
+ * Print an error message and optionally quit.
+ */
+ void
+-error(va_alist)
+- va_dcl
++error(int quit, int e, const char *fmt, ...)
+ {
+ va_list l;
+- int quit, e;
+- char *fmt;
+
+- va_start(l);
+- quit = va_arg(l, int);
+- if ((e = va_arg(l, int)) < 0)
+- e = errno;
+- fmt = va_arg(l, char *);
++ va_start(l, fmt);
+ verror(quit, (char *)NULL, fmt, l, e);
+ va_end(l);
+ }
+@@ -180,15 +167,12 @@
+ * Panic (print to stderr and abort).
+ */
+ void
+-panic(va_alist)
+- va_dcl
++panic(const char *fmt, ...)
+ {
+ va_list l;
+- char *fmt;
+
+ SetErrorTrap((void (*)())NULL); /* shut down any trap */
+- va_start(l);
+- fmt = va_arg(l, char *);
++ va_start(l, fmt);
+ verror(0, "panic: ", fmt, l, 0);
+ va_end(l);
+ abort();
+diff -Nur dvibook-orig/libtex/error.h dvibook/libtex/error.h
+--- dvibook-orig/libtex/error.h 1994-03-19 01:00:00.000000000 +0100
++++ dvibook/libtex/error.h 2004-07-08 09:24:05.054916460 +0200
+@@ -8,7 +8,7 @@
+ /*
+ * Errors.
+ */
+-void error(/* int quit, int e, char *fmt, ... */);
+-void panic(/* char *fmt, ... */);
++void error(int quit, int e, const char *fmt, ...);
++void panic(const char *fmt, ...);
+
+ void SetErrorTrap(/* void (*fn)(int quit, char *text) */);
+diff -Nur dvibook-orig/libtex/gripes0.c dvibook/libtex/gripes0.c
+--- dvibook-orig/libtex/gripes0.c 1994-03-19 01:00:00.000000000 +0100
++++ dvibook/libtex/gripes0.c 2004-07-08 09:24:05.054916460 +0200
+@@ -14,12 +14,11 @@
+ */
+
+ #include <stdio.h>
++#include <errno.h>
+ #include "types.h"
+ #include "error.h"
+ #include "gripes.h"
+
+-extern errno;
+-
+ /*
+ * Cannot allocate memory.
+ */
+diff -Nur dvibook-orig/libtex/sdecode.c dvibook/libtex/sdecode.c
+--- dvibook-orig/libtex/sdecode.c 1994-03-19 01:00:00.000000000 +0100
++++ dvibook/libtex/sdecode.c 2004-07-08 09:24:05.055916315 +0200
+@@ -10,7 +10,7 @@
+ #endif
+
+ #include <stdio.h>
+-#include <varargs.h>
++#include <stdarg.h>
+ #include "types.h"
+ #include "sdecode.h"
+
+@@ -21,7 +21,7 @@
+ static int sdset; /* flag says whether cclass[] set up */
+
+ static void args(), badarg();
+-static int scan(), scan_i(), scan_d();
++static int scan_i(), scan_d();
+
+ extern char *strsave();
+
+@@ -80,6 +80,8 @@
+ int di_bkw; /* true iff keyword is in static buffer */
+ };
+
++static int scan(register struct decode_info *di, ...);
++
+ /*
+ * `Edit' the text in the buffer in-place.
+ * Return the count of characters resulting from the edit (e.g.,
+@@ -553,17 +555,14 @@
+ }
+
+ static int
+-scan(va_alist)
+- va_dcl
++scan(register struct decode_info *di, ...)
+ {
+- register struct decode_info *di;
+ register char *fmt;
+ register int c;
+ char **fmtp;
+ va_list ap;
+
+- va_start(ap);
+- di = va_arg(ap, struct decode_info *);
++ va_start(ap, di);
+ fmtp = va_arg(ap, char **);
+ fmt = *fmtp;
+ while ((c = *fmt++) != 0) {
diff --git a/app-text/dvibook/metadata.xml b/app-text/dvibook/metadata.xml
new file mode 100644
index 00000000000..ba6a8a8800d
--- /dev/null
+++ b/app-text/dvibook/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>