summaryrefslogtreecommitdiff
path: root/app-text/glosung/glosung-3.6.4.ebuild
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2016-01-22 22:19:40 -0500
committerChris Reffett <creffett@gentoo.org>2016-01-22 22:19:40 -0500
commit64db96ccd892c0cf7cec5949908220776328d22d (patch)
tree9fa812880d6cbc611798b70ae35716ca8cd2be39 /app-text/glosung/glosung-3.6.4.ebuild
parentabf8c7bc8ccd2c33fbc29ac319b2b84fd3f5bd44 (diff)
downloadgentoo-64db96ccd892c0cf7cec5949908220776328d22d.tar.gz
gentoo-64db96ccd892c0cf7cec5949908220776328d22d.tar.xz
app-text/glosung: Version bump
Gentoo-Bug: 571144 Package-Manager: portage-2.2.26
Diffstat (limited to 'app-text/glosung/glosung-3.6.4.ebuild')
-rw-r--r--app-text/glosung/glosung-3.6.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/glosung/glosung-3.6.4.ebuild b/app-text/glosung/glosung-3.6.4.ebuild
new file mode 100644
index 00000000000..9eb8319f8cb
--- /dev/null
+++ b/app-text/glosung/glosung-3.6.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+DESCRIPTION="Watch word program for the GNOME2 desktop (watch word (german): losung)"
+HOMEPAGE="http://www.godehardt.org/losung.html"
+SRC_URI="mirror://sourceforge/glosung/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=("${FILESDIR}/${PN}-3.6.4-scons-respectflags.patch")
+
+RDEPEND="
+ dev-libs/libxml2
+ >=gnome-base/gconf-2.0:2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ net-misc/curl
+ >=x11-libs/gtk+-2.10:2
+"
+
+DEPEND="${RDEPEND}
+ >=dev-util/scons-0.93
+ >=dev-util/intltool-0.22
+ >=sys-devel/gettext-0.10
+ virtual/pkgconfig
+"
+
+src_compile() {
+ tc-export CC
+ scons ${MAKEOPTS} || die "scons make died"
+}
+
+src_install() {
+ scons install DESTDIR="${D}" || die "scons install died"
+ #Ships with an ISO-8859 encoded .desktop file, which causes validation to fail, so ship a UTF-8 version
+ cp "${FILESDIR}/glosung.desktop" "${D}/usr/share/applications"
+}