summaryrefslogtreecommitdiff
path: root/app-text/glosung
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/glosung
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/glosung')
-rw-r--r--app-text/glosung/Manifest1
-rw-r--r--app-text/glosung/files/glosung-3.6.2-glib-includes.patch11
-rw-r--r--app-text/glosung/files/glosung-3.6.2-scons-2.3.2-respectflags.patch63
-rw-r--r--app-text/glosung/files/glosung-3.6.2-scons-respectflags.patch64
-rw-r--r--app-text/glosung/files/glosung.desktop12
-rw-r--r--app-text/glosung/glosung-3.6.2-r1.ebuild51
-rw-r--r--app-text/glosung/metadata.xml11
7 files changed, 213 insertions, 0 deletions
diff --git a/app-text/glosung/Manifest b/app-text/glosung/Manifest
new file mode 100644
index 00000000000..ac78040b29f
--- /dev/null
+++ b/app-text/glosung/Manifest
@@ -0,0 +1 @@
+DIST glosung-3.6.2.tar.bz2 65089 SHA256 5b46cd776b51ea3ace6ef901512c4100e79ce5225f7d7cf910b69d930b7df4c9 SHA512 a9e16f9202092e6b73ca640787785fd6985ea1ba914260b783bf8f4b6ebbd6ed807cbdec5381059a2f905fae31b7aa844844ae2f9df0379c60e1251140760b11 WHIRLPOOL 91bb6e08f149430edb41b901072b5fe4993590f7ef173b99f313d857539e1be40dd00797b8623312da8a2909be7577d39b5804523e3b79bce00eccf919ee5a8c
diff --git a/app-text/glosung/files/glosung-3.6.2-glib-includes.patch b/app-text/glosung/files/glosung-3.6.2-glib-includes.patch
new file mode 100644
index 00000000000..715b201ca64
--- /dev/null
+++ b/app-text/glosung/files/glosung-3.6.2-glib-includes.patch
@@ -0,0 +1,11 @@
+diff -ruN glosung-3.6.2/src/losung.c glosung-3.6.2-patched/src/losung.c
+--- glosung-3.6.2/src/losung.c 2010-01-04 15:28:38.000000000 -0500
++++ glosung-3.6.2-patched/src/losung.c 2013-01-21 14:34:14.318711560 -0500
+@@ -31,7 +31,6 @@
+ #endif /* WIN32 */
+
+ #include <glib/gi18n.h>
+-#include <glib/goption.h>
+
+ #include "util.h"
+
diff --git a/app-text/glosung/files/glosung-3.6.2-scons-2.3.2-respectflags.patch b/app-text/glosung/files/glosung-3.6.2-scons-2.3.2-respectflags.patch
new file mode 100644
index 00000000000..0f4ac73a06b
--- /dev/null
+++ b/app-text/glosung/files/glosung-3.6.2-scons-2.3.2-respectflags.patch
@@ -0,0 +1,63 @@
+--- a/SConstruct
++++ b/SConstruct
+@@ -17,6 +17,7 @@
+
+
+ import os
++import SCons.Util
+
+ version = '3.6.2'
+
+@@ -32,14 +33,22 @@
+ (this option is only for packaging)''')
+
+ env = Environment (
+- LINK = 'gcc',
+- CC = 'gcc',
+ CPPPATH = '',
+ LINKFLAGS = '',
+ CCFLAGS = '',
+ ENV = os.environ,
+ TARFLAGS = '-c -j')
+
++if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+
+ if env['PLATFORM'] == 'win32':
+ prefix = ARGUMENTS.get ('PREFIX', '')
+@@ -58,7 +68,7 @@
+ BuildDir ('build', 'src')
+
+ cpppath = ['#', '#build']
+-ccflags = ['-O2', '-std=c99', '-Wall', '-g', '-Wl,--export-dynamic',
++ccflags = ['-std=c99',
+ # '-DLIBXML_STATIC',
+ '-DVERSION=\\"' + version + '\\"',
+ '-DGLOSUNG_DATA_DIR=\\"' + data_dir + '\\"',
+@@ -74,7 +74,7 @@
+ '-DGLOSUNG_DATA_DIR=\\"' + data_dir + '\\"',
+ '-DPACKAGE_PIXMAPS_DIR=\\"' + pixmap_dir + '\\"']
+
+-linkflags = ['-Wl,--export-dynamic', '-L.']
++linkflags = []
+ # -L/usr/lib'
+ # `pkg-config --libs gtk+-2.0 libxml-2.0 gconf-2.0 libcurl`
+
+@@ -83,9 +83,6 @@
+ ccflags.append ('-pg', '-fprofile-arcs')
+ linkflags.append ('-pg', '-fprofile-arcs')
+
+-if env['PLATFORM'] != 'win32':
+- linkflags.append ('-Wl,--as-needed')
+-
+ #if not (ARGUMENTS.get ('dev')):
+ if (ARGUMENTS.get ('dev')):
+ ccflags += [
diff --git a/app-text/glosung/files/glosung-3.6.2-scons-respectflags.patch b/app-text/glosung/files/glosung-3.6.2-scons-respectflags.patch
new file mode 100644
index 00000000000..15c12bf9488
--- /dev/null
+++ b/app-text/glosung/files/glosung-3.6.2-scons-respectflags.patch
@@ -0,0 +1,64 @@
+--- a/SConstruct
++++ b/SConstruct
+@@ -17,6 +17,7 @@
+
+
+ import os
++import SCons.Util
+
+ version = '3.6.2'
+
+@@ -32,14 +33,23 @@
+ (this option is only for packaging)''')
+
+ env = Environment (
+- LINK = 'gcc',
+- CC = 'gcc',
++ CC = '',
+ CPPPATH = '',
+ LINKFLAGS = '',
+ CCFLAGS = '',
+ ENV = os.environ,
+ TARFLAGS = '-c -j')
+
++if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+
+ if env['PLATFORM'] == 'win32':
+ prefix = ARGUMENTS.get ('PREFIX', '')
+@@ -58,7 +68,7 @@
+ BuildDir ('build', 'src')
+
+ cpppath = ['#', '#build']
+-ccflags = ['-O2', '-std=c99', '-Wall', '-g', '-Wl,--export-dynamic',
++ccflags = ['-std=c99',
+ # '-DLIBXML_STATIC',
+ '-DVERSION=\\"' + version + '\\"',
+ '-DGLOSUNG_DATA_DIR=\\"' + data_dir + '\\"',
+@@ -74,7 +74,7 @@
+ '-DGLOSUNG_DATA_DIR=\\"' + data_dir + '\\"',
+ '-DPACKAGE_PIXMAPS_DIR=\\"' + pixmap_dir + '\\"']
+
+-linkflags = ['-Wl,--export-dynamic', '-L.']
++linkflags = []
+ # -L/usr/lib'
+ # `pkg-config --libs gtk+-2.0 libxml-2.0 gconf-2.0 libcurl`
+
+@@ -83,9 +83,6 @@
+ ccflags.append ('-pg', '-fprofile-arcs')
+ linkflags.append ('-pg', '-fprofile-arcs')
+
+-if env['PLATFORM'] != 'win32':
+- linkflags.append ('-Wl,--as-needed')
+-
+ #if not (ARGUMENTS.get ('dev')):
+ if (ARGUMENTS.get ('dev')):
+ ccflags += [
diff --git a/app-text/glosung/files/glosung.desktop b/app-text/glosung/files/glosung.desktop
new file mode 100644
index 00000000000..7372b0f4712
--- /dev/null
+++ b/app-text/glosung/files/glosung.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=GLosung - Herrnhut's Watchwords
+Name[de]=GLosung - Herrnhuter Losungen
+Name[hu]=GLosung - Herrnhuter-i Útmutató
+Comment=Gods Word for every day
+Comment[de]=Gottes Wort für jeden Tag
+Comment[hu]=Isten igéje minden napra
+Exec=glosung
+Icon=/usr/share/glosung/glosung.png
+Terminal=false
+Type=Application
+Categories=Utility;X-Red-Hat-Extra;Spirituality;
diff --git a/app-text/glosung/glosung-3.6.2-r1.ebuild b/app-text/glosung/glosung-3.6.2-r1.ebuild
new file mode 100644
index 00000000000..2d12bf81785
--- /dev/null
+++ b/app-text/glosung/glosung-3.6.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+DESCRIPTION="Watch word program for the GNOME2 desktop (watch word (german): losung)"
+HOMEPAGE="http://www.godehardt.org/losung.html"
+SRC_URI="mirror://sourceforge/glosung/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libxml2
+ >=gnome-base/gconf-2.0:2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ net-misc/curl
+ >=x11-libs/gtk+-2.10:2
+"
+
+DEPEND="${RDEPEND}
+ >=dev-util/scons-0.93
+ >=dev-util/intltool-0.22
+ >=sys-devel/gettext-0.10
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.6.2-glib-includes.patch"
+ if has_version '>=dev-util/scons-2.3.2'; then
+ epatch "${FILESDIR}/${PN}-3.6.2-scons-2.3.2-respectflags.patch"
+ else
+ epatch "${FILESDIR}/${PN}-3.6.2-scons-respectflags.patch"
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ scons ${MAKEOPTS} || die "scons make died"
+}
+
+src_install() {
+ scons install DESTDIR="${D}" || die "scons install died"
+ #Ships with an ISO-8859 encoded .desktop file, which causes validation to fail, so ship a UTF-8 version
+ cp "${FILESDIR}/glosung.desktop" "${D}/usr/share/applications"
+}
diff --git a/app-text/glosung/metadata.xml b/app-text/glosung/metadata.xml
new file mode 100644
index 00000000000..9d0a422b1f4
--- /dev/null
+++ b/app-text/glosung/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>theology</herd>
+ <maintainer>
+ <email>theology@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">glosung</remote-id>
+ </upstream>
+</pkgmetadata>