summaryrefslogtreecommitdiff
path: root/app-text/gspell
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-20 00:46:12 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-20 01:26:47 +0200
commita31c1159fcc861cff0c8a47f200a4fb9707c1042 (patch)
tree79ce89a7a6e186eee62f17bf8f43a2c6be3fd1f8 /app-text/gspell
parent9d31b621e12c0c51a6866c1f2235828f75cc66fc (diff)
downloadgentoo-a31c1159fcc861cff0c8a47f200a4fb9707c1042.tar.gz
gentoo-a31c1159fcc861cff0c8a47f200a4fb9707c1042.tar.xz
app-text/gspell: version bump 1.4.1 → 1.4.2
Make the code navigating through PangoLogAttr more robust. Translation updates. Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'app-text/gspell')
-rw-r--r--app-text/gspell/Manifest1
-rw-r--r--app-text/gspell/gspell-1.4.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index b0d4922540b..dec486886c5 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1,2 +1,3 @@
DIST gspell-1.2.3.tar.xz 395360 SHA256 a64e158e47a6e2b8ec9a3a1fea98a416f78a13e275c909b2ed488494ff835f82 SHA512 b45f17e8707187a070d4c5d4f91e4bcbd4108e596519c2900d7ca1f35050b6b397ed8c012fa25e179dddaf8b9c3a356b26c6070698f8333dff00c57a72e47198 WHIRLPOOL 1b6f22740d2b5597c20aa6d84e3e9e0b0b50c2fccfd811f49c99dff5e3762bc91a7582f223711f0f37a95c37d302b40697bd3517c170e8991cad4d556398875f
DIST gspell-1.4.1.tar.xz 408996 SHA256 442f88fecd7f9e00a6a9d0af2d762744dd3c119217ff11d6739500f75b0f10be SHA512 ded60e876598d8b6002ea28aa9a0d8f84c56c3a46d245df051949f5400f605a666279e42949bf2bfb365cf31f4618f1ce657dd3b81ed748af1036eddc1e67f6d WHIRLPOOL 5d76db642cad3dcfdc58d7a2a5b81768b16f7c29829646c8d6517e6fbc835389affc06372b9e339bfade388debd57d3d389920b2bd1e605b1e3cbbcfdbb61f64
+DIST gspell-1.4.2.tar.xz 407356 SHA256 a59ba7e747bfbe93f6e511d7df3169d1530b518b46ca620cbc000fecbcdf0399 SHA512 00f53d3ca47a4ba1af1e8b4983a41dc6df8a9788898b45ffdd161a3fc8de28024cc985f49fbb872912c0a94addbca3b28ce2edda70eeb206a794e2bcf65e4a5e WHIRLPOOL a657ad0b6d3c41fccee2ddf09cf220acd8e59dbe687b78d61e1c25a6bf03e5033efa988587fbe511428562be85593bffefa47ee3188d48e929cca32c8aeddccf
diff --git a/app-text/gspell/gspell-1.4.2.ebuild b/app-text/gspell/gspell-1.4.2.ebuild
new file mode 100644
index 00000000000..3981f50f9f0
--- /dev/null
+++ b/app-text/gspell/gspell-1.4.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ app-text/iso-codes
+ >=app-text/enchant-1.6.0
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}