summaryrefslogtreecommitdiff
path: root/app-text/gspell
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-03-23 05:20:11 +0200
committerMart Raudsepp <leio@gentoo.org>2017-03-23 05:20:11 +0200
commitbfa73ceed71dd2657df186bad08a21ee7670394b (patch)
tree0e7b3481a9aad054593a6a3b25ecd6b1dae0b5b6 /app-text/gspell
parent839e7f4afeb51330ca9b8730be0da53c1ae40955 (diff)
downloadgentoo-bfa73ceed71dd2657df186bad08a21ee7670394b.tar.gz
gentoo-bfa73ceed71dd2657df186bad08a21ee7670394b.tar.xz
app-text/gspell: bump to 1.2.3
Package-Manager: Portage-2.3.4, Repoman-2.3.1
Diffstat (limited to 'app-text/gspell')
-rw-r--r--app-text/gspell/Manifest1
-rw-r--r--app-text/gspell/gspell-1.2.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index 8c53de5f55e..4065a88d93d 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1,2 +1,3 @@
DIST gspell-0.1.2.tar.xz 355128 SHA256 e8625c57296b6c178bc37659f023342f8edefaaa2c5eccf40de8bd479dbfa8f0 SHA512 8d9bd61f378929217b9461debb58df5070952539f30f6ee211cf13f856dfe5d5216468679a8d7d7b08df47ee6b7b45f25b2b6400212a83de9563e2bf175905bb WHIRLPOOL 44334ac608e9a66c5a6bf011ad21d7d368e29d7923079e947ed5484ae0c7847df1f29dc255979d0da844e1ecba16fa19dfae5b84aefd85287bc63de1465d3ffa
DIST gspell-1.2.2.tar.xz 395120 SHA256 d93c677b77e8b92cf00693ade6ea0d46e478fc5fe75cc508111428e77e90661e SHA512 3bc8274e63eb11e0364adfeeec5963f480180774797b675f440a092a6208121ab52a39b27e61ba8305acba954a68cdf53dbe49acb4d6ef8e5d92e8efa9824800 WHIRLPOOL c3e42a619bb42da297130485c2bb691220e6844383c66f52ee9e73c9ad1899778d23db6edfce10fd8bd52e461d8d8bc46f7a7a4b64b9e3f7475774f4b5397799
+DIST gspell-1.2.3.tar.xz 395360 SHA256 a64e158e47a6e2b8ec9a3a1fea98a416f78a13e275c909b2ed488494ff835f82 SHA512 b45f17e8707187a070d4c5d4f91e4bcbd4108e596519c2900d7ca1f35050b6b397ed8c012fa25e179dddaf8b9c3a356b26c6070698f8333dff00c57a72e47198 WHIRLPOOL 1b6f22740d2b5597c20aa6d84e3e9e0b0b50c2fccfd811f49c99dff5e3762bc91a7582f223711f0f37a95c37d302b40697bd3517c170e8991cad4d556398875f
diff --git a/app-text/gspell/gspell-1.2.3.ebuild b/app-text/gspell/gspell-1.2.3.ebuild
new file mode 100644
index 00000000000..268364a736a
--- /dev/null
+++ b/app-text/gspell/gspell-1.2.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~x86"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ app-text/iso-codes
+ >=app-text/enchant-1.6.0
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.25
+ >=dev-util/intltool-0.35.0
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}