summaryrefslogtreecommitdiff
path: root/app-text/libstaroffice/libstaroffice-0.0.3.ebuild
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-02-26 19:15:38 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-02-26 19:37:24 +0100
commitb08cfc53ed4347044930547b016e48669f6b691f (patch)
treed9abce465ca196b887043018b0d5df388a65e46e /app-text/libstaroffice/libstaroffice-0.0.3.ebuild
parente70e1b7558f3e43445cd1d54711299ec074e83c2 (diff)
downloadgentoo-b08cfc53ed4347044930547b016e48669f6b691f.tar.gz
gentoo-b08cfc53ed4347044930547b016e48669f6b691f.tar.xz
app-text/libstaroffice: 0.0.3 version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text/libstaroffice/libstaroffice-0.0.3.ebuild')
-rw-r--r--app-text/libstaroffice/libstaroffice-0.0.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-text/libstaroffice/libstaroffice-0.0.3.ebuild b/app-text/libstaroffice/libstaroffice-0.0.3.ebuild
new file mode 100644
index 00000000000..1f95c9155aa
--- /dev/null
+++ b/app-text/libstaroffice/libstaroffice-0.0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/fosnola/libstaroffice.git"
+[[ ${PV} == 9999 ]] && inherit git-r3 autotools
+
+DESCRIPTION="Import filter for old StarOffice documents"
+HOMEPAGE="https://github.com/fosnola/libstaroffice"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1+ MPL-2.0 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug doc tools +zlib"
+
+RDEPEND="
+ dev-libs/librevenge
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable tools) \
+ $(use_enable zlib zip)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}