summaryrefslogtreecommitdiff
path: root/app-text/libwpd
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-08 20:19:39 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-08 21:08:14 +0200
commit2928e92e3ff364d34f16260357bff639fcc6c14f (patch)
tree3e84eb8f56aeb5797df601b9e7b889a1246a709d /app-text/libwpd
parent5757a45d9cb9bd75bcf8d843f7847235aed0ca33 (diff)
downloadgentoo-2928e92e3ff364d34f16260357bff639fcc6c14f.tar.gz
gentoo-2928e92e3ff364d34f16260357bff639fcc6c14f.tar.xz
app-text/libwpd: 0.10.2 version bump
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'app-text/libwpd')
-rw-r--r--app-text/libwpd/Manifest1
-rw-r--r--app-text/libwpd/libwpd-0.10.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/libwpd/Manifest b/app-text/libwpd/Manifest
index ac2fd59c9a9..96e519055c8 100644
--- a/app-text/libwpd/Manifest
+++ b/app-text/libwpd/Manifest
@@ -1 +1,2 @@
DIST libwpd-0.10.1.tar.xz 524004 SHA256 09d3410bc770f9d9eedc8544b5c211771ea3322de3fee19b58ad7d40fb2984f6 SHA512 976694b5e02fd9eb0b3769d5071e9ae88505f491d8fa34473e5b99cd350060a85ddfad9b3c38e9b37a280e695e4571d353fd69fe7b69a627097587912b58ad2c WHIRLPOOL c6c1124a7124edda4dad6788794c46067ad21c8fde0765ff1b1ca6305c08139e86ac0667d6fd6ca53e4bed41ad0b7aa6b4803fad5f7f72c529cf0c3b22bc7b43
+DIST libwpd-0.10.2.tar.xz 536400 SHA256 323f68beaf4f35e5a4d7daffb4703d0566698280109210fa4eaa90dea27d6610 SHA512 821dbc0535ebd4fa41bcf984e344e11176862676c66abebe45cf4284f8de6e6cc7629f8a605b169d034a5c2f3e2461513d61e11e549ca73b8328eb66ac3bdd79 WHIRLPOOL 9ac29bab74f6131966212b932601e397fb5f291aed78e5e1e9da1bafc3ac21329bf1f3b39fde4ed8e8b84918903bb5142624a44293631c515c96b8f9d3511cd6
diff --git a/app-text/libwpd/libwpd-0.10.2.ebuild b/app-text/libwpd/libwpd-0.10.2.ebuild
new file mode 100644
index 00000000000..c541619cd91
--- /dev/null
+++ b/app-text/libwpd/libwpd-0.10.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit alternatives
+
+DESCRIPTION="WordPerfect Document import/export library"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~x86 ~x86-fbsd"
+IUSE="doc +tools"
+
+RDEPEND="dev-libs/librevenge"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable tools) \
+ --program-suffix=-${SLOT}
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-9][0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-9][0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-9][0-9]"
+ fi
+}
+
+pkg_postrm() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-9][0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-9][0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-9][0-9]"
+ fi
+}