summaryrefslogtreecommitdiff
path: root/app-text/openjade/openjade-1.3.2-r6.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/openjade/openjade-1.3.2-r6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/openjade/openjade-1.3.2-r6.ebuild')
-rw-r--r--app-text/openjade/openjade-1.3.2-r6.ebuild116
1 files changed, 116 insertions, 0 deletions
diff --git a/app-text/openjade/openjade-1.3.2-r6.ebuild b/app-text/openjade/openjade-1.3.2-r6.ebuild
new file mode 100644
index 00000000000..6f9aba742a7
--- /dev/null
+++ b/app-text/openjade/openjade-1.3.2-r6.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools sgml-catalog eutils flag-o-matic multilib
+
+DESCRIPTION="Jade is an implementation of DSSSL - an ISO standard for formatting SGML and XML documents"
+HOMEPAGE="http://openjade.sourceforge.net"
+SRC_URI="mirror://sourceforge/openjade/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="app-text/sgml-common
+ >=app-text/opensp-1.5.1"
+DEPEND="dev-lang/perl
+ ${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-deplibs.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch "${FILESDIR}"/${P}-msggen.pl.patch
+ epatch "${FILESDIR}"/${P}-respect-ldflags.patch
+ epatch "${FILESDIR}"/${P}-libosp-la.patch
+ epatch "${FILESDIR}"/${P}-gcc46.patch
+ epatch "${FILESDIR}"/${P}-darwin.patch
+
+ # Please note! Opts are disabled. If you know what you're doing
+ # feel free to remove this line. It may cause problems with
+ # docbook-sgml-utils among other things.
+ #ALLOWED_FLAGS="-O -O1 -O2 -pipe -g -march"
+ strip-flags
+
+ # Default CFLAGS and CXXFLAGS is -O2 but this make openjade segfault
+ # on hppa. Using -O1 works fine. So I force it here.
+ use hppa && replace-flags -O2 -O1
+
+ ln -s config/configure.in configure.ac || die
+ cp "${FILESDIR}"/${P}-acinclude.m4 acinclude.m4 || die
+ rm config/missing || die
+
+ AT_NOEAUTOMAKE=yes
+ eautoreconf
+
+ SGML_PREFIX="${EPREFIX}"/usr/share/sgml
+}
+
+src_configure() {
+ # We need Prefix env, bug #287358
+ export CONFIG_SHELL="${CONFIG_SHELL:-${BASH}}"
+ econf \
+ --enable-http \
+ --enable-default-catalog="${EPREFIX}"/etc/sgml/catalog \
+ --enable-default-search-path="${EPREFIX}"/usr/share/sgml \
+ --enable-splibdir="${EPREFIX}"/usr/$(get_libdir) \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --datadir="${EPREFIX}"/usr/share/sgml/${P} \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ # Bug 412725.
+ unset INCLUDE
+
+ emake -j1 SHELL="${BASH}"
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)
+
+ make DESTDIR="${D}" \
+ SHELL="${BASH}" \
+ libdir="${EPREFIX}"/usr/$(get_libdir) \
+ install install-man
+
+ prune_libtool_files
+
+ dosym openjade /usr/bin/jade
+ dosym onsgmls /usr/bin/nsgmls
+ dosym osgmlnorm /usr/bin/sgmlnorm
+ dosym ospam /usr/bin/spam
+ dosym ospent /usr/bin/spent
+ dosym osx /usr/bin/sgml2xml
+
+ insinto /usr/share/sgml/${P}/
+ doins dsssl/builtins.dsl
+
+ echo 'SYSTEM "builtins.dsl" "builtins.dsl"' > ${ED}/usr/share/sgml/${P}/catalog
+ insinto /usr/share/sgml/${P}/dsssl
+ doins dsssl/{dsssl.dtd,style-sheet.dtd,fot.dtd}
+ newins "${FILESDIR}"/${P}.dsssl-catalog catalog
+# Breaks sgml2xml among other things
+# insinto /usr/share/sgml/${P}/unicode
+# doins unicode/{catalog,unicode.sd,unicode.syn,gensyntax.pl}
+ insinto /usr/share/sgml/${P}/pubtext
+ doins pubtext/*
+
+ dodoc NEWS README VERSION
+ dohtml doc/*.htm
+
+ insinto /usr/share/doc/${PF}/jadedoc
+ doins jadedoc/*.htm
+ insinto /usr/share/doc/${PF}/jadedoc/images
+ doins jadedoc/images/*
+}
+
+sgml-catalog_cat_include "/etc/sgml/${P}.cat" \
+ "/usr/share/sgml/openjade-${PV}/catalog"
+sgml-catalog_cat_include "/etc/sgml/${P}.cat" \
+ "/usr/share/sgml/openjade-${PV}/dsssl/catalog"
+sgml-catalog_cat_include "/etc/sgml/sgml-docbook.cat" \
+ "/etc/sgml/${P}.cat"