summaryrefslogtreecommitdiff
path: root/app-text/rnv
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/rnv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/rnv')
-rw-r--r--app-text/rnv/Manifest1
-rw-r--r--app-text/rnv/files/rnv-1.7.8-respect-CFLAGS_and_CC.patch29
-rw-r--r--app-text/rnv/metadata.xml14
-rw-r--r--app-text/rnv/rnv-1.7.11.ebuild29
4 files changed, 73 insertions, 0 deletions
diff --git a/app-text/rnv/Manifest b/app-text/rnv/Manifest
new file mode 100644
index 00000000000..afa0a6ae204
--- /dev/null
+++ b/app-text/rnv/Manifest
@@ -0,0 +1 @@
+DIST rnv-1.7.11.zip 211316 SHA256 39ed53271f20517a55aa74ad5e393dca407e14512a31ecac4c223378bdd4a6ac SHA512 0d9457015e35177144eb88f6d6234e8d94c3a5a45f26f961b4aaba892bf92c0ddcaf0e037cf3fbbeecf110399760e182c20973e6ba32d1223d2f82600582a28e WHIRLPOOL fe82f65b68e55a7f607d7fb0cc200e83e6882c71226095894615822e68d06e20aebb85e80028edd3c5d4881f47779e42a26947d03757c1391ff8a1dc1a5ab175
diff --git a/app-text/rnv/files/rnv-1.7.8-respect-CFLAGS_and_CC.patch b/app-text/rnv/files/rnv-1.7.8-respect-CFLAGS_and_CC.patch
new file mode 100644
index 00000000000..7a06bca630a
--- /dev/null
+++ b/app-text/rnv/files/rnv-1.7.8-respect-CFLAGS_and_CC.patch
@@ -0,0 +1,29 @@
+--- Makefile.gnu.orig 2006-11-02 09:54:08.000000000 +0100
++++ Makefile.gnu 2008-10-14 01:45:25.000000000 +0200
+@@ -26,7 +26,7 @@
+ WARN=-Wall -Wstrict-prototypes -Wmissing-prototypes -Wcast-align
+ OPT=-O -g
+
+-CFLAGS=${INC} ${DEF} ${WARN} ${OPT}
++CLAGS=${INC} ${DEF} ${WARN} ${OPT} ${CFLAGS}
+ LFLAGS=${OPT} ${LBL}
+
+ LIBEXPAT=-lexpat
+@@ -106,6 +106,6 @@
+ .SUFFIXES: .c .o
+
+ .c.o:
+- ${CC} ${CFLAGS} -c -o $@ $<
++ ${CC} ${CLAGS} -c -o $@ $<
+
+ all: rnv arx rvp xsdck test
+
+--- Makefile.gnu.orig 2008-10-27 20:08:38.000000000 +0100
++++ Makefile.gnu 2008-10-27 20:08:56.000000000 +0100
+@@ -1,6 +1,5 @@
+
+ VERSION=1.7.8
+-CC=cc
+
+ # optional features
+ M_STATIC=0
diff --git a/app-text/rnv/metadata.xml b/app-text/rnv/metadata.xml
new file mode 100644
index 00000000000..64bd34360c4
--- /dev/null
+++ b/app-text/rnv/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>l.valerimanera@gmail.com</email>
+ </maintainer>
+ <maintainer>
+ <email>dma05@web.de</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">rnv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/rnv/rnv-1.7.11.ebuild b/app-text/rnv/rnv-1.7.11.ebuild
new file mode 100644
index 00000000000..42cce74a995
--- /dev/null
+++ b/app-text/rnv/rnv-1.7.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A lightweight Relax NG Compact Syntax validator"
+HOMEPAGE="http://www.davidashen.net/rnv.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="dev-libs/expat"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ sed -i -e "/^AR/s/ar/$(tc-getAR)/" Makefile.in || die 'sed on Makefile.in failed'
+}
+
+src_install() {
+ dobin rnv rvp arx
+ dodoc readme.txt
+}