summaryrefslogtreecommitdiff
path: root/app-text/sary
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/sary
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/sary')
-rw-r--r--app-text/sary/Manifest1
-rw-r--r--app-text/sary/metadata.xml10
-rw-r--r--app-text/sary/sary-1.2.0-r1.ebuild42
3 files changed, 53 insertions, 0 deletions
diff --git a/app-text/sary/Manifest b/app-text/sary/Manifest
new file mode 100644
index 00000000000..dc4b98d945e
--- /dev/null
+++ b/app-text/sary/Manifest
@@ -0,0 +1 @@
+DIST sary-1.2.0.tar.gz 393787 SHA256 d4b16e32c97a253b546922d2926c8600383352f0af0d95e2938b6d846dfc6a11 SHA512 0eeae82a384970b4d96f7a0ca3929e74d17b8b3ebc61459ec9fc7172e61c3835ffe2de8aaab7ebd64f54be24d39f6734949ebc98758c28cec299b3bd25020632 WHIRLPOOL 0a63d5a507da154588228e18c777eaca251888b7b67342c31775d6f1d8b0c9f877b2e79be473807ab08dc4d9cb87779cac3bdd8290a64333b3507b65583ac7d2
diff --git a/app-text/sary/metadata.xml b/app-text/sary/metadata.xml
new file mode 100644
index 00000000000..47b74cfd91c
--- /dev/null
+++ b/app-text/sary/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+<longdescription>Sary is a suffix array library and tools. It provides
+fast full-text search facilities for text files on the order of 10 to
+100 MB using a data structure called a suffix array. It can also
+search specific fields in a text file by assigning index points to
+those fields.</longdescription>
+</pkgmetadata>
diff --git a/app-text/sary/sary-1.2.0-r1.ebuild b/app-text/sary/sary-1.2.0-r1.ebuild
new file mode 100644
index 00000000000..097ea4fb730
--- /dev/null
+++ b/app-text/sary/sary-1.2.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools
+
+DESCRIPTION="Sary: suffix array library and tools"
+HOMEPAGE="http://sary.sourceforge.net/"
+SRC_URI="http://sary.sourceforge.net/${P}.tar.gz"
+IUSE="static-libs"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+SLOT="0"
+RESTRICT="test"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ echo "libsary_la_LIBADD = @GLIB_LIBS@" >> sary/Makefile.am || die
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in || die
+ eautoreconf
+}
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docsdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ install
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -delete
+ fi
+
+}