summaryrefslogtreecommitdiff
path: root/app-text/wgetpaste
diff options
context:
space:
mode:
authorNicholas Vinson <nvinson234@gmail.com>2016-12-17 09:09:16 -0800
committerNicholas Vinson <nvinson234@gmail.com>2016-12-17 09:14:34 -0800
commit8af5f47d02439a17b9d1453bc9ca83b093a9e4c1 (patch)
tree6e8467c473ade54a673d89684d622e5e059b5906 /app-text/wgetpaste
parent85e0c86286792ba8305c3c3c14899716333c72d3 (diff)
downloadgentoo-8af5f47d02439a17b9d1453bc9ca83b093a9e4c1.tar.gz
gentoo-8af5f47d02439a17b9d1453bc9ca83b093a9e4c1.tar.xz
app-text/wgetpaste: Add wget SSL support
Many of the paste bins wgetpaste supports require SSL. This includes the current default paste bin. Without wget SSL support, these paste bins are not accessible. This change allows wgetpaste to depend on ssl-enabled wget. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text/wgetpaste')
-rw-r--r--app-text/wgetpaste/wgetpaste-2.28-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/wgetpaste/wgetpaste-2.28-r1.ebuild b/app-text/wgetpaste/wgetpaste-2.28-r1.ebuild
new file mode 100644
index 00000000000..6c3eff136a9
--- /dev/null
+++ b/app-text/wgetpaste/wgetpaste-2.28-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+DESCRIPTION="Command-line interface to various pastebins"
+HOMEPAGE="http://wgetpaste.zlin.dk/"
+SRC_URI="http://wgetpaste.zlin.dk/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="+ssl"
+
+DEPEND=""
+RDEPEND="net-misc/wget[ssl?]"
+
+src_prepare() {
+ sed -i -e "s:/etc:\"${EPREFIX}\"/etc:g" wgetpaste || die
+ default
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/zsh/site-functions
+ doins _wgetpaste
+}