summaryrefslogtreecommitdiff
path: root/app-vim/slimv
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/slimv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/slimv')
-rw-r--r--app-vim/slimv/Manifest2
-rw-r--r--app-vim/slimv/metadata.xml22
-rw-r--r--app-vim/slimv/slimv-0.9.11.ebuild31
-rw-r--r--app-vim/slimv/slimv-0.9.12-r1.ebuild34
-rw-r--r--app-vim/slimv/slimv-0.9.12.ebuild31
5 files changed, 120 insertions, 0 deletions
diff --git a/app-vim/slimv/Manifest b/app-vim/slimv/Manifest
new file mode 100644
index 00000000000..42d9e0dbc39
--- /dev/null
+++ b/app-vim/slimv/Manifest
@@ -0,0 +1,2 @@
+DIST slimv-0.9.11.tar.bz2 614946 SHA256 97213b2e31c8a5aaf73e3852b27bc08f7556513dfc854bc617628e6bd1d1f579 SHA512 883339af9dcc4a23cd5c142dc849dc064e8785ddd509163c0e31ad81418c5231506209d5b1b089d8dc4b4161ebf49ff65b8898c258522993ee72b5e630106726 WHIRLPOOL 28dd1574ffe974a6e0f6ea1803f1a49126dd99b406083ef437fa3b206844ad87c15dbfe2593acf787875873812642ddd81d27ab2d3f3fe5efe4430b016f8bfca
+DIST slimv-0.9.12.tar.bz2 614025 SHA256 ee7785027191fc74041d874e3a390cdd4044dc9dcd85392671016601b77161b1 SHA512 7ccf617780c5d6b8d25738546cb9df6986b4409748a5938e8d9112b057d34626a6b8525fb8622db06d0f300d6ec38f7513ef2c0e49df3bcd89614888887ca057 WHIRLPOOL c455c56422714af809efe18a05e2d12542030bf83d90b11656570e0df94f67624398b7a5953e8b5f1892121ccec3b6608a726b25cf261bbcec6691b94f02a740
diff --git a/app-vim/slimv/metadata.xml b/app-vim/slimv/metadata.xml
new file mode 100644
index 00000000000..6e78b9a3677
--- /dev/null
+++ b/app-vim/slimv/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <longdescription lang="en">
+ Slimv tries to mimic a subset of SLIME's (Superior Lisp Interaction Mode
+ for Emacs) functionality inside Vim. The script defines functions and
+ keybindings to send s-expressions to a console mode Lisp or Clojure REPL
+ (Read-Eval-Print Loop).
+
+ Slimv runs its own REPL or connects to a running REPL started by a
+ previous Slimv session, the connection is established when the first
+ Slimv command is executed (e.g. an s-expression is evaluated). The Lisp
+ REPL buffer can also be opened inside Vim as a Vim buffer with syntax
+ highlighting and autoindenting, Lisp commands may be entered in the
+ command line, just as in a regular REPL. The script also has a basic
+ support for Clojure REPL.
+
+ The script also supports a number of other features provided by SLIME
+ including profiling, paredit mode, and hyperspec lookups.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-vim/slimv/slimv-0.9.11.ebuild b/app-vim/slimv/slimv-0.9.11.ebuild
new file mode 100644
index 00000000000..f5a8a95b2d5
--- /dev/null
+++ b/app-vim/slimv/slimv-0.9.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin vcs-snapshot
+
+DESCRIPTION="vim plugin: aid Lisp development by providing a SLIME-like Lisp and Clojure REPL"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2531"
+SRC_URI="https://bitbucket.org/kovisoft/${PN}/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="public-domain"
+KEYWORDS="amd64 x86"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ >=dev-lang/python-2.4
+ || (
+ dev-lisp/clisp
+ dev-lang/clojure
+ dev-lisp/abcl
+ dev-lisp/clozurecl
+ dev-lisp/ecls
+ dev-lisp/sbcl
+ )"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ # remove emacs related files
+ rm -r slime swank-clojure || die
+}
diff --git a/app-vim/slimv/slimv-0.9.12-r1.ebuild b/app-vim/slimv/slimv-0.9.12-r1.ebuild
new file mode 100644
index 00000000000..533c5124fc1
--- /dev/null
+++ b/app-vim/slimv/slimv-0.9.12-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 vim-plugin vcs-snapshot
+
+DESCRIPTION="vim plugin: aid Lisp development by providing a SLIME-like Lisp and Clojure REPL"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2531"
+SRC_URI="https://bitbucket.org/kovisoft/${PN}/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}
+ || (
+ dev-lisp/clisp
+ dev-lang/clojure
+ dev-lisp/abcl
+ dev-lisp/clozurecl
+ dev-lisp/ecls
+ dev-lisp/sbcl
+ )"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ # remove emacs related files
+ rm -r slime swank-clojure || die
+}
diff --git a/app-vim/slimv/slimv-0.9.12.ebuild b/app-vim/slimv/slimv-0.9.12.ebuild
new file mode 100644
index 00000000000..0ffa4878879
--- /dev/null
+++ b/app-vim/slimv/slimv-0.9.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin vcs-snapshot
+
+DESCRIPTION="vim plugin: aid Lisp development by providing a SLIME-like Lisp and Clojure REPL"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2531"
+SRC_URI="https://bitbucket.org/kovisoft/${PN}/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="public-domain"
+KEYWORDS="amd64 x86"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ >=dev-lang/python-2.4
+ || (
+ dev-lisp/clisp
+ dev-lang/clojure
+ dev-lisp/abcl
+ dev-lisp/clozurecl
+ dev-lisp/ecls
+ dev-lisp/sbcl
+ )"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ # remove emacs related files
+ rm -r slime swank-clojure || die
+}