summaryrefslogtreecommitdiff
path: root/app-vim/vim-autoclose/vim-autoclose-2.0.ebuild
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-02-27 23:50:47 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-27 23:51:05 +0100
commit6136ecf2da97e6e997097fac597cf509a26e3b84 (patch)
tree7cd918dc59a0009963d0120347ff295f7bc2fe42 /app-vim/vim-autoclose/vim-autoclose-2.0.ebuild
parentf70574691bd93d3b512520ef86c14e28642c283d (diff)
downloadgentoo-6136ecf2da97e6e997097fac597cf509a26e3b84.tar.gz
gentoo-6136ecf2da97e6e997097fac597cf509a26e3b84.tar.xz
app-vim/vim-autoclose: new package.
autoclose is a plugin to automatically open and close pair or characters. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-vim/vim-autoclose/vim-autoclose-2.0.ebuild')
-rw-r--r--app-vim/vim-autoclose/vim-autoclose-2.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/vim-autoclose/vim-autoclose-2.0.ebuild b/app-vim/vim-autoclose/vim-autoclose-2.0.ebuild
new file mode 100644
index 00000000000..f3f5770eb2e
--- /dev/null
+++ b/app-vim/vim-autoclose/vim-autoclose-2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: open-close pair of characters"
+HOMEPAGE="https://github.com/Townk/vim-autoclose"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ mv * "${P}" || die
+}