summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-03-26 11:38:56 -0400
committerTim Harder <radhermit@gentoo.org>2016-03-26 11:49:25 -0400
commite39e80be5700c151c4c668b8be5a9e543a056380 (patch)
tree4219c32533417864ba6f7044f7fffc7f899d80f7 /app-vim
parent8c3e372d2bb812e0d2f4de7fdf794c4a519bdec7 (diff)
downloadgentoo-e39e80be5700c151c4c668b8be5a9e543a056380.tar.gz
gentoo-e39e80be5700c151c4c668b8be5a9e543a056380.tar.xz
app-vim/vimtex: initial import
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimtex/Manifest1
-rw-r--r--app-vim/vimtex/metadata.xml11
-rw-r--r--app-vim/vimtex/vimtex-20160324.ebuild21
3 files changed, 33 insertions, 0 deletions
diff --git a/app-vim/vimtex/Manifest b/app-vim/vimtex/Manifest
new file mode 100644
index 00000000000..74f6dcaa663
--- /dev/null
+++ b/app-vim/vimtex/Manifest
@@ -0,0 +1 @@
+DIST vimtex-20160324.tar.bz2 95040 SHA256 4afc63478fc6480bb2240613efef89c498806be5b17383edf3f2e5ed3c1f11c0 SHA512 0c0d2a95f3b62239f47113f5b8876728d6d9fddf7e526477e92ef1f09317cb607ddd3b2aa07f6e8bebd357308adf21e4c353795952dc30372b493963bd0554ff WHIRLPOOL a7bb550a7ebf4f3b9395d44620e883c91ae238729b0cdc912baf4a83fd95f0ffc145edf0c2b34a6b08ad6953467e0610ea8e57101d5ad188c0349d87ff1345cb
diff --git a/app-vim/vimtex/metadata.xml b/app-vim/vimtex/metadata.xml
new file mode 100644
index 00000000000..761c713e285
--- /dev/null
+++ b/app-vim/vimtex/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lervag/vimtex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vimtex/vimtex-20160324.ebuild b/app-vim/vimtex/vimtex-20160324.ebuild
new file mode 100644
index 00000000000..b45bf56f882
--- /dev/null
+++ b/app-vim/vimtex/vimtex-20160324.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: a modern vim plugin for editing LaTeX files"
+HOMEPAGE="https://github.com/lervag/vimtex"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="!app-vim/vim-latex
+ virtual/latex-base
+ dev-tex/latexmk"
+
+src_prepare() {
+ rm -rf *.md test || die
+}