summaryrefslogtreecommitdiff
path: root/dev-ada/gnatcoll
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-07-05 22:26:56 +0200
committerTupone Alfredo <tupone@gentoo.org>2017-07-05 22:27:21 +0200
commitbbb0250a9d9849cf72b527b75205bc3107025546 (patch)
treec0f436fc0c3c648142cdccb8685ad3394e3c3584 /dev-ada/gnatcoll
parent41c32ee395dd63146eac41cdcfff14522ef1c91d (diff)
downloadgentoo-bbb0250a9d9849cf72b527b75205bc3107025546.tar.gz
gentoo-bbb0250a9d9849cf72b527b75205bc3107025546.tar.xz
dev-ada/gnatcoll: Add tools use flag to build gnatcoll_db2ada
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-ada/gnatcoll')
-rw-r--r--dev-ada/gnatcoll/files/gnatcoll-2016-gentoo.patch21
-rw-r--r--dev-ada/gnatcoll/gnatcoll-2016.ebuild15
-rw-r--r--dev-ada/gnatcoll/gnatcoll-2017.ebuild9
-rw-r--r--dev-ada/gnatcoll/metadata.xml14
4 files changed, 31 insertions, 28 deletions
diff --git a/dev-ada/gnatcoll/files/gnatcoll-2016-gentoo.patch b/dev-ada/gnatcoll/files/gnatcoll-2016-gentoo.patch
index a54a7c12566..1a1d4d14eec 100644
--- a/dev-ada/gnatcoll/files/gnatcoll-2016-gentoo.patch
+++ b/dev-ada/gnatcoll/files/gnatcoll-2016-gentoo.patch
@@ -23,27 +23,6 @@
#######################################################################
# install
-@@ -53,7 +53,7 @@
- #######################################################################
- # install
-
--GPRINST_OPTS=-p -f --prefix=${prefix} --install-name=gnatcoll \
-+GPRINST_OPTS=-p -f --prefix=$(DESTDIR)${prefix} --install-name=gnatcoll \
- --exec-subdir=${bindir} --project-subdir=lib/gnat \
- --build-var=LIBRARY_TYPE --build-name=$(@F) -XLIBRARY_TYPE=$(@F)
-
-@@ -73,9 +73,9 @@
- ${GPRINSTALL} --mode=usage ${GPRINST_OPTS} -Psrc/gnatcoll_tools
-
- install_gps_plugin: force
-- mkdir -p $(prefix)/share/gps/plug-ins
-+ mkdir -p $(DESTDIR)$(prefix)/share/gps/plug-ins
- (cd distrib/ ; tar cf - gnatcoll) | \
-- (cd $(prefix)/share/gps/plug-ins ; tar xf -)
-+ (cd $(DESTDIR)$(prefix)/share/gps/plug-ins ; tar xf -)
-
- # Regenerate part of the sources. Unfortunately, this can be run only after
- # we have build GNATCOLL, and then its tools, even though GNATCOLL itself
--- gnatcoll-gpl-2015-src/src/gnatcoll_gmp.gpr.in.old 2017-01-07 08:52:14.921110195 +0100
+++ gnatcoll-gpl-2015-src/src/gnatcoll_gmp.gpr.in 2017-01-07 08:55:35.718946607 +0100
@@ -24,6 +24,7 @@
diff --git a/dev-ada/gnatcoll/gnatcoll-2016.ebuild b/dev-ada/gnatcoll/gnatcoll-2016.ebuild
index 9ceb0858a42..165b27e6abd 100644
--- a/dev-ada/gnatcoll/gnatcoll-2016.ebuild
+++ b/dev-ada/gnatcoll/gnatcoll-2016.ebuild
@@ -16,7 +16,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="gmp gnat_2016 gnat_2017 gtk iconv postgresql pygobject projects readline
- +shared sqlite static syslog"
+ +shared sqlite static syslog tools"
RDEPEND="gnat_2016? ( dev-lang/gnat-gpl:4.9.4 )
gnat_2017? ( dev-lang/gnat-gpl:6.3.0 )
@@ -101,17 +101,24 @@ src_compile() {
emake PROCESSORS=$(makeopts_jobs) GPRBUILD_OPTIONS=-v GCC=${GCC} \
build_library_type/static
fi
+ if use tools; then
+ emake PROCESSORS=$(makeopts_jobs) GPRBUILD_OPTIONS=-v GCC=${GCC} \
+ build_tools/static
+ fi
python_fix_shebang .
}
src_install() {
if use shared; then
- emake DESTDIR="${D}" install_library_type/relocatable
+ emake prefix="${D}usr" install_library_type/relocatable
fi
if use static; then
- emake DESTDIR="${D}" install_library_type/static
+ emake prefix="${D}usr" install_library_type/static
+ fi
+ if use tools; then
+ emake prefix="${D}usr" install_tools/static
fi
- emake DESTDIR="${D}" install_gps_plugin
+ emake prefix="${D}usr" install_gps_plugin
einstalldocs
dodoc -r features-* known-problems-*
mv "${D}"/usr/share/doc/${PN}/GNATColl.pdf "${D}"/usr/share/doc/${PF}/
diff --git a/dev-ada/gnatcoll/gnatcoll-2017.ebuild b/dev-ada/gnatcoll/gnatcoll-2017.ebuild
index 21b6e39c137..9656c9a094e 100644
--- a/dev-ada/gnatcoll/gnatcoll-2017.ebuild
+++ b/dev-ada/gnatcoll/gnatcoll-2017.ebuild
@@ -16,7 +16,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="gmp gnat_2016 gnat_2017 gtk iconv postgresql pygobject projects readline
- +shared sqlite static syslog"
+ +shared sqlite static syslog tools"
RDEPEND="gnat_2016? ( dev-lang/gnat-gpl:4.9.4 )
gnat_2017? ( dev-lang/gnat-gpl:6.3.0 )
@@ -101,6 +101,10 @@ src_compile() {
emake PROCESSORS=$(makeopts_jobs) GPRBUILD_OPTIONS=-v GCC=${GCC} \
build_library_type/static
fi
+ if use tools; then
+ emake PROCESSORS=$(makeopts_jobs) GPRBUILD_OPTIONS=-v GCC=${GCC} \
+ build_tools/static
+ fi
python_fix_shebang .
}
@@ -111,6 +115,9 @@ src_install() {
if use static; then
emake prefix="${D}usr" install_library_type/static
fi
+ if use tools; then
+ emake prefix="${D}usr" install_tools/static
+ fi
emake prefix="${D}usr" install_gps_plugin
einstalldocs
}
diff --git a/dev-ada/gnatcoll/metadata.xml b/dev-ada/gnatcoll/metadata.xml
index a54b19b4b3c..cca8442f43b 100644
--- a/dev-ada/gnatcoll/metadata.xml
+++ b/dev-ada/gnatcoll/metadata.xml
@@ -13,10 +13,20 @@
<flag name="pygobject">Adds support for pygobject</flag>
<flag name="shared">Build shared library</flag>
<flag name="static">Build static library</flag>
+ <flag name="tools">Build associated tools</flag>
</use>
<longdescription lang="en">
- The reusable library known as the GNAT Component Collection (GNATColl) is based on one main principle: general-purpose packages that are part of the GNAT technology should also be available to GNAT user application code. The compiler front end, the GNAT Programming Studio (GPS) Interactive Development Environment, and the GNAT Tracker web-based interface all served as sources for the components.
+ The reusable library known as the GNAT Component Collection (GNATColl)
+ is based on one main principle: general-purpose packages that are part
+ of the GNAT technology should also be available to GNAT user
+ application code. The compiler front end, the GNAT Programming Studio
+ (GPS) Interactive Development Environment, and the GNAT Tracker
+ web-based interface all served as sources for the components.
- The GNATColl components complement the predefined Ada and GNAT libraries and deal with a range of common programming issues including string and text processing, memory management, and file handling. Several of the components are especially useful in enterprise applications.
+ The GNATColl components complement the predefined Ada and GNAT
+ libraries and deal with a range of common programming issues including
+ string and text processing, memory management, and file handling.
+ Several of the components are especially useful in enterprise
+ applications.
</longdescription>
</pkgmetadata>