summaryrefslogtreecommitdiff
path: root/dev-cpp/gtest/files
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-08-20 21:48:10 -0400
committerPatrice Clement <monsieurp@gentoo.org>2017-08-29 22:30:15 +0200
commitfb37bc926a630ca175bc424843d57fe9d21a8f0a (patch)
treec0bf6309c147eda74ea20627db683837cb300b9e /dev-cpp/gtest/files
parent312c0e521f86798ac3209e25641c41e9829f9d2d (diff)
downloadgentoo-fb37bc926a630ca175bc424843d57fe9d21a8f0a.tar.gz
gentoo-fb37bc926a630ca175bc424843d57fe9d21a8f0a.tar.xz
dev-cpp/gtest: version bump to 1.8.0.
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=602218 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-cpp/gtest/files')
-rw-r--r--dev-cpp/gtest/files/gtest-1.8.0-multilib-strict.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-cpp/gtest/files/gtest-1.8.0-multilib-strict.patch b/dev-cpp/gtest/files/gtest-1.8.0-multilib-strict.patch
new file mode 100644
index 00000000000..c18b58e16fb
--- /dev/null
+++ b/dev-cpp/gtest/files/gtest-1.8.0-multilib-strict.patch
@@ -0,0 +1,40 @@
+--- a/googlemock/CMakeLists.txt
++++ b/googlemock/CMakeLists.txt
+@@ -11,6 +11,8 @@
+
+ option(gmock_build_tests "Build all of Google Mock's own tests." OFF)
+
++set(LIB_INSTALL_DIR lib CACHE STRING "Library install directory")
++
+ # A directory to find Google Test sources.
+ if (EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/gtest/CMakeLists.txt")
+ set(gtest_dir gtest)
+@@ -104,7 +106,7 @@
+ #
+ # Install rules
+ install(TARGETS gmock gmock_main
+- DESTINATION lib)
++ DESTINATION ${LIB_INSTALL_DIR})
+ install(DIRECTORY ${gmock_SOURCE_DIR}/include/gmock
+ DESTINATION include)
+
+--- a/googletest/CMakeLists.txt
++++ b/googletest/CMakeLists.txt
+@@ -27,6 +27,8 @@
+ "Build gtest with internal symbols hidden in shared libraries."
+ OFF)
+
++set(LIB_INSTALL_DIR lib CACHE STRING "Library install directory")
++
+ # Defines pre_project_set_up_hermetic_build() and set_up_hermetic_build().
+ include(cmake/hermetic_build.cmake OPTIONAL)
+
+@@ -103,7 +105,7 @@
+ #
+ # Install rules
+ install(TARGETS gtest gtest_main
+- DESTINATION lib)
++ DESTINATION ${LIB_INSTALL_DIR})
+ install(DIRECTORY ${gtest_SOURCE_DIR}/include/gtest
+ DESTINATION include)
+