summaryrefslogtreecommitdiff
path: root/dev-cpp/gtkmm-utils
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-23 12:03:40 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-23 12:03:40 +0100
commit75c13e9e91c547a7615dac8bbde7f3634b95d87c (patch)
tree2462d01db05a35761d6d458ef08a6021791a6eeb /dev-cpp/gtkmm-utils
parente5c4b5fc6265b29c24bef9f4a220d7a8f31b9da6 (diff)
downloadgentoo-75c13e9e91c547a7615dac8bbde7f3634b95d87c.tar.gz
gentoo-75c13e9e91c547a7615dac8bbde7f3634b95d87c.tar.xz
dev-cpp/gtkmm-utils: Fix building with latest glibmm/libsigc++
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-cpp/gtkmm-utils')
-rw-r--r--dev-cpp/gtkmm-utils/gtkmm-utils-0.4.1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-cpp/gtkmm-utils/gtkmm-utils-0.4.1.ebuild b/dev-cpp/gtkmm-utils/gtkmm-utils-0.4.1.ebuild
index ea91835d54e..cb1da71e662 100644
--- a/dev-cpp/gtkmm-utils/gtkmm-utils-0.4.1.ebuild
+++ b/dev-cpp/gtkmm-utils/gtkmm-utils-0.4.1.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-
-inherit eutils
+EAPI=5
+inherit eutils flag-o-matic
DESCRIPTION="Utility functions, classes and widgets written on top of gtkmm and
glibmm."
@@ -28,5 +27,11 @@ src_prepare() {
}
src_configure() {
+ append-cxxflags -std=c++11
econf $(use_enable doc documentation)
}
+
+src_install() {
+ default
+ prune_libtool_files
+}