summaryrefslogtreecommitdiff
path: root/dev-cpp/lucene++
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/lucene++
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/lucene++')
-rw-r--r--dev-cpp/lucene++/Manifest2
-rw-r--r--dev-cpp/lucene++/files/lucene++-3.0.6-disable-demos.patch13
-rw-r--r--dev-cpp/lucene++/files/lucene++-3.0.6-disable-tests.patch42
-rw-r--r--dev-cpp/lucene++/files/lucene++-3.0.6-fix-installing-headers.patch39
-rw-r--r--dev-cpp/lucene++/lucene++-3.0.6.ebuild39
-rw-r--r--dev-cpp/lucene++/lucene++-3.0.7.ebuild35
-rw-r--r--dev-cpp/lucene++/metadata.xml12
7 files changed, 182 insertions, 0 deletions
diff --git a/dev-cpp/lucene++/Manifest b/dev-cpp/lucene++/Manifest
new file mode 100644
index 00000000000..611bcb35f96
--- /dev/null
+++ b/dev-cpp/lucene++/Manifest
@@ -0,0 +1,2 @@
+DIST lucene++-3.0.6.tar.gz 1529066 SHA256 3e7092a4935e0d1ad5c6d7ac8f3c6ed2f53e51321237ce83744bbf02e0d61519 SHA512 c65aac4cdc92b4593a7d9996273047ff68cc097b755bacdd424266ffcf9143b491ef91123b8e78d9f1fba3d9ac39078a0c2c97c22a39f646f84a0fef0f2956ef WHIRLPOOL 7064b69214d62e05986c78fee2873222c85c2a7a4c892fcc29a5b47f0b1cb67e64789f3665dc3b8ca3628daf28e05c331a99cd0111062683e9323a6827e7ebf5
+DIST lucene++-3.0.7.tar.gz 2013570 SHA256 6c19f203311e4b44a0ccf7b1127db77436eb47159ea1c54f7531a0b1ca585e0c SHA512 92f3bba320980673cc64c983616aa38d25b44ea811237ed226741b892757fb8151e4f833aa58a18dbe7a0c9a899d94e828aa15e6d7b48a69ab730d1d772db220 WHIRLPOOL e5d18d6d0ac90f8b0ace161dc0457b2ca3546c211e96ac3c44dea4ba7d9bbd6bd9183016ceb2bccd8516261db0ca2dd4331701bb37e653e96df9453d6acbc878
diff --git a/dev-cpp/lucene++/files/lucene++-3.0.6-disable-demos.patch b/dev-cpp/lucene++/files/lucene++-3.0.6-disable-demos.patch
new file mode 100644
index 00000000000..ba5deca413c
--- /dev/null
+++ b/dev-cpp/lucene++/files/lucene++-3.0.6-disable-demos.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9217c21..d4e7b86 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -118,7 +118,7 @@ enable_testing()
+
+ add_subdirectory(src/core)
+ add_subdirectory(src/contrib)
+-add_subdirectory(src/demo)
++#add_subdirectory(src/demo)
+ add_subdirectory(src/test)
+
+ #################################
diff --git a/dev-cpp/lucene++/files/lucene++-3.0.6-disable-tests.patch b/dev-cpp/lucene++/files/lucene++-3.0.6-disable-tests.patch
new file mode 100644
index 00000000000..1fae17e71d3
--- /dev/null
+++ b/dev-cpp/lucene++/files/lucene++-3.0.6-disable-tests.patch
@@ -0,0 +1,42 @@
+Forwarded: https://github.com/luceneplusplus/LucenePlusPlus/pull/64
+Author: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
+Description: Disabling tests until we find a proper way for building and including gtest
+ In the next release this might become possible, after commit 83356d9681fb52
+ https://github.com/luceneplusplus/LucenePlusPlus/commit/83356d9681fb52a4c190d2cf033279006c1bf57d
+Last-Update: 2014-08-25
+--- a/CMakeExternal.txt
++++ b/CMakeExternal.txt
+@@ -1,5 +1,6 @@
+ # Enable ExternalProject CMake module
+ include(ExternalProject)
++find_package(Subversion REQUIRED)
+
+ # main directory for external projects
+ set_directory_properties(PROPERTIES EP_PREFIX ${CMAKE_CURRENT_BINARY_DIR}/ThirdParty)
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -49,7 +49,6 @@
+ # bootstrap
+ ####################################
+
+-find_package(Subversion REQUIRED)
+ find_package(Threads REQUIRED)
+ find_package(Boost COMPONENTS
+ date_time
+@@ -114,13 +113,13 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/include
+ )
+
+-include(CMakeExternal.txt)
+-enable_testing()
++#include(CMakeExternal.txt)
++#enable_testing()
+
+ add_subdirectory(src/core)
+ add_subdirectory(src/contrib)
+ #add_subdirectory(src/demo)
+-add_subdirectory(src/test)
++#add_subdirectory(src/test)
+
+ #################################
+ # install pkg-config file
diff --git a/dev-cpp/lucene++/files/lucene++-3.0.6-fix-installing-headers.patch b/dev-cpp/lucene++/files/lucene++-3.0.6-fix-installing-headers.patch
new file mode 100644
index 00000000000..f9ccc84eccd
--- /dev/null
+++ b/dev-cpp/lucene++/files/lucene++-3.0.6-fix-installing-headers.patch
@@ -0,0 +1,39 @@
+From: rezso <rezso@example.com>
+Date: Mon, 19 May 2014 09:20:40 +0100
+Subject: [PATCH] fix installing lucene++ headers in 3.0.6
+
+Origin: upstream, https://github.com/luceneplusplus/LucenePlusPlus/commit/994f03cf736229044a168835ae7387696041658f
+Description: backport upstream patch to fix missing headers install
+
+Index: lucene++-3.0.6/CMakeLists.txt
+===================================================================
+--- lucene++-3.0.6.orig/CMakeLists.txt
++++ lucene++-3.0.6/CMakeLists.txt
+@@ -139,6 +139,14 @@ if(NOT WIN32)
+ DESTINATION ${LIB_DESTINATION}/pkgconfig)
+ endif()
+
++#################################
++# install Config.h
++#################################
++install(
++ FILES
++ "${CMAKE_CURRENT_BINARY_DIR}/include/Config.h"
++ DESTINATION include/lucene++)
++
+ ####################################
+ # custom targets
+ ####################################
+Index: lucene++-3.0.6/src/core/CMakeLists.txt
+===================================================================
+--- lucene++-3.0.6.orig/src/core/CMakeLists.txt
++++ lucene++-3.0.6/src/core/CMakeLists.txt
+@@ -20,7 +20,7 @@ file(GLOB_RECURSE lucene_internal_header
+ )
+
+ file(GLOB_RECURSE lucene_headers
+- include/*.h
++ "${lucene++_SOURCE_DIR}/include/*.h"
+ )
+
+ add_definitions(-DLPP_BUILDING_LIB)
diff --git a/dev-cpp/lucene++/lucene++-3.0.6.ebuild b/dev-cpp/lucene++/lucene++-3.0.6.ebuild
new file mode 100644
index 00000000000..702ca21bca7
--- /dev/null
+++ b/dev-cpp/lucene++/lucene++-3.0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="LucenePlusPlus-rel_${PV}"
+inherit cmake-utils multilib
+
+DESCRIPTION="C++ port of Java Lucene library, a high-performance, full-featured text search engine"
+HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
+SRC_URI="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS README.rst )
+
+PATCHES=(
+ "${FILESDIR}/${P}-disable-demos.patch"
+ "${FILESDIR}/${P}-disable-tests.patch"
+ "${FILESDIR}/${P}-fix-installing-headers.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_DESTINATION=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/lucene++/lucene++-3.0.7.ebuild b/dev-cpp/lucene++/lucene++-3.0.7.ebuild
new file mode 100644
index 00000000000..3bb2bb8343b
--- /dev/null
+++ b/dev-cpp/lucene++/lucene++-3.0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="LucenePlusPlus-rel_${PV}"
+inherit cmake-utils multilib
+
+DESCRIPTION="C++ port of Java Lucene library, a high-performance, full-featured text search engine"
+HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
+SRC_URI="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS README.rst )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEMO=OFF
+ -DENABLE_TEST=OFF
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/lucene++/metadata.xml b/dev-cpp/lucene++/metadata.xml
new file mode 100644
index 00000000000..06ee9b592b0
--- /dev/null
+++ b/dev-cpp/lucene++/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>johu@gentoo.org</email>
+ <name>Johannes Huber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">luceneplusplus/luceneplusplus</remote-id>
+ </upstream>
+</pkgmetadata>
+