summaryrefslogtreecommitdiff
path: root/dev-cpp/waylandpp
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2017-08-21 22:55:55 -0400
committerCraig Andrews <candrews@gentoo.org>2017-08-22 16:01:45 -0400
commit8aefce0d6bf9f411298063a200654b39115500b3 (patch)
tree62391539a83d9c01ae619ecb83c0eb76b13cad5e /dev-cpp/waylandpp
parente55875404bfbf9b965d139e431fcc280532a3534 (diff)
downloadgentoo-8aefce0d6bf9f411298063a200654b39115500b3.tar.gz
gentoo-8aefce0d6bf9f411298063a200654b39115500b3.tar.xz
dev-cpp/waylandpp: Wayland C++ bindings
Gentoo-bug: 628562 Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: #5504
Diffstat (limited to 'dev-cpp/waylandpp')
-rw-r--r--dev-cpp/waylandpp/Manifest1
-rw-r--r--dev-cpp/waylandpp/metadata.xml12
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.1.0.ebuild51
-rw-r--r--dev-cpp/waylandpp/waylandpp-9999.ebuild51
4 files changed, 115 insertions, 0 deletions
diff --git a/dev-cpp/waylandpp/Manifest b/dev-cpp/waylandpp/Manifest
new file mode 100644
index 00000000000..49e18e0bbbb
--- /dev/null
+++ b/dev-cpp/waylandpp/Manifest
@@ -0,0 +1 @@
+DIST waylandpp-0.1.0.tar.gz 166427 SHA256 117df357cbd1f272737b6379e05925b38bad41bafda02761017530053fa950e7 SHA512 e0521ea99eeb7ae196ed9c8759e10d28406c5b99534b52ac51845cdd9c384ff820e4cc1fec65c537a0d071046746884793da122c72f6e75e7df4bca089d19eca WHIRLPOOL 1d589fbe1884dbd38547a0957b07533e3029cca7453618375227d87afa90fa36eded62283bf302139920860c90b250aeaca9b48e0f8098b0f9f8bbaffa889067
diff --git a/dev-cpp/waylandpp/metadata.xml b/dev-cpp/waylandpp/metadata.xml
new file mode 100644
index 00000000000..05f0a64835c
--- /dev/null
+++ b/dev-cpp/waylandpp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/NilsBrause/waylandpp/issues</bugs-to>
+ <remote-id type="github">NilsBrause/waylandpp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/waylandpp/waylandpp-0.1.0.ebuild b/dev-cpp/waylandpp/waylandpp-0.1.0.ebuild
new file mode 100644
index 00000000000..a85f301bf9f
--- /dev/null
+++ b/dev-cpp/waylandpp/waylandpp-0.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib scons-utils toolchain-funcs versionator
+
+DESCRIPTION="Wayland C++ bindings"
+HOMEPAGE="https://github.com/NilsBrause/waylandpp"
+
+LICENSE="MIT"
+IUSE="doc"
+SLOT="0/$(get_major_version)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/NilsBrause/waylandpp.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/waylandpp-${PV}"
+fi
+
+COMMON_DEPEND="
+ >=dev-libs/wayland-1.11.0
+ media-libs/mesa[wayland]
+"
+DEPEND="${COMMON_DEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ "
+RDEPEND="${COMMON_DEPEND}"
+
+src_compile() {
+ CC="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)" escons
+ if use doc; then
+ doxygen || die "error making docs"
+ fi
+}
+
+src_install() {
+ PREFIX="${D%/}/usr" scons install
+ # fix multilib-strict QA failures
+ mv "${ED%/}"/usr/{lib,$(get_libdir)} || die
+ if use doc; then
+ doman doc/man/man3/*.3
+ HTML_DOCS="doc/html" einstalldocs
+ fi
+}
diff --git a/dev-cpp/waylandpp/waylandpp-9999.ebuild b/dev-cpp/waylandpp/waylandpp-9999.ebuild
new file mode 100644
index 00000000000..a85f301bf9f
--- /dev/null
+++ b/dev-cpp/waylandpp/waylandpp-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib scons-utils toolchain-funcs versionator
+
+DESCRIPTION="Wayland C++ bindings"
+HOMEPAGE="https://github.com/NilsBrause/waylandpp"
+
+LICENSE="MIT"
+IUSE="doc"
+SLOT="0/$(get_major_version)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/NilsBrause/waylandpp.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/waylandpp-${PV}"
+fi
+
+COMMON_DEPEND="
+ >=dev-libs/wayland-1.11.0
+ media-libs/mesa[wayland]
+"
+DEPEND="${COMMON_DEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ "
+RDEPEND="${COMMON_DEPEND}"
+
+src_compile() {
+ CC="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)" escons
+ if use doc; then
+ doxygen || die "error making docs"
+ fi
+}
+
+src_install() {
+ PREFIX="${D%/}/usr" scons install
+ # fix multilib-strict QA failures
+ mv "${ED%/}"/usr/{lib,$(get_libdir)} || die
+ if use doc; then
+ doman doc/man/man3/*.3
+ HTML_DOCS="doc/html" einstalldocs
+ fi
+}