summaryrefslogtreecommitdiff
path: root/dev-cpp/websocketpp
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/websocketpp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/websocketpp')
-rw-r--r--dev-cpp/websocketpp/Manifest2
-rw-r--r--dev-cpp/websocketpp/metadata.xml15
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.4.0.ebuild35
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.5.0.ebuild35
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-cpp/websocketpp/Manifest b/dev-cpp/websocketpp/Manifest
new file mode 100644
index 00000000000..bc9886073a1
--- /dev/null
+++ b/dev-cpp/websocketpp/Manifest
@@ -0,0 +1,2 @@
+DIST websocketpp-0.4.0.tar.gz 628675 SHA256 8634b233c0c47afa6b76c4edcb9694de490b33950c549fd2531b312c18e8cfca SHA512 770560afca5f9c88454c1aec61e5c4dfd38b3835897a96c3815fe1232ba6ef7622d07530d644055e60089d5c6f8ab383691358abf2da5782515ad9f313f1d253 WHIRLPOOL 2fa0f3deabe6c7b5ae22ea5d4e2f90367a68b816cf4ffe81d61b7f9b85ef575c1cc1baadbf685e9c58ea3f442136c3d1128585e7244498b9def0484995015926
+DIST websocketpp-0.5.0.tar.gz 642592 SHA256 ab032d61f1d94fc4ebf3bb74297e520499d6fe56801084d3cc828455482e81d9 SHA512 8c254a3dc772fce31e4dff58e352d967d47d64cfb07dd93d1da7707f27c43760bf2c3d1e43b7669dad20b7986159185e5ba26d87e1716fb896be23173438c947 WHIRLPOOL 719921a8e804a382020d507ebe33bb5779191cc756b92cf9bd5a576370d4824100ddba556b96a3cbe88f9d701e28e6471727ad34f268805006f03ae3b99e39e0
diff --git a/dev-cpp/websocketpp/metadata.xml b/dev-cpp/websocketpp/metadata.xml
new file mode 100644
index 00000000000..3268b5e9450
--- /dev/null
+++ b/dev-cpp/websocketpp/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>johu@gentoo.org</email>
+ <name>Johannes Huber</name>
+ </maintainer>
+ <use>
+ <flag name="boost">Use <pkg>dev-libs/boost</pkg> instead of C++11</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">zaphoyd/websocketpp</remote-id>
+ </upstream>
+</pkgmetadata>
+
diff --git a/dev-cpp/websocketpp/websocketpp-0.4.0.ebuild b/dev-cpp/websocketpp/websocketpp-0.4.0.ebuild
new file mode 100644
index 00000000000..bca41a7d042
--- /dev/null
+++ b/dev-cpp/websocketpp/websocketpp-0.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="C++/Boost Asio based websocket client/server library"
+HOMEPAGE="http://www.zaphoyd.com/websocketpp"
+SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+IUSE="boost test"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ boost? ( dev-libs/boost )
+"
+
+# tests no-op
+RESTRICT="test"
+
+src_configure() {
+ # Disable EXAMPLES as compilation is broken upstream
+ local mycmakeargs=(
+ -DEXAMPLES=OFF
+ $(cmake-utils_use_enable !boost CPP11)
+ $(cmake-utils_use_enable test)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/websocketpp/websocketpp-0.5.0.ebuild b/dev-cpp/websocketpp/websocketpp-0.5.0.ebuild
new file mode 100644
index 00000000000..6d334bd4909
--- /dev/null
+++ b/dev-cpp/websocketpp/websocketpp-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="C++/Boost Asio based websocket client/server library"
+HOMEPAGE="http://www.zaphoyd.com/websocketpp"
+SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+IUSE="boost test"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ boost? ( dev-libs/boost )
+"
+
+# tests no-op
+RESTRICT="test"
+
+src_configure() {
+ # Disable EXAMPLES as compilation is broken upstream
+ local mycmakeargs=(
+ -DEXAMPLES=OFF
+ $(cmake-utils_use_enable !boost CPP11)
+ $(cmake-utils_use_enable test TESTS)
+ )
+
+ cmake-utils_src_configure
+}